These are chat archives for highfidelity/hifi

14th
Jun 2017
Midnight
@MidnightRift
Jun 14 2017 21:26
with the latest build of Hifi is it now a requirement the server compile QtWebengine ?

CMake Error at /lib64/cmake/Qt5/Qt5Config.cmake:26 (find_package):
  Could not find a package configuration file provided by "Qt5WebEngine" with
  any of the following names:

    Qt5WebEngineConfig.cmake
    qt5webengine-config.cmake
Bradley Austin Davis
@jherico
Jun 14 2017 21:49
WebEngine has been a dependency for quite a while now.
I believe it should NOT be a dependency if you're only building the server components
if you're running cmake with -DSERVER_ONLY=1 and you're still getting that message, then let me know.
Midnight
@MidnightRift
Jun 14 2017 21:55
that is in the commands the tool im maintaining runs here is one of the lines from it.
RELEASE_TYPE=PRODUCTION RELEASE_NUMBER=$(echo $LATEST | cut -d'-' -f2) cmake3 -DSERVER_ONLY=TRUE -DDCMAKE_BUILD_TYPE=Release $HIFIBASEDIR/source