These are chat archives for highfidelity/hifi

25th
Sep 2017
Matti Lahtinen
@Menithal
Sep 25 2017 19:53

I am trying to figure out a bit more on getProceduralColors, shouldn't returned 0.0-1.0 float be the emit override any lighting on the entity with the shader?

I don't seem to be able to produce a situation where a shader is fully bright (as if a lightsource), and ignoring its environment, but it is always affected by the lighting around it.

Matti Lahtinen
@Menithal
Sep 25 2017 19:59
Forexample, setting my sprite sheet shader to emit, (which just makes the value returned to 1.0 doesnt seem to have the shader "emit" like an "emit" texture would.
Matti Lahtinen
@Menithal
Sep 25 2017 20:08
Even just doing a procedural shader that sets solid values seems to completely skip the emit
Matti Lahtinen
@Menithal
Sep 25 2017 20:40
Hmm, I think I found a bug, will be submitting a PR on it after I check if it was the cause
Matti Lahtinen
@Menithal
Sep 25 2017 21:27
@samcake you might find this fix of interest highfidelity/hifi#11453
Mohammed Nafees
@mnafees
Sep 25 2017 22:12
Hey, can someone test highfidelity/hifi#11412 please? Thank you :)
Matti Lahtinen
@Menithal
Sep 25 2017 22:30
Its not labeled as QA Ready and has a Merge conflict.
Also QA testers -> on Slack not on here
@mnafees see above.
Sam Gateau
@samcake
Sep 25 2017 22:37
@Menithal I won;t let you down
i know i how it to you
Matti Lahtinen
@Menithal
Sep 25 2017 22:38
@samcake that one is another new shader fix that is :D
not related to metallicness
Sam Gateau
@samcake
Sep 25 2017 22:42
ok got it :)