Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
  • 11:09
    wesparish edited #295
  • 11:08
    wesparish opened #295
  • 00:41
    Zerobian opened #294
  • Sep 23 21:17
    ElPiloto opened #293
  • Sep 23 12:54
    mad73923 edited #292
  • Sep 23 12:52
    mad73923 opened #292
  • Sep 22 17:48
    mcclurec opened #291
  • Sep 22 16:37
    mad73923 opened #290
  • Sep 22 11:31
    MephistoJB opened #289
  • Sep 21 22:22
    BornToBeRoot edited #288
  • Sep 21 22:18
    BornToBeRoot opened #288
  • Sep 21 20:25
    bastienwirtz labeled #270
  • Sep 21 20:22
    bastienwirtz labeled #286
  • Sep 21 20:18
    bastienwirtz labeled #287
  • Sep 19 15:30
    robinschneider opened #287
  • Sep 16 22:18
    neographophobic closed #285
  • Sep 16 10:57
    fitur opened #286
  • Sep 15 07:40
    bastienwirtz closed #243
  • Sep 15 02:33
    neographophobic opened #285
  • Sep 14 20:44
    waschinski synchronize #243
Simon Drake
Specifically highlight-primary and highlight-secondary
Agneev Mukherjee
How do I insert an iframe?
I run Homer via docker on a few systems and it works well. But the dynamic message thing does not work for me with a local server. The Chuck Norris example works. The local Server returns correct JSON, and it is reachable from within the Homer docker container, verified by ping from a shell inside the docker container. What else could be wrong?
hey all, i was wondering if theres a way to add multiple subtitle rows to the cards? In this case I want to have a line below each name showing the IP address of the device/app etc, and then another row below that with the function (which is what im currently using the subtitle row for)
thanks :)
1 reply
How can I force Homer to open link in new tab?
@brain-d - Under the URL, add a line like this: target: "_blank"
@djbr22 You're the best!
hello, is anyone that can help me? i just want to do a hover text on links in the nav bar
Peter Pagio

Having trouble getting homer to work through docker.

root@superstore:~# docker volume create homer
root@superstore:~# docker inspect homer
"CreatedAt": "2021-08-27T06:48:27-05:00",
"Driver": "local",
"Labels": {},
"Mountpoint": "/var/lib/docker/volumes/homer/_data",
"Name": "homer",
"Options": {},
"Scope": "local"
root@superstore:~# docker run -d -v homer:/www/assets -p 8081:8081 --restart=always b4bz/homer:latest
root@superstore:~# docker inspect homer
"CreatedAt": "2021-08-27T06:48:39-05:00",
"Driver": "local",
"Labels": {},
"Mountpoint": "/var/lib/docker/volumes/homer/_data",
"Name": "homer",
"Options": {},
"Scope": "local"

Do I need to an HTTP server to host the files still or was that included in the docker image?
Curious to know if there is a way to add spacing between the rows?
1 reply

I was hoping someone could help me here:

I'm trying to spin up Homer as a Dashboard for all the different self hosted services on my domain. I recently started migrating all my services to Docker and Traefik, so I'm trying to set Homer on my docker-compose file. Every time I spin it up and go to its domain, it loads infinitely until it gives me a "Gateway Timeout" though. And I'm not really sure how I'm supposed to debug the issue, as there's nothing on the docker logs that I can see.

My docker-compose file looks like this (trimmed for just the homer part):

  # Homer
    image: b4bz/homer:latest
      - traefik.http.routers.homer.rule=Host(`dashboard.{domain}.pt`)
      - traefik.http.middlewares.homer_https.redirectscheme.scheme=https
      - traefik.http.routers.homer.middlewares=homer_https@docker
      - traefik.http.routers.homer_https.rule=Host(`dashboard.{domain}.pt`)
      - traefik.http.routers.homer_https.tls=true
      - traefik.http.routers.homer_https.entrypoints=websecure
      - /home/debian/homer/assets:/www/assets
    restart: unless-stopped

And my config.yml (inside the homer/assets folder) is this:

title: "My Dashboard"
subtitle: "Homer"
logo: "assets/logo.png"
header: true # Set to false to hide the header
footer: '<p>Created with <span class="has-text-danger">❤️</span> with <a href="https://bulma.io/">bulma</a>, <a href="https://vuejs.org/">vuejs</a> & <a href="https://fontawesome.com/">font awesome</a> // Fork me on <a href="https://github.com/bastienwirtz/homer"><i class="fab fa-github-alt"></i></a></p>' # set false if you want to hide it.

columns: "2" # "auto" or number (must be a factor of 12: 1, 2, 3, 4, 6, 12)
connectivityCheck: false # whether you want to display a message when the apps are not accessible anymore (VPN disconnected for example)

theme: default # 'default' or one of the themes available in 'src/assets/themes'.

  - name: "Websites"
    icon: "fas fa-code-branch"
    # A path to an image can also be provided. Note that icon take precedence if both icon and logo are set.
    # logo: "path/to/logo"
      - name: "{domain}.pt"
        logo: "assets/tools/sample.png"
        # Alternatively a fa icon can be provided:
        # icon: "fab fa-jenkins"
        subtitle: "My Personal Website"
        tag: "website"
        url: "https://{domain}.pt"
        target: "_blank" # optional html tag target attribute
  - name: "Services"
    icon: "fas fa-heartbeat"
      - name: "Radicale"
        logo: "assets/tools/sample.png"
        subtitle: "My CALDav Server"
        tag: "service"
        url: "https://radicale.{domain}.pt"
        target: "_blank"

I can access the dasboard.{domain}.pt URL, and see that HTTPS certificate is correctly set for that subdomain. Additionally, I can see the /homer/assets folder being filled up with the default files. I just can't seem to access it. It is very similar to how my other services are already set up using traefik, so I don't know what gives :/

Anyone have any idea? Or could guide me on how I can debug this properly?


Mark Constable
Super simple newbie question. What version of Vue is being used? Is it Vue3 or Vue2?
Bastien Wirtz
Hi there :wave:
@markc It's vue2, but I plan to rebuild it with vue3 at some point
Hey there :)
Just wanted to share that I love Homer, and I made a container that integrates with the message feature https://github.com/quietsy/homer-status
Bastien Wirtz
Nice ! Thanks @quietsy1:matrix.org !!
Peter Olausson
Hi, are there any color attributes which are not in the regular configuration.yml?
Like for instance, text outline, text shadow, etc.
Hey there, experiencing some weirdness from a docker container on unraid server. Wrote a post with some screenshots here: https://forums.unraid.net/topic/89502-support-a75g-repo/?do=findComment&comment=1034728
Any insight would be appreciated
not sure what would cause all the hosts to keep submitting a get request
and then it replied with a POST request for something that isnt even related, a completely different plugin on the server
hmmm changed the port from 80 to 8080 and it stopped. i guess clients are pinging it because they are expecting something else. alright... if this doesnt sound right to you, please let me know. I'll idle here a bit
I have looked over the config files and docs but I am having issues getting homer to set as my homepage for SWAG I followed their steps and can get heimdall to work but it is like something is missing on the homer side...
Would there be a possibility to replace the "message" config with something else like Tabs?
2 replies
I'm sorry if this is a dumb question but is it possible to run homer on my wrodpress site and use it to access my services I have set up with nginx proxy manager?
Is anyone else able to get the Sonarr/Radarr/PiHole integration going? Given I have issues in all 3 I freely admit I'm doing something wrong, just don't see what. My Radarr tab shows a red ?, Sonarr shows nothing, and Pihole shows nothing. I would think I'd see a lot more, like Pihole stats and R/S details or errors/alerts, yes?
  • name: "Pi-hole"
      logo: "assets/tools/pihole.png"
      # subtitle: "Network-wide Ad Blocking" # optional, if no subtitle is defined, PiHole statistics will be shown
      url: ""
      type: "PiHole".   ....having the port in there shouldn't cause any issue, right? 
Bastien Wirtz
Hey @dclive do you have any error in the web console ? It's probably a CORS issue, it happens when homer and the service (pi-hole, Sonarr) are not on the same domain. You have to set something like Access-Control-Allow-Origin: * in the service headers (if you use a proxy, it should be simple). I have to add some documentation about that.
3 replies
Where would I look in the web console? (Which web console?). Homer is in a docker image on a PC, Sonarr is native on the PC, Radarr is native on the PC, and pihole is on a raspi, native.
Bastien Wirtz
the browser console (usually activated with ctrl+shit+i or F12).
Raphael Sabbat
how do i stop config files from regenerating after every restart?
Im using docker compose
and every restart just puts me back to demo page
Bastien Wirtz
@raphsabb_twitter Hi :wave: The demo config is installed only if the config.yml is not found. Otherwise nothing should be regenerated
Raphael Sabbat
@bastienwirtz i have a config.yml file with plenty of modifications, but it doesnt pick it up for some reason and just shiws the demo stuff.
Was trying it out quickly before I add to my stack so would love to figure out what the issue is
@raphsabb_twitter How does the volumes: section of your docker-compose.yml file look like? Make sure that your physical assets directory is connected properly.
Raphael Sabbat
@fjmavea i have it as /home/user/containers/homer:/www/assets
and when I delete the config.yml.dist file, it comes back in there after a reboot
The Doctor
Hi. I noticed something weird when trying to load my Homer startpage in Seamonkey while experimenting with other browsers this afternoon:
I have my Homer page behind HTTP basic auth, which I've been using for a couple of months now. And it works as expected. However, when I load my startpage in Seamonkey I get the "You're offline, friend" error.
When I open the browser console, it looks like /assets/config.yml gets an HTTP 401 error from the server. Which is weird because I'm already logged in. I went spelunking in the Homer bug tickets and found a few instances of folks getting the "You're offline" error, but nothing about Homer not being able to pull config.yml.
Loading the page in Firefox (per usual) I don't see any such error messages.
The Doctor
Weirdly, if I serve the copy of Homer I have on my laptop (I build from source) with Python's http.server module, it loads right up as expected.
Has anyone seen something similar?
The Doctor
Another data point: A HEAD /?alive HTTP request gets a 401, also. At pretty much the same time.
Same result if I access that URI manually.
If I try to access my /assets/config.yml file directly in my browser, it works. I'm prompted for what to do (default - gvim).
Raphael Sabbat
ok guys, brave is the culprit in my case, for some reason its not updating content when I make changes. I almost lost my beard trying to figure out what could be wrong