by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Alexandre Nizoux
@deurk
Anyone able to help ?
Anton Myrberg
@AntonMyr
@deurk is there any errors or it just doesn't work?
Are you sure that the emit_events and no_merge should be true?
Alexandre Nizoux
@deurk
It doesn't work as in it doesn't validate the post action as the same as the curl
yes, emit_events has to be true since I want to parse the returned html, and no_merge has to be true as payload is a string
it feels to me as if the payload somehow goes through some transformation to be sent
is there any way for me to see the actual complete payload sent?
and headers and such?
Anton Myrberg
@AntonMyr
The only way I can think of (I'm new to Huginn tho) is to log what gets sent inside the code
So in the post agent code you can log the payload
I don't know how familiar you are with coding but that's a viable option.
Alexandre Nizoux
@deurk
hmm, I'll try that, and I'll parse the code of the PostAgent to see if something happens to the payload on the way
I'm pretty sure it's very close to working, just a matter of formatting that payload
I tried with payload as an array with condition and nextButton in it, but same result (403 from destination)
Anton Myrberg
@AntonMyr
Hmm so you got 403 from the website you linked earlier?
Alexandre Nizoux
@deurk
yes only with postagent
curl or manual owrks
Anton Myrberg
@AntonMyr
I tried your configuration on Post Agent and I think I got status 200
Alexandre Nizoux
@deurk
oh really? Oo
interesting
Alexandre Nizoux
@deurk
well, I think that my host is on blocked subnet then :(
that would explain why it won't work anyway
Anton Myrberg
@AntonMyr
Hope you figure it out!
The Doctor
@virtadpt
Try proxying through something, like a search engine direct request? Or change the user-agent string for that Website Agent?
malcmail
@malcmail
Hey guys. Not sure if this is the right place to ask what I suspect is an easy question for those in the know. JUst installed the repo with a view to using it to watch for changes on webpages. But having a struggle working out what to put where in the website agent. Managed the URL but looking to monitor the bulk of the page for changes. This is way out of my usual comfort zone so be gentle ...please :)
willwrong
@willwrong
image.png
Hi guys. Having a good time with Huginn lately but struggling with the IMAP agent. It scans alright and sees how many emails are in the folder, but doesn't seem to pick anything up based on the Conditions (per this one, looking for any containing the word "call" in the subject). I've tried with case sensitive/insensitive tags. Any ideas? Thanks in advance!
willwrong
@willwrong
Figured it out... needed correct Regex syntax. Disregard!
Gideon Wolfe
@GideonWolfe
So I am having an issue where thousands of events are stacking up and failing because "Run Agent Schedule" and "Run Event Propogation" are hanging without doing anything
I've had glitches where a single formatting agent stopped the entire pipeline, but it seems like now it isnt even running the agentsa
The Doctor
@virtadpt
Are you running in Docker, in production, or some other way?
Have to ask, sorry about this: Have you restarted the scheduler?
delayed_job workers or threaded worker?
Database locally or hosted on another box?
matrixbot
@matrixbot
k0b0 @Flame you would have to write your own agent to process Facebook pages. If you are after Facebook posts, you could use rss-bridge to convert them to rss/json output which you could use in Huggin.
Anton Myrberg
@AntonMyr
Are there any guidelines regarding opening a pr for a new agent?
malcmail
@malcmail
Has anyone managed to get an agent to post to a channel in Microsoft Teams? Managed to get Slack going but no joy with Teams.
The Doctor
@virtadpt
Can't say I've tried yet. Sorry.
James Deaton
@okjed
Anyone aware of a place with some good examples of using the javascript agent? I'm trying to loop through an API request that is limited to a small number of responses per query and need to generate a series of offsets. I assume using the javascript agent is the best option.
The Doctor
@virtadpt
Off the top of my head, no. Admittedly, I don't know anything about JS.
James Deaton
@okjed
Thanks, I'm realizing that I may be stuck unless I craft a new agent. I do have another question, I have a number coming in from an API request that I'd like to format as a currency/money via liquid. In my tests, it looks like those filters aren't implemented/available? Or am I missing something.
The Doctor
@virtadpt
Hmmm...
Depending on what you want to do, you can go pretty far with just the round Liquid tag. Unless you want to do something more complex?
or schapira
@schapira_gitlab
hi, is there a way to automate telegram group images save to some cloud service?
Srinivasan Iyer
@sriniiyer
is there a way to ask the WebsiteAgent to wait for the page to finish loading?
Jimmy B.
@jimmybrancaccio
So I have an external MySQL container I am using, is the local MySQL service necessary in the Huginn docker container and if not, how to disable?
malcmail
@malcmail
Been plugging away trying to improve my knowledge on this. From a particular site I managed to get ""date": "<td>10/07/2020</td>\n"," using the css "//table[@class='decisionrepeater']/tr/td[1]". Is ther eany way to strip out the tags etc and just leave the date? CAn I do this in the website agent or do I need to use another process before posting the result elsewhere? Thanks.
malcmail
@malcmail
Also wonderign how I can extract the number after RowOnClick in this "</tr><tr onmouseover="this.tmp = this.style.backgroundColor; this.style.backgroundColor='#cccccc'" onmouseout="this.style.backgroundColor = '#ffffff'" onclick="RowOnClick('11735');" style="cursor: pointer;">". I've tried substring but can't get it to work at all probably as I've little idea s to what I'm doing as you can likely tell!)
Jimmy B.
@jimmybrancaccio
Any ideas on how to get Huginn to not start it's internal MySQL process, as I assume it's not needed if using an external MySQL DB?
danquach
@danquach_twitter

I'm deploying huginn with this

version: '2'
services:
  huginn: 
    container_name: huginn
    networks:
        - main
    image: huginn/huginn-single-process
    restart: always
    env_file:
      - ./huginn/mysql.env
      - ./huginn/secrets.env    
  threaded:
    image: huginn/huginn-single-process
    networks:
        - main
    command: /scripts/init bin/threaded.rb
    restart: always
    env_file:
      - ./huginn/mysql.env
      - ./huginn/secrets.env
    depends_on:      
      - huginn
networks:
  main:
    driver: bridge

Every morning at 8am pst tons of resources seems to get used, I logged into the docker images but can't seem to find the logs. What directory is it in?

danquach
@danquach_twitter
Actually nevermind, I checked the logs and it logs to /dev/stdout which can be grabbed through docker logs CONTAINER_ID

For all of my agents, I run them at 2am in the middle of the night, but I am noticing in the AgentRunScheduleJob enqueueing things at weird times

[ActiveJob] Enqueued AgentRunScheduleJob (Job ID: 7ca30795-a1b8-41ac-9d2f-b705d20e74b4) to DelayedJob(default) with arguments: "every_2h"
Queuing schedule for 8am
[ActiveJob] Enqueued AgentRunScheduleJob (Job ID: 746f2601-d8f8-4119-abcc-666bad62678a) to DelayedJob(default) with arguments: "8am"
2020-07-21T08:00:08-0700: [Worker(host:c7f63f9e7430 pid:1)] Job AgentRunScheduleJob [3b67878b-557f-413f-8788-d19cc9d43575] from DelayedJob(default) with arguments: ["every_10m"] (id=277248) (queue=default) RUNNING
[ActiveJob] [AgentRunScheduleJob] [3b67878b-557f-413f-8788-d19cc9d43575] Performing AgentRunScheduleJob (Job ID: 3b67878b-557f-413f-8788-d19cc9d43575) from DelayedJob(default) enqueued at 2020-07-21T15:00:02Z with arguments: "every_10m"
[ActiveJob] [AgentRunScheduleJob] [3b67878b-557f-413f-8788-d19cc9d43575] Performed AgentRunScheduleJob (Job ID: 3b67878b-557f-413f-8788-d19cc9d43575) from DelayedJob(default) in 0.96ms
2020-07-21T08:00:08-0700: [Worker(host:c7f63f9e7430 pid:1)] Job AgentRunScheduleJob [3b67878b-557f-413f-8788-d19cc9d43575] from DelayedJob(default) with arguments: ["every_10m"] (id=277248) (queue=default) COMPLETED after 0.0088
2020-07-21T08:00:08-0700: [Worker(host:c7f63f9e7430 pid:1)] Job AgentRunScheduleJob [6560c76b-9d46-4dcd-af29-e5bcfc946955] from DelayedJob(default) with arguments: ["every_30m"] (id=277249) (queue=default) RUNNING
[ActiveJob] [AgentRunScheduleJob] [6560c76b-9d46-4dcd-af29-e5bcfc946955] Performing AgentRunScheduleJob (Job ID: 6560c76b-9d46-4dcd-af29-e5bcfc946955) from DelayedJob(default) enqueued at 2020-07-21T15:00:02Z with arguments: "every_30m"
[ActiveJob] [AgentRunScheduleJob] [6560c76b-9d46-4dcd-af29-e5bcfc946955] Performed AgentRunScheduleJob (Job ID: 6560c76b-9d46-4dcd-af29-e5bcfc946955) from DelayedJob(default) in 1.23ms
2020-07-21T08:00:08-0700: [Worker(host:c7f63f9e7430 pid:1)] Job AgentRunScheduleJob [6560c76b-9d46-4dcd-af29-e5bcfc946
955] from DelayedJob(default) with arguments: ["every_30m"] (id=277249) (queue=default) COMPLETED after 0.0141
2020-07-21T08:00:08-0700: [Worker(host:c7f63f9e7430 pid:1)] Job AgentRunScheduleJob [4b89e30f-8ec6-4064-8e60-a97c5abe232f] from DelayedJob(default) with arguments: ["every_1h"] (id=277250) (queue=default) RUNNING
[ActiveJob] [AgentRunScheduleJob] [4b89e30f-8ec6-4064-8e60-a97c5abe232f] Performing AgentRunScheduleJob (Job ID: 4b89e30f-8ec6-4064-8e60-a97c5abe232f) from DelayedJob(default) enqueued at 2020-07-21T15:00:02Z with arguments: "every_1h"
[ActiveJob] [AgentRunScheduleJob] [4b89e30f-8ec6-4064-8e60-a97c5abe232f] Performed AgentRunScheduleJob (Job ID: 4b89e30f-8ec6-4064-8e60-a97c5abe232f) from DelayedJob(default) in 2.41ms

Is there any reason why things are being queued at times what I didn't specify in the UI, and why other things are appearing like every_1h, etc?

In my agents, I don't have anything set with args of every_Xm