Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
Repo info
    Michael A. Ventarola
    How do I make Hypriot OS network boot?
    Johan Pramming
    There is, although confusingly enough named pi3.
    Add the following to /boot/config.txt and reboot to disable wifi and bluetooth:
    Luís Sousa
    @rbartoli , does those files, /user-data and /network-config placed on root, overwrite the default ones, /boot/user-data and /boot/network-config?
    I only add luck changing parameters on file /boot/user-data and running afterwards cloud-init clean --reboot. What am I doing wrong?
    Anders Björklund
    Did someone make an amd64 image?
    As a boot2docker alternative I mean
    Luis Fernandes
    did you manage to have an amd64 image? or do we need to manually build it out of raspbian 64bits?
    what are the issues with using an amd64 image right now ?
    I'm assuming all 32bit containers won't work, which is 80% of my images...
    Anders Björklund
    Are you mixing up amd64 with arm64 perhaps ? I meant x86_64
    Luis Fernandes
    oops, yes I wanted to say arm64 and wrote amd64 lol
    hello, we want to use hypriot as access point, we install and configure dnsmasq hostapd , and every thing seems ok, waln0: AP-ENABLED
    but the access point does not appear in the list of accesspoint or in sudo iwlist wlan0 scan
    it is with an rapsberry pi 0 with hypriot uname -r 4.14.34hypriotos+
    Alan Ionita

    Hey folks,

    Has this happen recently with a fresh install of Hypriot: seems like the hostname is not detected locally offline when connected to a MBP via ethernet. Raspbian hostname can be found just fine in the same conditions.

    Internet sharing options are actually turned off with the above, but if I allow internet sharing I can see the Hypriot hostname.

    I'm thinking this might be a bug. Really I would expect the Hypriot hostname to be found locally, so I can orchestrate some distro harderning tasks before I open it up to the world.

    Anyone else notice this?

    Eko Saleh
    Hello everybody: i have installed om micro sd card the RPI/HypruitOS latest image. I am loged in as the user pirate. To check whether the Docker system run correctly i like to start the browser. Can you tell me what is the correct command line to use to start the browser?. Kind regards.\
    Hans Donner
    HI, anybody got seedfrom: http://<whaterver>working on pi? (part of no cloud datasource, so it can fetch meta-data and user-data from <whatever>). On PI I can see it tries to fetch it, but as eth0 has no ip yet, it is not able to reach the remote server. (normally cloud init should wait for network being up, but fails in this case)
    Eduardo Maia
    Hello guys. I flashed my SD with pretty standard user-data as I see in the examples, but when I try to scale one (swarm) service up, I keep getting "1/1: network sandbox join failed: subnet sandbox join failed for "":…". Does anyone have any idea?
    Eduardo Maia
    HypriotOS/armv7: pirate@black-pearl in ~
    $ uname -a
    Linux black-pearl 4.19.118-v7+ #1311 SMP Mon Apr 27 14:21:24 BST 2020 armv7l GNU/Linux
    HypriotOS/armv7: pirate@black-pearl in ~
    $ cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
    NAME="Raspbian GNU/Linux"
    VERSION="10 (buster)"
    HYPRIOT_DEVICE="Raspberry Pi"
    HypriotOS/armv7: pirate@black-pearl in ~
    $ docker info
     Debug Mode: false
     Containers: 0
      Running: 0
      Paused: 0
      Stopped: 0
     Images: 2
     Server Version: 19.03.12
     Storage Driver: overlay2
      Backing Filesystem: extfs
      Supports d_type: true
      Native Overlay Diff: true
     Logging Driver: json-file
     Cgroup Driver: cgroupfs
      Volume: local
      Network: bridge host ipvlan macvlan null overlay
      Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
     Swarm: active
      NodeID: ms4b648fk0ivyk2qn8yfkepgq
      Is Manager: true
      ClusterID: w2zjwc9av2lr3f204xda2zpgq
      Managers: 1
      Nodes: 1
      Default Address Pool:
      SubnetSize: 24
      Data Path Port: 4789
       Task History Retention Limit: 5
       Snapshot Interval: 10000
       Number of Old Snapshots to Retain: 0
       Heartbeat Tick: 1
       Election Tick: 10
       Heartbeat Period: 5 seconds
      CA Configuration:
       Expiry Duration: 3 months
       Force Rotate: 0
      Autolock Managers: false
      Root Rotation In Progress: false
      Node Address:
      Manager Addresses:
     Runtimes: runc
     Default Runtime: runc
     Init Binary: docker-init
     containerd version: 7ad184331fa3e55e52b890ea95e65ba581ae3429
     runc version: dc9208a3303feef5b3839f4323d9beb36df0a9dd
     init version: fec3683
     Security Options:
       Profile: default
     Kernel Version: 4.19.118-v7+
     Operating System: Raspbian GNU/Linux 10 (buster)
     OSType: linux
     Architecture: armv7l
     CPUs: 4
     Total Memory: 975.6MiB
     Name: black-pearl
     Docker Root Dir: /var/lib/docker
     Debug Mode: false
     Registry: https://index.docker.io/v1/
     Experimental: true
     Insecure Registries:
     Live Restore Enabled: false
    WARNING: No swap limit support
    WARNING: No cpu cfs quota support
    WARNING: No cpu cfs period support
    Eduardo Maia
    Testing locally in my OSX seems to be running fine, the problem is only in my Raspberry Pi 3B
    Eduardo Maia
    This only seems to work after a full re-install of Docker CE.
    Eduardo Maia
    Reflashed everything, after a few restarts, everything seems to be working fine. This is so frustrating :joy:
    The image-rpi-builder is broken because of a sub-dependency. You can't build images in any of the latest releases :cry:
    Asterion Daedalus
    I have been running hypriot for months and love it! However, this morning I am docker is no longer running. I am getting docker.service - Docker Application Container Engine
    Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Thu 2019-02-14 10:25:05 UTC; 13s ago
    Docs: https://docs.docker.com
    Process: 727 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
    Main PID: 727 (code=exited, status=1/FAILURE)
    I cannot otherwise restart docker.
    Manav Sethi
    Hi folks first of all thanks for developing this great operating system
    I tried this on my new raspi 4 4gb but this gets stuck on the rainbow screen
    I remember something similar to this on github , is this a known problem ?
    Asterion Daedalus
    A little digging and I discovered why the docker daemon won't start, nor can I run apt or apt-get, nor can I connect from a PC using VSCODE embedded (since it tries to save sessions on the RPi). This is because my RPi running Hypriot is reporting no space available. I tried resizing using resize2fs but it won't resize mmcblk0p1 boot since its FAT and it would not resize mmcblk0p2 since it felt it was good enough. I snuck on and deleted my homeassistant log and got 1% of my 6.9G /dev/root back and got docker up again. I cleaned out a install of snap that I played with but was not using and got back 3% of /dev/root in all of 8G SD. So, it seems 8G is tight to run Hypriot and a combination of node-red, emqx, deCONZ and homeassistant. Especially if logs creep up. I will have to look at getting a larger SD card and setting up to clear logs and other chattel more regularly. Now, if I took notice of the help file it said 16G as a minimum ... DOH! RTFM is not my strong point LOL.
    Asterion Daedalus
    Okay, so who's being funny? I got myself a 32G SD card and used "flash --userdata setup.yml hypriotos-rpi-v1.12.3.img.zip" from my AMD64 Debian box. The setup.yml file was based upon the static.yml example at github and I had a static IP set to . Everything seemed to run fine and I booted the RPI3+ but found it at! When I opened up /etc/dhcpcd.conf on the RPI the IP address in that file was certainly set to Not a problem when using black-pearl.local but I am having to use raw IP on occasion and have set up my IP map for the Hypriot based home server at This is a fresh install so what is likely the problem please?
    Tigran Tch
    hello, is this project still maintained actively ?
    Asterion Daedalus
    @NargiT I have just downloaded the latest image dated 02.07.2020 so that suggests yes the project is still up. The blog pages seem not to be updated as often.
    Asterion Daedalus
    So, looks like there is a problem with the use of flash and setting static IP in Hypriot-1.12.3 that also seems to have been reported against earlier versions. Currently I am using flash 2.4 so I will update to flash 2.7 to see if there was magic missing from 2.4. Otherwise, I note a ramble of confused messages on the problem in the git issues that does not really definitively provided a solution, including someone recommending the use of the example static.yml file which means people are missing the point that the flash using the static.yml is how we are coming across the problem.
    Asterion Daedalus
    Okay so updated to flash 2.7 and nope, the RPi still ignores the static config and runs under DHCP.
    Hi folks, I am trying to create NFS Volumes with Docker, for storing the Data of my nextcloud container. I made an "sudo apt-get install nfs-common" to install the needed NFS Services as in https://www.portainer.io/2018/07/use-nfs-docker-local%E2%80%8B-volume-driver-portainer-io/ described. But I didn't find any NFS option under the "Volumes" tab in my Portainer installation. Even after rebooting there in no entry. Could you tell me how to use NFS mounts for Volumes with the Hypriot-OS? Using version v1.12.3
    Tigran Tch
    thx @Bazmundi, but I will give a shot to https://github.com/rancher/k3os, because I need to reduce manually operations and scale easily when I have new pi's
    Chris Love
    I can confirm the same issues trying to use flash and configure a static IP. The /etc/dhcpcd.conf is getting written correctly but is getting ignored. Doing an apt-get upgrade there is a newer version of cloud-init, but that didn't resolve anything.
    Asterion Daedalus
    I am looking at running a clusterHAT on top of a RPi 3+ running hypriot (https://clusterhat.com/setup-overview). Install for clusterctl manually at https://8086.support/?action=faq&cat=23&id=120&artlang=en and found when I ran "clusterctl status" it reports a python package smbus missing. So I found a hint at how to install that at https://skpang.co.uk/blog/archives/575 which I find some of the steps I can skip because hypriot does not blacklist i2c as a starting position and i2c-dev is already mentioned in /etc/modules. So I installed i2c-tools, added user pirate to i2c group etc. I though that I was then ready to look at installing python-smbus BUT a test of sudo i2cdetect -y 1 leads me to believe that i2c has not been set up properly the way that I have attempted since I get an empty table displayed. Since I did naught other than add pirate to i2c group and install i2c-tools I am not sure what why i2cdetect is not seeing anything and reporting an empty table. I have rebooted my RPi etc., post setting up pirate in i2c group, so not sure what I need do get an I2C channel displayed by i2cdetect on this config. Because the i2c seemed already to be setup, why would it not be detected by i2cdetect?
    Asterion Daedalus
    i2cdetect -F 1 happily lists /dev/i2c-1 functions. I have no clusterHAT installed physically and so nothing on any i2c channel, which I assume accounts for nothing in table when using i2cdetect -y 1? Sorry, my first time through i2c setup on RPi/Hypriot etc.
    Michael A Cooper
    Hey Guys, New to talking here in the community. Has anyone tried the new portainer 2 on the latest hypriot os
    Ryder Saint

    Great new release. I guess it's not 64 bits. Why this lack of 64 bits OS for rPI4?

    I know this was discuss before, is there any update I have missed?
    Would like to use ARM64 or arm8.
    Could some please provide some advise

    Georg Krause
    @rydersaint i came here for the same question: D
    Henrik F
    did anyone try autologin on raspberry with hyriot? i have the option in raspi-config but i wont work :/
    Al West
    Hi - I am trying to configure local ntp server but my install seems to be ignoring /etc/ntp.conf
    Al West

    Hi - I am trying to configure local ntp server but my install seems to be ignoring /etc/ntp.conf

    I found the issue - dhclient was generating the ntp.conf from dhcp setting

    Michael Cooper
    Can anyone tell me why Hypriot won't let me change the hostname at all. I have tried editing /etc/hostname, I have tried raspi-config, I have tried hostnamectl set-hostname, and I have tried editing the nano -c /boot/user-data nothing has worked it keeps resetting itself to black-pearl?
    2 replies
    Christopher Rijos
    Any tips on how to alias a full subnet of static ip addresses to 1 pi running the hypriot os?
    i want to alias many static ips to 1 network interface on a pi running hypriotos
    $ docker run -d -p 80:80 hypriot/rpi-busybox-httpd
    Unable to find image 'hypriot/rpi-busybox-httpd:latest' locally
    docker: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on dial udp connect: network is unreachable.
    2 replies
    Hi, just read your article about installing docker compose on the Nvidia Jetson Nano, thought I would chime in that I run docker compose on a different arm64 board but I did it as a docker container itself by building their git repository and copying the run.sh file from the release to /usr/local/bin/docker-compose it works well, there are some caveats that it can only access the current working directory but I've not had a problem and it's a very clean way to get it installed.
    marx engels
    @TurtleHunter : you shouldn't publish your ip address, certainly not when you clearly have config issues [Verizon Business (MCICS)] (x.x.x.x:53 dns) ought be enough - :( dial udp**) connect: network is unreachable. - i doubt that is hub.docker's ip addr > (IPv4 address (; so it must be yours -which would probably mean your resolv.conf / dns setup is iffy - how and where did you set hostname . /etc/hosts or user-data(cloud-init) - are you on a dial up modem - in 2020 ?you couldn't reliably pull docker images at 56kb/s