These are chat archives for hypriot/talk

26th
Dec 2016
Christopher Burroughs
@axuan25
Dec 26 2016 11:04
Greetings! Merry christmas / hanukah!
I'd like to ask if anyone has encountered issues mounting a local folder as volume. I'm running a java app using hypriot but my logger (Logback) cannot seem to be able to write (it creates the folders, though..). Is there any kind of special permission or tweaking needed for containers to be able to write to a mounted folder?
(raspberry pi 3)
Fabian
@235Fabi_twitter
Dec 26 2016 15:24
Hi! I am having a problem playing sound on my Raspberry pi using the latest version of hypriot. Is there something I should know about this? I am forwarding -v /dev/snd/ and I tried --priviledged... but the container still says that there is no sound device -.-
Adam Ness
@greylurk
Dec 26 2016 19:09
I was just trying to add an old RPI 1 to my cluster, but I’m having some issues getting it to start up docker.
I tried just running the docker daemon manually from ssh, and that seems to work, but every time I use systemctl, the docker daemon dies immediately.
Any thoughts?
Adam Ness
@greylurk
Dec 26 2016 19:17
Ah, never mind, there was an overlay.service in /etc/systemd/system/docker.service.d/ that was screwing things up.
Christopher Burroughs
@axuan25
Dec 26 2016 19:19
As for my issue, I found that hypriot/rpi-java sets the WORKDIR to /data. It's not mentioned anywhere else (than the dockerfile itself), and so can be a cause for confusion