These are chat archives for ikkentim/SampSharp

24th
Sep 2016
Tim Potze
@ikkentim
Sep 24 2016 11:00
id is not yet set in the constructor :/
override OnSpawn and do it there
SomeDevil
@SomeDevil
Sep 24 2016 11:56
still not working
Tim Potze
@ikkentim
Sep 24 2016 11:57
:o then I'll check it out later
when i got the time
SomeDevil
@SomeDevil
Sep 24 2016 16:12
debugged a little bit
OnSpawn is not called at all
Tim Potze
@ikkentim
Sep 24 2016 16:13
oh, i just read the docs :( 'This callback is called when a vehicle respawns.'
SomeDevil
@SomeDevil
Sep 24 2016 16:13
that's sad
Tim Potze
@ikkentim
Sep 24 2016 16:13
hmm... For now, can you set a 1 sec timer to attach it? I'll figure out a way to improve it (so id is set in the constructor) later
1 msec*
SomeDevil
@SomeDevil
Sep 24 2016 16:14
btw model id isn't set in ctor, too
Tim Potze
@ikkentim
Sep 24 2016 16:14
nothing is set :(
model is get using a getter, but no variables are assigned at .ctor time
SomeDevil
@SomeDevil
Sep 24 2016 16:17
I believe there is a bug with attaching text label to vehicle, cause it's not attaching even if I do it after car is already spawned
I will check right now and confirm
ok, I lied, it's working. jsut appeared too high and I didn't see it :D
Tim Potze
@ikkentim
Sep 24 2016 16:19
phew :)
Tim Potze
@ikkentim
Sep 24 2016 16:51
gawd. writing this testing stuff is so boring. For the framework itself i already went trough all the natives, now i have to again https://puu.sh/rmjEl/faa7a1bc50.png
SomeDevil
@SomeDevil
Sep 24 2016 17:09
huh, seems like a lot of fun :D