Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    jserdaru
    @jserdaru
    Anyone here?
    Looking for some help using the jenkins plugin
    russomi
    @russomi
    Good afternoon!
    russomi
    @russomi
    Need some help with Credentials Setup for the awseb deployment plugin...
    russomi
    @russomi
    Aldrin Leal
    @aldrinleal
    If your server uses IAM Authentication on your Jenkins Slave (or master, not sure), you need not to setup nothing at all. Otherwise, use the IAM console to create the credentials.
    Brian Stolz
    @tecnobrat
    Entered a PR jenkinsci/awseb-deployment-plugin#5 .. haven't written java for about a decade, and never written anything with a jenkins plugin. So be vigorous :)
    Aldrin Leal
    @aldrinleal
    Sure, I'll look into it in the next few days. Thanks!
    Brian Stolz
    @tecnobrat
    @aldrinleal seeing some weirdness with the new version
    14:08:41 Versions reported: (current=5d4581218a57753180048c0c4dc1588826a63b07-jenkins-eb-deploy-stage-659, underDeployment: 5b3a5f255f4acea97b55e4023592f538d700f3ad-jenkins-eb-deploy-stage-673). Should I move on? false
    14:08:41 Environment Status is 'Ready'. Moving on.
    14:08:41 Deployment marked as 'successful'. Starting post-deployment cleanup.
    Versions mismatched, and it still moved on
    Instead of failing.
    Basically EB rolled back my deploy, so it should be marked as "failed". Health is Green / Status is Ready, because it rolled back.
    Aldrin Leal
    @aldrinleal
    O.o
    Ok, I'll review it okay?
    Brian Stolz
    @tecnobrat
    awesome :)
    myoung34
    @myoung34
    is this still the upstream code repo for the plugin?
    Just curious about ingenieux/awseb-deployment-plugin#45 , i ran into it today and opened https://issues.jenkins-ci.org/browse/JENKINS-39721 before i found that GH link
    myoung34
    @myoung34
    ingenieux/awseb-deployment-plugin#46 as well....one of those days...
    myoung34
    @myoung34
    i can also confirm #45 works, i build it and placed it on my box and the problem is gone
    Matt Foxx
    @FoxxMD
    Hello! Anyone here use intellij as their IDE? I'm trying to setup this project but intellij is having a hard time recognizing imports and i have very little experience with java/maven.
    Lots of experience with JS,PHP, and C#...I know what I'm doing just not exactly here :P
    Aldrin Leal
    @aldrinleal
    @FoxxMD Well, Project | New | File from Existing Sources (or from Source Control)
    Steven Hawley
    @Twistedst
    Hello, I'm attempting to add the feature ingenieux/awseb-deployment-plugin#42. I'm a noob to Jenkins plugins. I would like to keep your plugin deployed and would like to test my changes. How do I change the name for the Build Step dropdown "Deploy into AWS Elastic Beanstalk"? Currently it is conflicting with it.
    Aldrin Leal
    @aldrinleal
    Hm... interesting. Well, if you do mvn hpi:run, it will create a separate jenkins instance with just the plugin installed, so you need not to conflict with your main jenkins install
    Steven Hawley
    @Twistedst
    Awesome. I'll try that. Is that how you would go about testing it?'
    Aldrin Leal
    @aldrinleal
    Actually yes. I don't even have Jenkins installed on my workstation
    and you can create a debug target for maven hpi:run from Idea at least, thus making it easy to debug
    Steven Hawley
    @Twistedst
    I am using IntelliJ, so I can try that as well.
    David Brown
    @davebrown1975
    Hi, I'm having an issue trying to deploy to region eu-west-2. Is this supported? (FATAL: java.lang.IllegalArgumentException: Cannot create enum from eu-west-2 value!)
    Aldrin Leal
    @aldrinleal
    can you paste the whole stacktrace?
    Axel
    @asquel
    Hi Here,
    I'm having issues with the credentials part of the plugin, I continue clicking on "add" but the select box is never upadted. When I go to the credentials page from page, there are all here ...
    Any idea ?
    Aldrin Leal
    @aldrinleal
    look into the jenkins logs, also your browser console tab (hit f12)
    Axel
    @asquel
    so if I had the credentials through the "credentials page" first, it's working
    if I do it directly in the popin it's not
    Aldrin Leal
    @aldrinleal
    its mostly credentials - its a bit tricky with js sometimes
    Axel
    @asquel
    Yeah I guess, a question though: is the S3 bucket / prefix required?
    no option to select an already uploaded artifact ?
    Aldrin Leal
    @aldrinleal
    No. Its part of the plugin functionality, and intentional
    Axel
    @asquel
    can I ask why ?
    Aldrin Leal
    @aldrinleal
    bc users abuse and use the same S3 URL
    Axel
    @asquel
    ok