Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 15 18:04

    kirtansakariya on flask

    working on bottle to flask (compare)

  • Sep 15 18:03

    kirtansakariya on filter

    train with filtering working, n… (compare)

  • Sep 09 22:17
    colinallen opened #356
  • Aug 28 19:21
    colinallen opened #355
  • Aug 28 19:19
    colinallen opened #354
  • Jul 30 18:26

    JaimieMurdock on topic-labels

    topic labels in cluster view (compare)

  • Jul 19 19:38

    JaimieMurdock on topic-labels

    basic label_file support (compare)

  • Jul 19 19:32

    JaimieMurdock on topic-labels

    custom topic labels (compare)

  • Jul 18 13:03

    colinallen on master

    Update README.md Revisions for… (compare)

  • Jul 18 12:50

    colinallen on master

    Update README.md (compare)

  • Jul 10 21:49
    JaimieMurdock assigned #348
  • Jul 10 21:48
    JaimieMurdock commented #348
  • Jun 22 17:43
    JaimieMurdock commented #352
  • Jun 22 02:34
    brandontlocke commented #352
  • Jun 05 19:57

    JaimieMurdock on 1.0b225

    (compare)

  • Jun 05 19:54

    JaimieMurdock on master

    version bump to fix htrc metada… (compare)

  • May 06 17:00
    coveralls commented #353
  • May 06 17:00
    coveralls commented #353
  • May 06 16:09
    RamIyer1998 opened #353
  • May 06 16:07

    RamIyer1998 on Default_Corpora

    Implemented temporary fix for d… (compare)

Neeraj Kumar
@kumarneeraj2005
Hello..please guide me how to run inpho/topic-explorer on new data
Jaimie Murdock
@JaimieMurdock
Hi Neeraj, glad to hear from you
Sorry I wasn't online earlier - the easiest way to prepare your data is to create a folder consisting of PDFs or TXT files
the topic explorer can then be pointed at that folder:
topicexplorer init <YOUR PATH HERE>
I can give more help if I know whether you are on Windows, Mac, or Linux
Ed Kaplan
@dropshot_twitter
Great project! I just started using it, and am examining my first corpus of data. The topic modeling goes fine, but I can't open a document. The document entry page "select a random document" button doesn't pull anything up, and when I click on the fingerprint next to a topic bar, nothing happens.
Jaimie Murdock
@JaimieMurdock
Hi Ed, thanks for the contact.
Which OS are you using?
When you run "topicexplorer launch" in your console it should log requests - if you set up your computer so you have the explorer open in a browser and can still see the console, you'll notice that everytime you go to a new page, it prints a line in the console
Here's an example of some lines:
127.0.0.1 - - [17/Apr/2017:08:58:32 -0400] "GET /40/topics.json HTTP/1.1" 200 15161 "http://compy386:8000/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36"
127.0.0.1 - - [17/Apr/2017:08:58:32 -0400] "GET /60/topics.json HTTP/1.1" 200 22759 "http://compy386:8000/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36"
Jaimie Murdock
@JaimieMurdock
I actually just found an error on my machine: uBlock Origin will block the fingerprint.js script that tries to load
That's an extension on Chrome and Firefox - I'm not sure why it's blocking right now, but will file an issue and look into it
@dropshot_twitter will resolve at #198
Ed Kaplan
@dropshot_twitter
ah...I'm running uBlock too
The first problem is resolved by disabling uBlock, but I've run into a second problem which uBlock disabling doesn't fix: I get no response when I put a term into the search box.
Jaimie Murdock
@JaimieMurdock
(I'm pushing a patch to permanently solve the uBlock issue, while keeping uBlock on)
Ed Kaplan
@dropshot_twitter
Here's the relevant entry from the console:
10.211.55.2 - - [17/Apr/2017:09:16:29 -0400] "GET /topics.json?q=cuba HTTP/1.1" 400 25 "http://edwards-macbook-pro.local:8000/topics?q=cuba" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36"
Just clicking on "view topic clusters" without a search term works fine.
Jaimie Murdock
@JaimieMurdock
The issue there is that cuba may have been stop-listed during the prepstage, especially if it was a very frequent or infrequent word in your corpus
Ed Kaplan
@dropshot_twitter
ah...that's probably it...documents from the kennedy library
thank you!
btw...how do I pull the patched version?
Jaimie Murdock
@JaimieMurdock
ah, that makes sense - cool corpus too! I should definitely add a GUI message about the terms - the browser sees a 400 Bad Request but for the user it just fails silently.
in about 5 minutes I should have the patch uploaded to the server and topicexplorer update will update the software
Ed Kaplan
@dropshot_twitter
Thanks! I'm just getting into topic modeling and the digital humanities generally. I study nuclear and airpower history. I'd like to trace the development of certain ideas (like ways of thinking about limited war) over time. I think this will give me great insights into my documents.