Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    instantOS
    @OsInstant_twitter
    [discord] <robcsi> the version is the same I use
    [discord] <paperbenni> no idea, I've never done that
    Is there even anything to compile? I thought nvidia is just a giant blob...
    [discord] <robcsi> for dkms there is
    [discord] <robcsi> I get an error message to check /var/lib/dkms/nvidia/340.108.build/make.log
    [discord] <paperbenni> What's the content of that file?
    [discord] <robcsi> and in that I see that it fails because ioctl32.h is missing
    [discord] <robcsi> yes, i posted it in the github issue
    [discord] <paperbenni> ioctl.h is probably a kernel header
    [discord] <robcsi> I know
    [discord] <robcsi> linux/ioctl32.h
    [discord] <robcsi> because I tried with both linux and linux-lts
    [discord] <robcsi> and dkms option
    [discord] <robcsi> for both
    [discord] <robcsi> none work
    [discord] <paperbenni> did you install both linux-headers and linux-lts-headers?
    [discord] <robcsi> only linux-lts + no-dkms option
    [discord] <robcsi> yes
    [discord] <robcsi> otherwise it stops earlier
    [discord] <robcsi> so, if @cid0rz succeeded, I wonder how
    [discord] <robcsi> my problem is that if install with no dkms, I have install it every time the kernel is updated
    instantOS
    @OsInstant_twitter
    [discord] <robcsi> hence me trying with dkms, as discussed with you earlier in the github issue
    instantOS
    @OsInstant_twitter
    [discord] <cid0rz> hey sorry i was afk, I will check it after dinner. Im a he, sorry to deceive you so early xD
    [discord] <cid0rz> for me it compiled, no errors
    [discord] <cid0rz> did you start as i did and run it on sh? i guess yes but...
    [discord] <robcsi> I did sudo ./NVidia....run
    [discord] <robcsi> it requires sudo
    [discord] <cid0rz> do sudo sh
    [discord] <cid0rz> i think shell may be important there
    [discord] <robcsi> what kernel are you using? the installer runs fine, I don't think sh is missing link here
    [discord] <robcsi> ok, I'll try
    [discord] <cid0rz> im a big ignorant 😄 i use linux lts i think
    [discord] <robcsi> uname -r
    [discord] <robcsi> please
    [discord] <cid0rz> im on windows on the other ocmputer
    [discord] <cid0rz> xD
    [discord] <cid0rz> ill come back later
    [discord] <robcsi> ok, thanks
    [discord] <cid0rz> promised i need to eat xD
    [discord] <robcsi> no problem 🙂
    [discord] <cid0rz> btw benni what is the firewall is installed now when you click, is not clear for me yet L:S
    [discord] <cid0rz> or how can i see the commit
    [discord] <cid0rz> so i dont bother u so much xD
    [discord] <cid0rz> brb in some mins
    [discord] <cid0rz> 🍕
    instantOS
    @OsInstant_twitter
    [discord] <robcsi> so, here's the build error when trying with dkms + linux-lts
    [discord] <robcsi> without dkms, it installs fine, just have to reinstall it every time the kernel is updated 🙂

    [discord] <robcsi> with the linux-lts kernel the build error in make.log is different than with linux:

    /var/lib/dkms/nvidia/340.108/build/uvm/nvidia_uvm_lite.c:859:14: error: initialization of 'vm_fault_t ()(struct vm_fault ) ... from incompatible pointer type '...' (I omitted some details here for brevity)

    instantOS
    @OsInstant_twitter
    [discord] <cid0rz> have you tried this?
    [discord] <cid0rz> Run 'make oldconfig && make prepare' on kernel src to fix it."