Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    [discord] <cid0rz> did you start as i did and run it on sh? i guess yes but...
    [discord] <robcsi> I did sudo ./NVidia....run
    [discord] <robcsi> it requires sudo
    [discord] <cid0rz> do sudo sh
    [discord] <cid0rz> i think shell may be important there
    [discord] <robcsi> what kernel are you using? the installer runs fine, I don't think sh is missing link here
    [discord] <robcsi> ok, I'll try
    [discord] <cid0rz> im a big ignorant 😄 i use linux lts i think
    [discord] <robcsi> uname -r
    [discord] <robcsi> please
    [discord] <cid0rz> im on windows on the other ocmputer
    [discord] <cid0rz> xD
    [discord] <cid0rz> ill come back later
    [discord] <robcsi> ok, thanks
    [discord] <cid0rz> promised i need to eat xD
    [discord] <robcsi> no problem 🙂
    [discord] <cid0rz> btw benni what is the firewall is installed now when you click, is not clear for me yet L:S
    [discord] <cid0rz> or how can i see the commit
    [discord] <cid0rz> so i dont bother u so much xD
    [discord] <cid0rz> brb in some mins
    [discord] <cid0rz> 🍕
    [discord] <robcsi> so, here's the build error when trying with dkms + linux-lts
    [discord] <robcsi> without dkms, it installs fine, just have to reinstall it every time the kernel is updated 🙂

    [discord] <robcsi> with the linux-lts kernel the build error in make.log is different than with linux:

    /var/lib/dkms/nvidia/340.108/build/uvm/nvidia_uvm_lite.c:859:14: error: initialization of 'vm_fault_t ()(struct vm_fault ) ... from incompatible pointer type '...' (I omitted some details here for brevity)

    [discord] <cid0rz> have you tried this?
    [discord] <cid0rz> Run 'make oldconfig && make prepare' on kernel src to fix it."
    [discord] <cid0rz> im a total igniorant so forgive me if i say things that make no sense xD
    [discord] <robcsi> so am I, no worries. I'm currently trying this: https://aur.archlinux.org/packages/nvidia-340xx-dkms/
    it has some patches, too
    [discord] <robcsi> they may be fixing my build errors
    [discord] <cid0rz> i got some message also about kernel preparation not necessry
    [discord] <cid0rz> that was skipped then modules were compiled
    [discord] <cid0rz> i did not install any special dkms package or anything
    [discord] <cid0rz> just in a fresh instant os install
    [discord] <robcsi> ok, thanks
    [discord] <robcsi> I'll report back if I have some news
    [discord] <cid0rz> when i start the other pc ill confirm the kernel but is 90% lts one
    [discord] <robcsi> ok
    [discord] <cid0rz> when install succeeds does it record any log or anything
    [discord] <cid0rz> i can retrieve for you?
    [discord] <robcsi> probably, but I don't remember
    [discord] <robcsi> the build of the package I showed is still running, so it may be a good sign. the other one stopped at 5%
    [discord] <robcsi> so, it worked. the nvidia-340xx-dkms package is good for linux kernel. I now have to see what happens when the kernel is updated
    [discord] <cid0rz> idk why dkms was ok on my system
    [discord] <robcsi> don't touch it, if it works 🙂
    [discord] <cid0rz> thats a golden rule for computers and life in general xD
    [discord] <RedFive> driver 455.28 and cuda 11.1 working well with my 1050ti
    [discord] <RedFive> was having problems earlier tho, but fixed by updating driver
    [discord] <OdiousImp> If I was to customise my dotfiles would it similar to dwm