These are chat archives for internalfx/quickshot

20th
Nov 2015
Winston Hughes
@hughker
Nov 20 2015 15:20

@internalfx getting the following issue when trying to run quickshot blogs download

(~/GitHub/Urban-Undercover) Winstons-MacBook-Air $ quickshot blogs download
/usr/local/lib/node_modules/quickshot/lib/blogs.js:35
  (0, _co2['default'])(function* () {
                               ^
SyntaxError: Unexpected token *
    at exports.runInThisContext (vm.js:73:16)
    at Module._compile (module.js:443:25)
    at Object.Module._extensions..js (module.js:478:10)
    at Module.load (module.js:355:32)
    at Function.Module._load (module.js:310:12)
    at Module.require (module.js:365:17)
    at require (module.js:384:17)
    at /usr/local/lib/node_modules/quickshot/lib/main.js:45:15
    at /usr/local/lib/node_modules/quickshot/lib/main.js:54:15
    at Object.exports.run (/usr/local/lib/node_modules/quickshot/lib/main.js:114:13)
(~/GitHub/Urban-Undercover)

I just ran npm install -g quickshot to make sure i was at the newest version but still having the same issue.

Bryan Morris
@internalfx
Nov 20 2015 17:56
I looks like you need a newer version of node...
weird though. I assume you didn't downgrade recently
But nodejs 4.2 should fix you right up.
@hughker
Winston Hughes
@hughker
Nov 20 2015 18:43
Okay thanks @internalfx will try that. And for sure didn't downgrade for any reason known to me.