These are chat archives for ipython/ipython

21st
Sep 2015
When I write a interactive function with the @interact decorator, it seems that after changing the function, re-evaluations of that particular cell will bring the interact widgets into a weird state. Instead of calling only the latest version, all previous versions of the functions appear to be called when moving my slider. Any ideas?
Min RK
@minrk
Sep 21 2015 09:05 UTC
Can you provide an example?
yes, I will try to do tonight.
the problem is, that I accidentally reused a slider. Still this is weird.
Scott Provost
@scottprovost
Sep 21 2015 12:09 UTC
Where is the instruction for installing a Cluster?
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/pip/basecommand.py", line 211, in main
status = self.run(options, args)
Min RK
@minrk
Sep 21 2015 12:15 UTC
@scottprovost the readme
IPython doesn't support Python 2.6
Scott Provost
@scottprovost
Sep 21 2015 12:16 UTC
oic Thanks. No Centos support then.
Min RK
@minrk
Sep 21 2015 12:17 UTC
If you want to use IPython with 2.6, you must install an old version: pip install 'ipython<2'
It's been a few years since even Python supported 2.6. The general recommendation on CentOS is to not use the system-provided 2.6, instead get 3.5 (or 2.7 for Legacy Python) from other sources, e.g. rpms or anaconda.
Scott Provost
@scottprovost
Sep 21 2015 12:18 UTC
We are not allowed to use any software that does not support standard distros. Probably hacked or substandard.
Min RK
@minrk
Sep 21 2015 12:19 UTC
Are official RedHat Software Collections not official enough?
Scott Provost
@scottprovost
Sep 21 2015 12:20 UTC
Python is integral to the OS
Min RK
@minrk
Sep 21 2015 12:21 UTC
It is indeed.
Python 2.6 has been EOL for a couple of years, now.
And rhscl allows you to have multiple Python versions on the system at once (as do conda, pythonbrew, virtualenv, etc.)
But if you are stuck with very old Python for institutional reasons, then you are also stuck with very old Python packages.
Scott Provost
@scottprovost
Sep 21 2015 12:24 UTC
No such things are mentioned in any install instructions.
Following the given instructions does not resuly in a working system on any common distro.
Unfit for public distobution or NSF use.
Min RK
@minrk
Sep 21 2015 12:26 UTC
I guess none of debian, ubuntu, fedora, gentoo, arch, suse, solaris, freebsd, etc. are common distros, then.
Scott Provost
@scottprovost
Sep 21 2015 12:26 UTC
We will be testing them all. So far, no joy.
Min RK
@minrk
Sep 21 2015 12:27 UTC
All of the above are known to work.
Scott Provost
@scottprovost
Sep 21 2015 12:28 UTC
REHEL and Centos both failed in more than one version. Thats 60% or the server OS's on the Web and almost 80% of the NSF Server farm.
Min RK
@minrk
Sep 21 2015 12:28 UTC
I'm running notebook servers on multiple CentOS 6 systems right now.
Scott Provost
@scottprovost
Sep 21 2015 12:29 UTC
But the standard CentOS python does not work and fails with no informative error and not prerequisit designation.
Min RK
@minrk
Sep 21 2015 12:31 UTC
I'm curious. Why is it prohibited to install another Python, but allowed to install the latest IPython with pip?
Scott Provost
@scottprovost
Sep 21 2015 12:32 UTC
To test uses the published install instructions. That why we ask for the official page to make sure we are using the correct instructions.
If the developers of the software can not write an install instruction page that works.
They are not qualified to maintain software used by government institutions.
Steven Silvester
@blink1073
Sep 21 2015 12:34 UTC
@scottprovost, I direct you to this post by one of the Python core developers: http://www.curiousefficiency.org/posts/2015/04/stop-supporting-python26.html
Scott Provost
@scottprovost
Sep 21 2015 12:35 UTC
Al lI do is the test. So far no joy.
Min RK
@minrk
Sep 21 2015 12:35 UTC
@scottprovost you are right that we should make it clearer that Python 2.6 is not supported.
Scott Provost
@scottprovost
Sep 21 2015 12:37 UTC
If there is an OS version you think will certainly work without diverging from the published install instructions. I will spin up a VM for it and give it a test.
Bastian Hoyer
@bastianh
Sep 21 2015 12:37 UTC
which documentation are you using?
first line of the page I found says: IPython requires Python 2.7 or ≥ 3.3.
installing a newer python version for your system is out of scope for the ipython documentation
it also contains a link to ipython 1.0 in line 2
Scott Provost
@scottprovost
Sep 21 2015 12:39 UTC
Bastian Hoyer
@bastianh
Sep 21 2015 12:41 UTC
ah.. I had still bookmarked the ipyhton documentation: https://ipython.org/ipython-doc/dev/install/install.html
Min RK
@minrk
Sep 21 2015 12:41 UTC
The Jupyter install docs are brand new, and there's definitely some info missing.
Scott Provost
@scottprovost
Sep 21 2015 12:42 UTC
My hands are tied. But with less energy than required to argue with me, some one could create functional install docs.
Min RK
@minrk
Sep 21 2015 12:43 UTC
There are some holes, and we are working on them. The install docs do work for the vast majority of user systems that have been encountered.
Damian Avila
@damianavila
Sep 21 2015 12:50 UTC

Where's the old example notebook?

Also here's my attempt at a 'bare' slides template: >http://antonakhmerov.org/misc/slides_reveal_bare.tpl

Great, I will take a look during the week...

Jason Grout
@jasongrout
Sep 21 2015 13:18 UTC
@minrk - what repo are the jupyter install docs in?
Scott Provost
@scottprovost
Sep 21 2015 13:19 UTC
2.6.32-573.3.1.el6.centos.plus.x86_64 #1 SMP Fri Aug 14 01:00:05 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Fail
3.10.0-229.11.1.el7.x86_64 #1 SMP Thu Aug 6 01:06:18 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Fail.
Jason Grout
@jasongrout
Sep 21 2015 13:20 UTC
@scottprovost - let's help you get up to speed, and then could you please submit a pull request to the docs at https://github.com/jupyter/jupyter/blob/master/docs/source/install.rst with corrections you see fit?
This is an open-source project - everyone helps
:)
To begin with, as you notice, there should be a line at the top saying that Jupyter only supports Python 2.7 or >= 3.3 (@minrk - is it still 3.3?)
Min RK
@minrk
Sep 21 2015 13:21 UTC
jupyter/jupyter#44 restores the note about 2.6/3.2
Jason Grout
@jasongrout
Sep 21 2015 13:22 UTC
Great; can I merge?
dumb question; I can.
Min RK
@minrk
Sep 21 2015 13:22 UTC
:+1:
Jason Grout
@jasongrout
Sep 21 2015 13:23 UTC
I should probably build the docs before merging. Don't think I've done that before
Scott Provost
@scottprovost
Sep 21 2015 13:23 UTC
Command "/usr/bin/python -c "import setuptools, tokenize;file='/tmp/pip-build-ZQL7me/pyzmq/setup.py';exec(compile(getattr(tokenize, 'open', open)(file).read().replace('\r\n', '\n'), file, 'exec'))" install --record /tmp/pip-rXxEI5-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-ZQL7me/pyzmq
Min RK
@minrk
Sep 21 2015 13:26 UTC
You need the ability to build Python packages with extensions.
Scott Provost
@scottprovost
Sep 21 2015 13:26 UTC
Package python-setuptools-0.9.8-3.el7.noarch already installed and latest version
Seven OS Versions. No joy.
Min RK
@minrk
Sep 21 2015 13:27 UTC
That typically means a compiler and Python headers. These are provided by build-essential and python-dev on Debian/Ubuntu.
If setting up a Python environment is unfamiliar, I would recommend using Anaconda.
Jason Grout
@jasongrout
Sep 21 2015 13:30 UTC
IIRC, you can install just IPython without needing to build extensions, right? But to install the full jupyter project, you do.
Min RK
@minrk
Sep 21 2015 13:30 UTC
Yes, I doubt any of IPython's dependencies have extensions.
Scott Provost
@scottprovost
Sep 21 2015 13:32 UTC
'Development Tools' are installed an all test images. Not mentioned in any requirements.
Min RK
@minrk
Sep 21 2015 13:35 UTC
It's likely the absence of Python headers.
Scott Provost
@scottprovost
Sep 21 2015 13:38 UTC
Installed:
python-devel.x86_64 0:2.7.5-18.el7_1.1
Successfully installed functools32-3.2.3-2 ipykernel-4.0.3 ipython-4.0.0 ipywidgets-4.0.2 jinja2-2.8 jsonschema-2.5.1 jupyter-1.0.0 jupyter-client-4.0.0 jupyter-console-4.0.2 mistune-0.7.1 nbconvert-4.0.0 nbformat-4.0.0 notebook-4.0.4 path.py-8.1.1 pexpect-3.3 pickleshare-0.5 ptyprocess-0.5 pygments-2.0.2 pyzmq-14.7.0 qtconsole-4.0.1 simplegeneric-0.8.1 terminado-0.5
mcburton
@mcburton
Sep 21 2015 13:49 UTC
Hey, I don't know if this is the right forum for this question, but I'm having some problems with the GithubOAuthenticator on JupyterHub. I must have something configured wonky because instead of getting redirected to Github when I visit /hub/oauth_login I'm getting directed to my application (and a 404 obviously). If I manually direct myself to https://github.com/login/oauth/authorize with the correct parameters everything works. What am I missing?
Scott Provost
@scottprovost
Sep 21 2015 13:55 UTC
Are we certain this is the instructions for installing an IPython Cluster?
Where is the instruction for installing a Cluster?
Min RK
@minrk
Sep 21 2015 13:57 UTC
@scottprovost sorry, got lost due to following the jupyter installation instructions that were linked. IPython parallel is the package ipyparallel. If you run pip install ipyparallel now, you will have it.
Scott Provost
@scottprovost
Sep 21 2015 13:57 UTC
Will do.
Min RK
@minrk
Sep 21 2015 14:01 UTC
@scottprovost what's the name of the RH dev tools package?
I'll make sure that we mention the build-essential,python-dev dependendencies for Linux distros are noted when installing with pip.
mcburton
@mcburton
Sep 21 2015 14:09 UTC
ah, I think the problem is my proxy, not GithubOAuthenticator config. Thanks guys! :smile:
Scott Provost
@scottprovost
Sep 21 2015 14:36 UTC
yum install python-devel
Carlos Cordoba
@ccordoba12
Sep 21 2015 23:14 UTC
@minrk, could you tell me of which IPython/Jupyter package appnope is a dependency of?
Right now we're not packaging appnope in conda, and that's breaking the Matplotlib Qt backend in Mac.
Matthias Bussonnier
@Carreau
Sep 21 2015 23:23 UTC
@ccordoba12 at least ipython itself and ipykernel use it otherwise in some case OSX will put them to sleep.
Carlos Cordoba
@ccordoba12
Sep 21 2015 23:33 UTC
Thanks @Carreau!
I could find appnope as an ipykernel dependency in its setup.py
Sorry, s/could/couldn't/g
But I just saw it as an IPython dep. Thanks for your help :-)