These are chat archives for ipython/ipython

3rd
May 2016
cilidine
@cilidine
May 03 2016 15:05
ZhudeMacBook-Pro:Downloads zhuyu$ pip install pandoc
Requirement already satisfied (use --upgrade to upgrade): pandoc in /Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): ply in /Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages (from pandoc)
ZhudeMacBook-Pro:Downloads zhuyu$ pip install pandoc --upgrade
Requirement already up-to-date: pandoc in /Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages
Requirement already up-to-date: ply in /Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages (from pandoc)
ZhudeMacBook-Pro:Downloads zhuyu$ ipython nbconvert --to pdf boston_housing.ipynb
[NbConvertApp] Converting notebook boston_housing.ipynb to pdf
[NbConvertApp] ERROR | Error while converting 'boston_housing.ipynb'
Traceback (most recent call last):
File "/Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/nbconvert/nbconvertapp.py", line 335, in export_single_notebook
output, resources = self.exporter.from_filename(notebook_filename, resources=resources)
File "/Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/nbconvert/exporters/exporter.py", line 165, in from_filename
return self.from_notebook_node(nbformat.read(f, as_version=4), resources=resources, **kw)
……..omiited
any body can help me out, thanks in advance
File "/Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/nbconvert/filters/markdown.py", line 59, in markdown2latex
return pandoc(source, markup, 'latex', extra_args=extra_args)
File "/Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/nbconvert/utils/pandoc.py", line 49, in pandoc
check_pandoc_version()
File "/Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/nbconvert/utils/pandoc.py", line 95, in check_pandoc_version
v = get_pandoc_version()
File "/Users/zhuyu/Library/Enthought/Canopy_64bit/User/lib/python2.7/site-packages/nbconvert/utils/pandoc.py", line 74, in get_pandoc_version
raise PandocMissing()
PandocMissing: Pandoc wasn't found.
Please check that pandoc is installed:
http://johnmacfarlane.net/pandoc/installing.html