These are chat archives for ipython/ipython

4th
Aug 2016
Dave Hirschfeld
@dhirschfeld
Aug 04 2016 00:03
I'm seeing this behaviour in spyder and the qtconsole (launched with jupyter qtconsole) but the terminal ipython (launched with ipython) does load my startup file.
λ conda list ipython
# packages in environment at C:\Python:
#
Using Anaconda Cloud api site https://api.anaconda.org
ipython                   5.0.0                    py35_0
ipython-notebook          4.0.4                    py35_3
ipython-qtconsole         4.0.1                    py35_4
ipython_genutils          0.1.0                    py35_0
C:\dev\packages\spyder [master ≡]
λ conda list jupyter
# packages in environment at C:\Python:
#
Using Anaconda Cloud api site https://api.anaconda.org
jupyter                   1.0.0                    py35_3
jupyter_client            4.3.0                    py35_0
jupyter_console           5.0.0                    py35_0
jupyter_core              4.1.0                    py35_0
C:\dev\packages\spyder [master ≡]
λ conda list qtconsole
# packages in environment at C:\Python:
#
Using Anaconda Cloud api site https://api.anaconda.org
ipython-qtconsole         4.0.1                    py35_4
qtconsole                 4.2.1                    py35_0
Dave Hirschfeld
@dhirschfeld
Aug 04 2016 07:08
@minrk - please ignore. The culprit was a qt update which broke matplotlib which was in my startup.py file. I got the traceback in the terminal ipython but the qtconsole and hence spyder both silently swallowed the exception.