These are chat archives for ipython/ipython

3rd
Jun 2017
Brian M Hamlin
@darkblue-b
Jun 03 2017 17:10
hi all - preparing a setup for a conference .. using pip/pip3 to get an ipython 5.4 setup
thx very much for the prompt 5.4 release; noticed and appreciated
I thought it would be tidy to have both sides, Py2 and Py3 use the same version of ipython.. so I installed Py2 first, Ubuntu Linux, then {{{ pip3 install ipython==5.4 --upgrade-strategy only-if-needed }}}
then {{{ pip3 install --upgrade notebook --upgrade-strategy only-if-needed }}}
however, that still pulls in ipython 6 .. just so you know
Min RK
@minrk
Jun 03 2017 20:37
Sounds like a problem in only-if-needed, perhaps?
FWIW, the same commands do not upgrade IPython to 6 for me
$ pip3 install ipython==5.4
$ pip3 install --upgrade notebook --upgrade-strategy only-if-needed
...
ipykernel (4.6.1)
ipython (5.4.0)
ipython-genutils (0.2.0)
jupyter-client (5.0.1)
jupyter-core (4.3.0)
nbconvert (5.2.1)
nbformat (4.3.0)
notebook (5.0.0)
...
Perhaps simpler would be to just install in one command: pip3 install ipython==5.4 notebook==5.0, which will already upgrade dependencies as needed, without an --upgrade flag.
Brian M Hamlin
@darkblue-b
Jun 03 2017 21:56
hmm I needed a setuptools in there.. and, I definitely do get ipython 6.1.0
retrying with the second variation
Brian M Hamlin
@darkblue-b
Jun 03 2017 22:06
and yes, the second one gets ipython 5.4. good