Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 20 15:44
    jasongrout commented #2559
  • Sep 20 15:40
    kartoshhka edited #2559
  • Sep 20 15:38
    kartoshhka opened #2559
  • Sep 19 12:24
    vidartf commented #2431
  • Sep 18 16:54
    ldnelso2 commented #2538
  • Sep 17 17:03
    kebwi commented #2557
  • Sep 16 11:30
    vidartf commented #2382
  • Sep 16 11:29
    vidartf commented #2382
  • Sep 16 10:57
    vidartf commented #2548
  • Sep 16 02:00
    jetheurer commented #2382
  • Sep 15 19:20
    RDeRenzi commented #1815
  • Sep 15 19:18
    RDeRenzi commented #1815
  • Sep 15 19:18
    RDeRenzi commented #1815
  • Sep 13 03:45
    jasongrout milestoned #2557
  • Sep 13 03:45
    jasongrout commented #2557
  • Sep 13 03:22
    kebwi commented #2557
  • Sep 12 21:54
    jasongrout commented #2477
  • Sep 12 21:52
    jasongrout commented #2477
  • Sep 12 21:43
    kebwi commented #2477
  • Sep 12 16:49
    jasongrout demilestoned #1939
Jason Grout
@jasongrout
Second time it gave compile errors
Jason Grout
@jasongrout
@AbdealiJK - actually, it looks like somehow I didn't push my latest changes to github on that branch
Okay, I just pushed my changes to github, and your list of commands on the issue works for me now (intermediate npm commands will give build errors, but the last npm build command succeeds and widgets work...)
Sorry for not pushing to github!
Dhruv Madeka
@dmadeka
@ketch you could try the pyplot API. It tries to emulate mpl, as much as possible. bqplot works well as an independent plotting library outside of mpl - we use it for dozens of "non-simple" things - including full scale application development. But im with you, we need a better bridge
AbdealiJK
@AbdealiJK
@jasongrout thanks :)
Jason Grout
@jasongrout
did it work?
AbdealiJK
@AbdealiJK
@jasongrout - worked like a charm !
Jason Grout
@jasongrout
whew, great!
Jason Grout
@jasongrout
@SylvainCorlay - any comment on ipython/ipywidgets#1219 ?
cenveoanalyst
@cenveoanalyst
Has anyone ever used 'interact' or something similar to create a widget that periodically executes a function at a specified interval? I want to create some sort of process to periodically update a chart in one of my notebooks.
Maarten Breddels
@maartenbreddels
i think i had a gist somewhere..
https://gist.github.com/maartenbreddels/3378e8257bf0ee18cfcbdacce6e6a77e and ipython/ipywidgets#663 should help you out i guess
for the last issue, just look at my last post
Maarten Breddels
@maartenbreddels
I get npm ERR! notarget No compatible version found: jupyter-js-widgets@~3.0.0 when running dev-install.sh
this is the current master
Jason Grout
@jasongrout
yes, we haven't published 3.0.0, so there will be at least one error. That error may go away if you do npm run update.
Randy
@rskabelund
random question, are we able to set the background color of box widgets?
can't seem to get it to work
blob
b=widgets.Box(children=[widgets.HTML('hello')])
b.border='solid 1px red'
b.background_color='#FF00FF'
display(b)
Sylvain Corlay
@SylvainCorlay
@rskabelund as of 6.0, one can only set styling properties of widgets with the style attribute which enables a whitelist of stylable features on a per-widget basis.
Jason Grout
@jasongrout
If it's an html widget you are doing, you can probably put a <span style='...'>tag in it
Carol Willing
@willingc
@jasongrout What time is the conference call today? I have one email that says 10am Calif. and another that says 2pm Calif.
cenveoanalyst
@cenveoanalyst
@maartenbreddels Thank you so much!
Jason Grout
@jasongrout
1-3pm Eastern time
i.e., in one hour
Carol Willing
@willingc
Thanks! @jasongrout
Maarten Breddels
@maartenbreddels
@jasongrout i still cannot get it to install
in the widgetsnbextension i run npm install, that fails, same error as above (npm ERR! notarget No compatible version found: jupyter-js-widgets@~3.0.0)
npm run update fails rimraf: command not found
Maarten Breddels
@maartenbreddels
ok, manually installing that.. and then npm run update will install jupyter-js-widgets, but then fail, but then again npm install runs
Jason Grout
@jasongrout
@/all - I'm moving the ipywidgets to the new jupyter-widgets organization now...
Jason Grout
@jasongrout
I suppose we should move this channel too. @SylvainCorlay - thoughts?
or anyone else?
JamieW
@JamiesHQ
@jasongrout - can u give access to widgets collaborators too ie @lbustelo ?
Jason Grout
@jasongrout
I think the repo is moved, and we invited @lbustelo as an admin to the repo, IIRC
JamieW
@JamiesHQ
@jasongrout perfect. thanks!
Damian Avila
@damianavila
Sylvain Corlay
@SylvainCorlay
I am fine moving the channel
Jason Grout
@jasongrout
@/all - let's move over to the new jupyter-widgets/ipywidgets chat room, then: https://gitter.im/jupyter-widgets/ipywidgets
@/all - on second thought, let's move to the https://gitter.im/jupyter-widgets/Lobby channel - it's a bit broader than just ipywidgets
JamieW
@JamiesHQ
@jasongrout - sounds good- could you add the same visual cue here that you provided when u moved JupyterLab
Jason Grout
@jasongrout
Great idea.
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
Hi everyone, this channel is moving to https://gitter.im/jupyter-widgets/Lobby, to coincide with the repo move to the jupyter-widgets organization on GitHub
Sylvain Corlay
@SylvainCorlay
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
Hi everyone, this channel is moving to https://gitter.im/jupyter-widgets/Lobby, to coincide with the repo move to the jupyter-widgets organization on GitHub
Martin K. Scherer
@marscher
trying to get rid of the border of a Text widget, but adding a Layout with border='hidden' or border='none' still displays the border. However dotted style etc is possible. How can I achieve this?
Jason Grout
@jasongrout
Can you repost over on https://gitter.im/jupyter-widgets/Lobby? This channel is deprecated
Sylvain Corlay
@SylvainCorlay
*********************************************************************











  This channel has moved to https://gitter.im/jupyter-widgets/Lobby












*********************************************************************
This channel is moving to https://gitter.im/jupyter-widgets/Lobby.