Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    eZii-jester-data
    @eZii-jester-data
    i ran into this same issue (rails/webpacker#1923) before that and i simply did a "yarn add babel-loader"
    but that doesn seem to be the correct troubleshooting
    Jan Biedermann
    @janbiedermann
    no, just updat econfig
    eZii-jester-data
    @eZii-jester-data
    they suggest simply deleting .babelrc file
    Jan Biedermann
    @janbiedermann
    wait a sec
    eZii-jester-data
    @eZii-jester-data
    sebastian burkhardt did the ruby.js thingie
    Frederic ZINGG
    @fzingg
    I think @eZii-jester-data talk about http://hasclass.com/
    eZii-jester-data
    @eZii-jester-data
    yeah
    Jan Biedermann
    @janbiedermann
    Oh, i know rubjs
    so in your webpacker config look for the string style-loader and then delete the sourceMap option
    eZii-jester-data
    @eZii-jester-data
    ok
    Jan Biedermann
    @janbiedermann
    and webpack config
    (i found its not the owl rails config, phu)
    eZii-jester-data
    @eZii-jester-data
    i can't finde style-loader
    or not even anything for "style" search term
    hmm
    webpacker.yml?
    Jan Biedermann
    @janbiedermann
    oh, then its maybe a webpacker thing, so you lock in your package.json style-loader to the previous big version
    eZii-jester-data
    @eZii-jester-data
    in webpacker debug.js
    Jan Biedermann
    @janbiedermann
    version < 1.0.0
    eZii-jester-data
    @eZii-jester-data
    or
    wait
    webpack debugjs
    Jan Biedermann
    @janbiedermann
    (just to clarify: this is unrelated to owl)
    eZii-jester-data
    @eZii-jester-data
    hm, not sure
    owl also generates "sourceMap" in style loader options
    i found the sourceMap options now
    but weird
    i deleted them from all occurences under style loader
    and still i get an error for the same css file again
    same error
    ahh
    it's because the css also uses tthe cache loader
    now it's getting annoying
    i deleted all occurences of sourceMap
    in the whole project
    still the same error
    wth
    eZii-jester-data
    @eZii-jester-data
    now i'm doing as suggested
    version 0.23.1 of style loader
    and a different error at least
    ValidationError: Invalid options object. CSS Loader has been initialised using an options object that does not match the API schema.
    • options has an unknown property 'localIdentName'. These properties are valid:
    Jan Biedermann
    @janbiedermann
    you may try to delete the webpack caches: rm -rf node_modules/.cache or so
    eZii-jester-data
    @eZii-jester-data
    i did delete node_modules completely anyway
    before yarn install
    Jan Biedermann
    @janbiedermann
    so then i suggest to go with style-loader 1.0.0 and check all config, also the config generated by webpacker
    maybe update webpacker?
    eZii-jester-data
    @eZii-jester-data
    uff
    let's try again a different time
    thanks so much for your help