Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    eZii-jester-data
    @eZii-jester-data
    uff
    let's try again a different time
    thanks so much for your help
    i'll use three js react for now
    Jan Biedermann
    @janbiedermann
    ok, thats fine, your welcome
    sorry, that seems more like a webpacker rails problem, cant help much with that.
    eZii-jester-data
    @eZii-jester-data
    yeah
    well
    i always loved rails
    i'm starting to hate it
    first really big problem was the way asset digests are generated
    it's not even properly disclosed in the guides
    the whole webpacker / asset pipeline think is still far from finished
    looking forward to hear more from isomorfeus
    Jan Biedermann
    @janbiedermann
    sure
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> opal-webpack-loader 0.9.7 is out, fixing issues with loading when HMR is enabled
    Jan Biedermann
    @janbiedermann
    @eZii-jester-data found a issue in the generated config. sass loader config must look like this:
                           loader: "sass-loader",
                            options: {
                                sourceMap: true,
                                sassOptions: { includePaths: [path.resolve(__dirname, '../isomorfeus/styles')] }
                            }
    note the sassOptions. Thats for recent sass-loader versions.
    Jan Biedermann
    @janbiedermann

    Oh, well, but that config is not used for the webpack rails install, so this issue is still a rails issue where it uses the old config. You can look for the sass-loader config of webpacker and change:

    includePaths: whatever_rails_uses_here ]

    to:

    sassOptions: { includePaths: whatever_rails_uses_here ] }
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> opal-webpack-loader 0.9.8 available
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> opal-webpack-loader 0.9.9 available - fixing configuration issues for new installations
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> opal-webpack-loader 0.9.10 available since some time already, just forgot to announce
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> For the website, we are using :mui:, but adding :mui: adds >20s to the initial build time in development.
    Initial build with :mui: : ~26s
    without :mui: , only Opal code: ~4.5s
    without :mui: , only Opal code: ~3.3s with memcached or redis cache
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> opal-webpack-loader 0.9.11:
    • improve resolver performance a bit
    • can use memcached or redis as compiler cache
    Isomorfeus Robot
    @isomorfeusbot
    [slack] <janbiedermann> Upgrade procedure:
    • yarn add opal-wepback-loader
    • bundle update
    In that order