These are chat archives for jacobsenmd/opengcs

3rd
Nov 2015
Scott Slaughter
@sslaughter
Nov 03 2015 05:35

Just as a heads up, when I tried to install the pyqtgraph library for the new GCSWidgetPlot file, it failed with the following error:

'error: Microsoft Visual C++ 9.0 is required (Unable to find vcvarsall.bat). Get it from http://aka.ms/vcpython27'

Which is apparently a VC compiler for python. I'm installing it now, but is this something that is on most computers?

Scott Slaughter
@sslaughter
Nov 03 2015 06:19
After installing from that link, the pyqtgraph install worked fine.
Tim
@qfather
Nov 03 2015 12:16
@sslaughter that error typically pops up when you try to compile a Python 2.7 module from source without the C++ headers. Ran into it a few times on Windows.
Mark Jacobsen
@jacobsenmd
Nov 03 2015 13:12
Interesting, that’s good to know. I primarily work on Mac OS, and had no trouble. I’m glad we have all three OS’s covered between the three of us. My plan is to eventually use a tool like pyinstaller to package everything up, so hopefully users won’t have to worry about tricky package installations
FYI, I haven’t committed anything in a few days, but have been working hard on layout management… including the ability to edit screens, add widgets, and persist layout settings. Getting pretty close.
Mark Jacobsen
@jacobsenmd
Nov 03 2015 14:50
Just pushed layout management and persistent . The code is pretty complex and I expect there will be bugs. If you find any, please submit them as github issues. Thanks!