These are chat archives for japgolly/scalacss

4th
Apr 2017
Joan Goyeau
@joan38
Apr 04 2017 10:36
Hello
[error] missing or invalid dependency detected while loading class file 'ScalaCssReactImplicits.class'.
[error] Could not access type ReactElement in package japgolly.scalajs.react,
[error] because it (or its dependencies) are missing. Check your build definition for
[error] missing or conflicting dependencies. (Re-run with `-Ylog-classpath` to see the problematic classpath.)
[error] A full rebuild may help if 'ScalaCssReactImplicits.class' was compiled against an incompatible version of japgolly.scalajs.react.
[error] missing or invalid dependency detected while loading class file 'ScalaCssReactImplicits.class'.
[error] Could not access type TagMod in class japgolly.scalajs.react.vdom.Base,
[error] because it (or its dependencies) are missing. Check your build definition for
[error] missing or conflicting dependencies. (Re-run with `-Ylog-classpath` to see the problematic classpath.)
[error] A full rebuild may help if 'ScalaCssReactImplicits.class' was compiled against an incompatible version of japgolly.scalajs.react.vdom.Base.
[error] /.../LeftNav.scala:44: type mismatch;
[error]  found   : scalacss.internal.StyleA
[error]  required: japgolly.scalajs.react.vdom.TagMod
[error]       <.ul(Style.container)(
Is this issue known?
I'm using ScalaCSS 0.5.1 and Scala-React 1.0.0-RC2
Joan Goyeau
@joan38
Apr 04 2017 10:47
It seems to work with ScalaCSS 0.5.3-RC1
Joan Goyeau
@joan38
Apr 04 2017 13:41
FYI: I just upgraded the exemple template https://github.com/chandu0101/scalajs-react-template