Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Manu
    @mtancoigne:matrix.org
    [m]
    Thanks for sharing, yarrie
    yarrie
    @yarrie:matrix.org
    [m]
    🤍
    Roberto Delgado
    @RoskiDeluge
    Hi folks. I've been having a hell of a time just trying to run jekyll serve. As of two days ago this command worked: bundle exec jekyll serve --livereloadBut I've been unable to serve the site and receive the following error when I try to bundle install or bundle update: Installing eventmachine 1.2.7 with native extensions Gem::Ext::BuildError: ERROR: Failed to build gem native extension. Any help would be appreciated.
    For context: I'm on a new Mac with the M1 chip. From the bit of research I've done, it seems like the issue may be this: https://stackoverflow.com/questions/65075687/issues-serving-jekyll-to-localhost-eventmachine-1-2-7-has-an-error-when-install
    masoud
    @masouddastvarz
    Hello dear friends?
    Is there anyone to help me in Jekyll?
    anwait
    @anwait_gitlab

    Hi folks. I've been having a hell of a time just trying to run jekyll serve. As of two days ago this command worked: bundle exec jekyll serve --livereloadBut I've been unable to serve the site and receive the following error when I try to bundle install or bundle update: Installing eventmachine 1.2.7 with native extensions Gem::Ext::BuildError: ERROR: Failed to build gem native extension. Any help would be appreciated.
    For context: I'm on a new Mac with the M1 chip. From the bit of research I've done, it seems like the issue may be this: https://stackoverflow.com/questions/65075687/issues-serving-jekyll-to-localhost-eventmachine-1-2-7-has-an-error-when-install

    Your issue is as you see building the mentioned gems native parts, meaning that your machine is probably lacking something, you could debug this issue by trying to install said gem locally with gem install YOUR_GEM I am assuming that you are missing some build tools needed to build said gem

    masoud
    @masouddastvarz
    Is there anyone to help me?
    I have Jekyll website as a home page hacker theme . when i want to update the bundle I'm getting this error:bunlder could not find compatible version for gem "Jekyll'
    In Snapshot (Gemfile.lock):
    Jekyll (,] 3.5.0)
    In Gemfile:
    masoud
    @masouddastvarz
    Jekyll (- 3.5.0)
    Jekyll-feed ( - 0.12) was resolved to 0.16.0 which depends on
    Jekyll ( ] 3.7 , [ 5.0 )
    I'm running bundle update or bundle install command but the problem is persist and I couldn't fix.
    Is there anyone to help
    Manu
    @mtancoigne:matrix.org
    [m]
    @masouddastvarz: it seems to be an issue with jekyll-feed, try to update it too: version 0.12 depends on jekyll 3.7 at least
    (if my understandings of the weird version symbols is right... You may copy/paste code chunks using markdown syntax to keep the formatting here)
    Roberto Delgado
    @RoskiDeluge
    Thanks @anwait_gitlab. I did manage to install the eventmachine gem. But I'm still unable to jekyll serve because of this issue:
    Unable to load the EventMachine C extension; To use the pure-ruby reactor, require 'em/pure_ruby' /Users/katana/MIJE/sandbox-mije-jekyll/vendor/bundle/ruby/3.1.0/bundler/gems/eventmachine-9cb13a8a6236/lib/eventmachine.rb:8:in 'require': dlopen(/Users/katana/MIJE/sandbox-mije-jekyll/vendor/bundle/ruby/3.1.0/bundler/gems/eventmachine-9cb13a8a6236/lib/rubyeventmachine.bundle, 0x0009): symbol not found in flat namespace '_SSL_get1_peer_certificate' - /Users/katana/MIJE/sandbox-mije-jekyll/vendor/bundle/ruby/3.1.0/bundler/gems/eventmachine-9cb13a8a6236/lib/rubyeventmachine.bundle (LoadError)
    masoud
    @masouddastvarz
    Okay thanks freinds,I have solved my problem,bundle is now update
    I have another question: I'm using hacker theme for my Jekyll website,is there any way to add my social media accounts like Instagram and Twitter to the hackers theme in Jekyll?
    Manu
    @mtancoigne:matrix.org
    [m]
    Sorry @masouddastvarz I have no idea
    masoud
    @masouddastvarz
    Okay thanks freind
    Roberto Delgado
    @RoskiDeluge

    Thanks @anwait_gitlab. I did manage to install the eventmachine gem. But I'm still unable to jekyll serve because of this issue:
    Unable to load the EventMachine C extension; To use the pure-ruby reactor, require 'em/pure_ruby' /Users/katana/MIJE/sandbox-mije-jekyll/vendor/bundle/ruby/3.1.0/bundler/gems/eventmachine-9cb13a8a6236/lib/eventmachine.rb:8:in 'require': dlopen(/Users/katana/MIJE/sandbox-mije-jekyll/vendor/bundle/ruby/3.1.0/bundler/gems/eventmachine-9cb13a8a6236/lib/rubyeventmachine.bundle, 0x0009): symbol not found in flat namespace '_SSL_get1_peer_certificate' - /Users/katana/MIJE/sandbox-mije-jekyll/vendor/bundle/ruby/3.1.0/bundler/gems/eventmachine-9cb13a8a6236/lib/rubyeventmachine.bundle (LoadError)

    Update: I solved this issue by doing a gem update --system and upgrading everything to the latest version: openssl@3 and ruby-3.1.1

    benui
    @benui:matrix.org
    [m]
    I have a submodule that I'm using for both YAML config (stuff that I want to go in _data) and images (stuff that I want to go in assets). Is there a way to configure Jekyll so that both of these things can be served from a specific path? I know I can add directories with include, but is there a way to like, remap the included files? I want to put _data/mysubmodule/images/*.* => /assets/images/*.*
    benui
    @benui:matrix.org
    [m]
    Or maybe there's a way to copy files? I'm using GitHub pages so I think plugins are limited
    Lorenzo Rutayisire
    @loryruta
    Hello
    I'm struggling building a recursive navigation bar with Liquid, the main issue is that variables aren't scoped to the file
    is there any solution to that nowadays?
    kaosine
    @kaosine:matrix.org
    [m]
    Is there any way to figure out why my pages that are made with jekyll stopped updating? I was going through the tutorial page setting up the hello world and had gone back to change the home page to include the new layout and it doesn't show the navigation that's in the layout it's inheriting from....
    kaosine
    @kaosine:matrix.org
    [m]
    dang it's been almost 24 hours and still hasn't updated on githubs end....I knew i shouldn't of gone the easier route for trying to get something up as a placeholder 😆
    1 reply
    xbt573
    @xbt573
    Hi! How can i use jekyll static files in markdown posts?
    mikwee
    @mikwee:matrix.org
    [m]

    So I found this code in a Jekyll layout:

    {% if site.dark-theme == "auto" %}
            {% capture scss_sheet %}
                {% include style.scss %}
                @media (prefers-color-scheme: dark) {
                    {% include style-dark.scss %}
                }
            {% endcapture %}
        {% elsif site.dark-theme %}
            {% capture scss_sheet %}{% include style-dark.scss %}{% endcapture %}
        {% else %}
            {% capture scss_sheet %}{% include style.scss %}{% endcapture %}
        {% endif %}

    My question is: What does {% include style-dark.scss %} mean? There's no such file, and the VSCode explanations are kind of confusing. Thank you

    Vista2003
    @Vista2003
    Hi, I'm trying to edit an old site that I made in Jekyll last year and I'm trying to run Jekyll serve but I keep getting this error
    I've tried bundle update and bundle install and neither have done anything, wondering what I can do to reslove it
    Dependency Error: Yikes! It looks like you don't have tzinfo or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem. If you've run Jekyll with `bundle exec`, ensure that you have included the tzinfo gem in your Gemfile as well. The full error message from Ruby is: 'cannot load such file -- tzinfo' If you run into trouble, you can find helpful resources at https://jekyllrb.com/help/!
    jekyll 4.2.2 | Error:  tzinfo
    C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:73:in `rescue in block in require_with_graceful_fail': tzinfo (Jekyll::Errors::MissingDependencyException)
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:58:in `block in require_with_graceful_fail'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:57:in `each'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:57:in `require_with_graceful_fail'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/utils/win_tz.rb:15:in `calculate'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll.rb:135:in `set_timezone'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll.rb:123:in `block in configuration'
            from <internal:kernel>:90:in `tap'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll.rb:122:in `configuration'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/command.rb:44:in `configuration_from_options'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/commands/serve.rb:83:in `block (2 levels) in init_with_program'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `block in execute'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `each'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `execute'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/program.rb:44:in `go'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary.rb:21:in `program'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/exe/jekyll:15:in `<top (required)>'
            from C:/Ruby31-x64/bin/jekyll:25:in `load'
            from C:/Ruby31-x64/bin/jekyll:25:in `<main>'
    C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:60:in `require': cannot load such file -- tzinfo (LoadError)
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:60:in `block in require_with_graceful_fail'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:57:in `each'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/external.rb:57:in `require_with_graceful_fail'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/utils/win_tz.rb:15:in `calculate'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll.rb:135:in `set_timezone'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll.rb:123:in `block in configuration'
            from <internal:kernel>:90:in `tap'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll.rb:122:in `configuration'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/command.rb:44:in `configuration_from_options'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/jekyll-4.2.2/lib/jekyll/commands/serve.rb:83:in `block (2 levels) in init_with_program'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `block in execute'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `each'
            from C:/Ruby31-x64/lib/ruby/gems/3.1.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in `execute'
            from C:/Ruby31-x64/lib/ruby/gem
    mikwee
    @mikwee:matrix.org
    [m]
    Wait a minute... Does Neocities only host Jekyll sites on supporter accounts?
    mikwee
    @mikwee:matrix.org
    [m]
    1. Uploaded my site to Codeberg
    2. It's the whole project, which includes the _site folder
    3. Once you go to the site's /_site subdomain, you get a weird mix of the original theme I cloned from GitHub and my visual modifications, but with none of my content.
    Is this related to Jekyll?
    masoud
    @masouddastvarz
    Hello dear friends
    Hope you be fine all.
    I want to add my social media accounts like Twitter and Instagram to my Jekyll website by hackers theme.can u tell me how can i add?
    Matt
    @mattall
    Hello, I have been entrusted with running a Jekyll site and I have no background in frontend lol. I'm trying to use some Vue JS functions in a page. The content looks like this:
    I have elements called "tree_section" and "content_section", and some vuejs commands inside that are supposed to pull the content from an object in another js file. Even though I have Vue.js loaded, the commands don't get executed. My webspage just shows the text of the vue commands. Any ideas how to get those to execute from within the Jekyll environment?
    Matt
    @mattall
    The content loaded is all from an html file in my _includes directory. I'm loading it into a frontmatter page with {% include myfile_with_vuejs_stuff_in_it.html %}
    AJ
    @EidolonForgery
    Hmm. Is there any way to embed the title and summary of a post into another page, in such a way that if someone edits the summary, it'll also be edited on the page? I basically want post.summary but from outside of the post itself, like name-of-post.summary.
    cupofdirtfordinner
    @cupofdirtfordinner
    damn i dont think anyone has ever gotten help in this channel
    maybe like twice, ive been scrolling for a while
    im just gonna find help elsewhere ig
    dannyromano
    @dannyromano
    @cupofdirtfordinner What was your question?
    devinnasar
    @devinnasar
    Hello