These are chat archives for jescalan/roots

4th
Sep 2015
Michael Kornblum
@michaelkornblum
Sep 04 2015 17:16
Hello all. It's me again. Is anyone having trouble displaying the background image via css while using roots watch?
I know for a certainty the syntax is correct as I tried it using browsersync.
Michael Kornblum
@michaelkornblum
Sep 04 2015 17:35

Hello all, it's me again. I'm having some difficulty displaying background images with charge. I know the syntax is valid and everything compiles well

  body
    background-image: url('/img/background.jpg')

but the results are not showing up on the server. Any suggestions?

Sorry for the duplicate, btw.
Daniel Box
@dbox
Sep 04 2015 18:22
Background images are definitely borked in 3.2.2. Downgrading to 3.1 is only way to get them to work, currently.
@michaelkornblum
hopefully @jenius can resolve soon
Michael Kornblum
@michaelkornblum
Sep 04 2015 18:29
Hi dbox, I didn't even know about this issue until a few minutes ago, when a student called my attention to it. I did as you advised in the tracker and it works like a charm . I'm going to have to update the documentation to reflect your fix. I don't know if this helps, but I was able to do a browser sync instance with the roots site and it loaded without issue.
Daniel Box
@dbox
Sep 04 2015 18:31
Yeah there is a mystery bug screwing with everything currently. FWIW I'm following closely to juicebar updates. Can't wait to see browsersync working natively with roots
Anyone have any idea why i'm getting this autoprefixer warning: https://www.dropbox.com/s/68wxtyfils9mxb5/Screenshot%202015-09-04%2013.30.02.png?dl=0 @hhsnopek
Daniel Box
@dbox
Sep 04 2015 19:25
Nm. looks like it's a nib issue.... NIB!!!
Daniel Box
@dbox
Sep 04 2015 19:36

if anyone happens to come across same isssue, here is the fix:

flex-version = flex
support-for-ie = false
vendor-prefixes = official

can't wait to purge nib from axis

Michael Kornblum
@michaelkornblum
Sep 04 2015 20:28
Y'know dbox, you could use a postcss plugin for autoprefixing :)
Jeff Escalante
@jescalan
Sep 04 2015 21:43
hey guys, yeah sorry use 3.1.0 for now, i'm trying to get things switched back
Daniel Box
@dbox
Sep 04 2015 23:48
Yeah I'm using autoprefixer. It's just a conflict with nib's prefixing stuff. Won't be an issue for much longer. We are ripping nib out of axis.