These are chat archives for jescalan/roots

26th
Aug 2016
andrewgrano
@andrewgrano
Aug 26 2016 01:10 UTC
@jescalan - hello! I have a little more information that I'd like to report to you. I logged out "locals" and found that as it loops through each post, it will ADD the category from the previous post to the current post - which is whats causing the issue. (ex: post #1 is always correct. but post #2 has it's correct category PLUS the category that was assigned to post #1. Then post #3 has it's correct category PLUS the 2 categories that were assigned to post #1 & #2. And so on.) When logging out the "posts" variable, this issue does not occur -- each post has only the correct category. So I guess there is something wrong with the looping of "locals"?? I hope this information helps! I can provide you with the logs, if you'd like. Let me know if there is anything else I can do. Thanks!
Marc Haan
@Hoenoe
Aug 26 2016 06:58 UTC
@jescalan I get the require part but what do you mean with " add its contents to the locals" and how it this done?
The roots-records extension looks pretty easy to apply but I first wanne learn how its done with out extensions.
Chris Earls
@cearls
Aug 26 2016 11:35 UTC
@kylemac Thanks, got it working
Kyle MacDonald
@kylemac
Aug 26 2016 12:51 UTC
@cearls :thumbsup: glad to hear it. we're here if you run into anything else
Jeff Escalante
@jescalan
Aug 26 2016 18:08 UTC
@andrewgrano ah good call. i think i just found the bug causing this!
if you add an empty object as the first parameter, i think that might fix it?
try it locally and if it does, i'll ship a patch
@Hoenoe there's a locals object in the app.coffee. you can just add it to this object
andrewgrano
@andrewgrano
Aug 26 2016 21:53 UTC
@jescalan - yup, adding an empty object as the first parameter fixed it! Woohoo! Thanks for your help with this issue!