These are chat archives for jescalan/roots

31st
Oct 2016
Carl Morlock
@gin93r
Oct 31 2016 15:10
I seem to be getting a roots: command not found suddenly.
i did a npm i roots -g but when running any roots command I get the error.
Jeff Escalante
@jescalan
Oct 31 2016 15:24
what does which roots return
Carl Morlock
@gin93r
Oct 31 2016 15:25
it doesn't return anything. But I just did an npm uninstall roots -g and a reinstall and still no dice.
Jeff Escalante
@jescalan
Oct 31 2016 15:25
so that means your computer is screwed up, unfortunately
like quite badly
do you have node and npm installed?
Carl Morlock
@gin93r
Oct 31 2016 15:25
Yes.
Jeff Escalante
@jescalan
Oct 31 2016 15:25
ok so probably your $PATH is off
Carl Morlock
@gin93r
Oct 31 2016 15:26
I'm on windows if that makes a diff
Jeff Escalante
@jescalan
Oct 31 2016 15:26
oh windows
Carl Morlock
@gin93r
Oct 31 2016 15:26
haha
yeah
Jeff Escalante
@jescalan
Oct 31 2016 15:26
i have no idea then
Carl Morlock
@gin93r
Oct 31 2016 15:26
Awwww
Jeff Escalante
@jescalan
Oct 31 2016 15:26
I dont think we even have a windows machine in here
Carl Morlock
@gin93r
Oct 31 2016 15:26
It's probably a Path variable that isn't getting set for some reason
Jeff Escalante
@jescalan
Oct 31 2016 15:26
The best advice I can give is use linux
hahah
or osx
Carl Morlock
@gin93r
Oct 31 2016 15:27
Yeah - would if I could. I don't control the tools here.
Jeff Escalante
@jescalan
Oct 31 2016 15:27
:/
Carl Morlock
@gin93r
Oct 31 2016 15:27
Oddly enough it was working a week ago.
Jeff Escalante
@jescalan
Oct 31 2016 15:27
thats windows for ya
Carl Morlock
@gin93r
Oct 31 2016 15:27
Seriously - I probably need to add the roots cli to my Path ...
Jeff Escalante
@jescalan
Oct 31 2016 15:28
npm should symlink the bin into the place where windows keeps all the other bins
so your path just needs to point to that location
Carl Morlock
@gin93r
Oct 31 2016 15:29
Yeah it's already pointing to the npm directory... weird
Carl Morlock
@gin93r
Oct 31 2016 15:54
Alright got it working again.
Jeff Escalante
@jescalan
Oct 31 2016 15:54
🎉
Carl Morlock
@gin93r
Oct 31 2016 15:54
A few days ago I installed the Atlassian SDK and I think it buggered up my paths.
So I basically had to re-setup the paths for npm
Thanks for reading :)
Jeff Escalante
@jescalan
Oct 31 2016 15:55
:two_men_holding_hands:
Carl Morlock
@gin93r
Oct 31 2016 15:55
Haha! I think that's your favorite emoji.
Jeff Escalante
@jescalan
Oct 31 2016 15:56
:sparkles:
Carl Morlock
@gin93r
Oct 31 2016 18:36
Anyone ever run into the Error: Undefined variable: "$nth" It seems to be related to node-sass.
Carl Morlock
@gin93r
Oct 31 2016 20:43

Alright I apologize for all the questions today.
I don't know what changed since a couple weeks ago, but apparently, I can't get node-sass to recognize my includePaths. I'm sure it's because I don't know how to pass them properly via coffee script within module exports.

I'm supposed to pass them via sass.render({includePaths:[ ... ]})

But in app.coffee I don't really know how to call that... I know that seems newbish but it's the truth.

Anyone able to show me the way?

Ok - I don't know why - but apparently changing "sass" to "scss" changed everything it works... that just doesn't make sense to me.
Jeff Escalante
@jescalan
Oct 31 2016 21:04
It's an accord thing, it takes "scss" as its configuration
It would be a breaking change to switch this, which is why we havent yet
At one point, the node-sass library only would compile scss files
so it was that way for clarity
Carl Morlock
@gin93r
Oct 31 2016 21:06
No worries. I was getting confused because I was requiring node-sass at the top assigned as sass. Turns out I didn't need that require either.
Jeff Escalante
@jescalan
Oct 31 2016 21:06
:+1:
Carl Morlock
@gin93r
Oct 31 2016 21:06
I think I spent all day troubleshooting stuff. What a day...
Thanks for the input :D
Jeff Escalante
@jescalan
Oct 31 2016 21:06
haha been there for sure!
life of a developer
Carl Morlock
@gin93r
Oct 31 2016 21:07
Yeah seriously - and it always happens when you have a deadline
Anthony Nicholls
@gants102_twitter
Oct 31 2016 21:13
Hello, just wanted to say thanks to @jescalan @tkraak, for your help with this site. Way too many glitches and I would have liked to have done a fair bit to improve the functionality with filtering and other bits of animation but unfortunately have no time to fix. Hopefully for next year will be a whole lot better! On the plus side the week went really well, and was well attended, and also loved learning some new stuff so not all bad :-)
Jeff Escalante
@jescalan
Oct 31 2016 21:22
@gants102_twitter this is great! huge congrats :tada:
looks incredible
Tom Kraak
@tkraak
Oct 31 2016 21:22
@gants102_twitter :thumbsup: :rocket:
public repo?