Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 06 2018 11:01
    lefuturiste closed #112
  • Sep 06 2018 11:01
    lefuturiste commented #112
  • Sep 02 2018 12:01
    jettro commented #112
  • Aug 31 2018 14:01
    lefuturiste opened #112
  • Oct 03 2017 17:33
    ChristianAlexander synchronize #111
  • Oct 03 2017 17:31
    ChristianAlexander opened #111
  • Jul 28 2017 08:27
    xzer commented #109
  • Jul 28 2017 08:25
    xzer commented #110
  • May 11 2017 18:41
    sdiver78 commented #109
  • May 03 2017 18:11
    jettro commented #110
  • May 03 2017 18:10
    jettro commented #110
  • Apr 13 2017 22:57
    Akhilesh-Anb edited #110
  • Apr 13 2017 22:51
    Akhilesh-Anb opened #110
  • Mar 02 2017 19:55
    jettro commented #109
  • Mar 02 2017 14:16
    MetalArend commented #109
  • Oct 28 2016 21:07
    jettro commented #109
  • Oct 28 2016 17:08
    arnoldvilleneuve opened #109
  • Oct 12 2016 19:34
    kalwar commented #107
  • Oct 12 2016 19:32
    kalwar commented #107
  • Aug 09 2016 06:31
    jettro closed #103
Jettro Coenradie
@jettro
Are you sure? Don’t you see anything? This link shows me the main page http://www.gridshore.nl/esgui/#/dashboard
Rinaldo Di Giorgio
@digitalrinaldo
I just tried to install the plugin on Elasticsearch 2.0 and get the following error
Trying https://github.com/jettro/elasticsearch-gui/archive/master.zip ...
Downloading ................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................DONE
Verifying https://github.com/jettro/elasticsearch-gui/archive/master.zip checksums if available ...
NOTE: Unable to verify checksum for downloaded plugin (unable to find .sha1 or .md5 file to verify)
ERROR: Could not find plugin descriptor 'plugin-descriptor.properties' in plugin zip
Jettro Coenradie
@jettro
Sorry I missed your comment. This week-end I fixed the plugin to be ready for 2.0. It works for me. Can you try again @digitalrinaldo
Ron Cordell
@rocket-ron
I just tried out the lasted gui plugin on an elasticsearch 2.0 installation; unfortunately I'm unable to get it to work. The GUI is there but the pages say "ALERTunknown error" at the top. I'm probably missing something silly. I enabled cors and set the allow-origin as described....
Jettro Coenradie
@jettro
Hmm, annoying, did you install it as a plugin in elasticsearch?
@rocket-ron Can you maybe check the browser logs to see if there is more information, did you install it as a plugin?
Ron Cordell
@rocket-ron
Yes, I installed as a plugin as directed in the Readme.md on github. I will check the browser logs but it will be later this evening. Cheers!
Rinaldo Di Giorgio
@digitalrinaldo
I just installed the lastest master and I am getting an ALRT message "Unknown Error" on the landing screen
Rinaldo Di Giorgio
@digitalrinaldo
I would like to work on a change if you would consider it. ON the landing page I would suggest that the index listing become accordions so we could open them to display the json for the information about the index.
I would also like to suggest that the search page be refactored in a few ways the tag map like display needs more space between each entry and the search doesn't work for the simplest types of search
Ron Cordell
@rocket-ron
Hi, sorry for the delay in response. First, to answer your questions - yes, I installed as a plugin. However I was just able to get it working by clicking the gear icon in the upper right corner. The proper IP address was shown but it wasn't working until I clicked the "change" button. The status in the upper right said "No Connection" but after I clicked the "change" button it connected, showed the cluster and nodes and everything works.
It's great! Thanks for taking the time to respond to my questions! Cheers!
Jettro Coenradie
@jettro
Hi @digitalrinaldo I always consider enhancements and bug fixes. As for your questions: Not sure about the json for information about the index. In this plugin I try to limit the amount of json, would prefer a table or something. Maybe open an issue and do some discussion in there? Visual improvements are always nice and curious about the simplest type of search that does not work. And finally you bug with the unknown error, I hope I have resolved it, there was an issue with the configuration when the plugin was installed on a remote server.
david-wilson
@david-wilson
Hi. I've configured my search fields to show specific fields for "title" and "description", but all I see in my search results is "Show terms". Is there something else I need to be doing?
Jettro Coenradie
@jettro
Hi @david-wilson Maybe the scope you are searching in is to wide, to many indices? Than you might find the documents without the configured title/description. It could also be a bug. Did some fixes the last week, but had a very big refactoring so some issues might still be there. Will do some testing myself, but if you can give a hint on the index you use, than I might be able to help.
david-wilson
@david-wilson
@jettro have only one index in this case
Jettro Coenradie
@jettro
Hi @david-wilson sorry for the late response. If you still feel up for it, you can retest it, there was indeeded a regression test in the project. I have fixed it and it seems to work now.
Nejc Vukovic
@nvwebd
Question (maybe a dumb one since I’m just starting with elastic search): are the search queries send to ES handled in a async manner?
By this I mean: if I send 5 same queries to elasticsearch from Node env (that take the same amount of time) I would get the back in the same time?
Jettro Coenradie
@jettro
Yes, the queries are using futures in java and promises in javascript. You can use promises to wait for multiple responses to return though
Vinay M
@rmdort
Hi. Any ES experts here? I have a question on how to accomplish a feature in ES

What i want is to send a custom parameter to ElasticSearch and get it back in the results
Eg: { query: 'asdasd', timestamp: '123123123'}

And in the results i want to get { timestamp: '123123123', hits: []}

Jettro Coenradie
@jettro
Hard to call yourself an expert :-), but to my knowledge this is not possible @rmdort
Vinay M
@rmdort
ok Noted. Thanks jettro. I am trying to do an Instant search feature with ES. Will check out if there is any other work around.
Howard
@hwrdtm
Hi all! I am working with ES on my node server and ive got a couple of questions. Is this the official ES channel?
Jettro Coenradie
@jettro
Haha, no sorry, it is the channel for the plugin I have created. But since I am online I might be able to help you out.
Howard
@hwrdtm

Okay, so the issue is translating from SQL to the ES DSL and getting right results. I am essentially trying to do a SELECT * FROM items WHERE ("queryString" IN "tags") AND (date.NOW <= "deadline") OR ("age" >= 18);

With a mixture of ANDs and ORs I believe I should be using the bool query tool from ES? Is it possible to do a multi_match inside a bool query?

Jettro Coenradie
@jettro
Yes, you can play with the must / must_not and should. You can do any query you want within one of those blocks.
myoung34
@myoung34
Where could i go to ask some questions about curator (ES related) ?
Jettro Coenradie
@jettro
I would try stack overflow, usually people respond pretty quick
Ori Newman
@someone235
someone is here?
Jettro Coenradie
@jettro
I am now
Ori Newman
@someone235
Hi, when I use elasticsearch head, I get HTTP 403 for _search
someone knows why and how to fix this?
Jettro Coenradie
@jettro
You have to tell me a bit more, what is your setup? Anything in the log of elastic? What is the url you are using?
Jettro Coenradie
@jettro
A 403 free usually means you have no rights, do you have a load balancer in front of your elasticsearch service. Are you running the client remote (not localhost). You might need to do the CORS settings thing.
世外桃源 KPT-D
@jjhesk
hi what is the best way to query over indices
Deano
@amlife
Hi everyone
dose elasticsearch-gui work with 5.0.0?
When I attempt to install it via "./elasticsearch-plugin install elasticsearch-gui" I get "ERROR: Unknown plugin elasticsearch-gui"
Jettro Coenradie
@jettro
No it does not, elasticsearch has removed the option to install as a site plugin. You should be able to run it as a website and connect to elastic remote. I am thinking about what to do for elastic 5 support. Could go for the Kibana plugin, but that is not what I really want.
Fizer Khan (பைசர் கான்)
@fizerkhan
hey, I want to calculate percentile for response time field. Single documents can have multiple metrics. How do i calculate percentile without writing them as single document? This is the sample data: http://pastebin.com/NS49b7VX
tiggyboo
@tiggyboo
When I try the recommended install, i.e., bin/elasticsearch-plugin install jettro/elasticsearch-gui, I get ERROR: Unknown plugin jettro/elasticsearch-gui. Any suggestions?
alexpivtorak
@alexpivtorak
Hey guys, can I get here any help about ES query ?
Jettro Coenradie
@jettro
@tiggyboo Sorry I didn't notice your question. Still curious though, what version were you installing the plugin into?
@alexpivtorak I can try :-)
paraskashyap
@paraskashyap
hey i used elastic search in pelias and this error occurred