These are chat archives for jheinen/GR.jl

31st
Aug 2016
Robert Luke
@codles
Aug 31 2016 10:44
Ive been running in to a problem getting GR to play nice on windows with Plots.jl. Wasn't which packages gitter to ask this...

Using jupyter and julia0.4 i run

using Plots
gr()
plot(rand(44, 4))

and get

[Plots.jl] Initializing backend: gr

SystemError: opening file C:\Users\rluke\AppData\Local\Temp\julFFAA.tmp.svg: No such file or directory

However I can see and open the file using explorer. Any tips on what I am doing wrong?

I have the latest GR checked out
Christopher Rackauckas
@ChrisRackauckas
Aug 31 2016 14:33
Pkg.build("GR")?
alblaz
@alblaz
Aug 31 2016 14:36
Is GR supposed to work properly on windows? I can plot but I can't save png files and if I close a window I can't open it anymore. I'm on windows 10, GR => v0.14.0+ , and julia Version 0.5.0-rc3+0.
Christopher Rackauckas
@ChrisRackauckas
Aug 31 2016 14:52
It should
Josef Heinen
@jheinen
Aug 31 2016 14:55
GR (master) works fine on Windows (with PNG support). Plots + gr() produces the above mentioned error!? I still have no idea ...
Screen Shot 2016-08-31 at 16.57.33.png
Josef Heinen
@jheinen
Aug 31 2016 15:01
If your are missing PNG support on Windows, you probably have the wrong GR run-time. I had to remove temporary files on my Windows VM (using the system tools), because Windows seems to cache the download files ... :-1:
@codles : I can re-produce this system error, although GR (itself) works fine. I'll check this ...
alblaz
@alblaz
Aug 31 2016 15:21
I think I'm missing PNG support because I can't save figures when using GR by itself. I did a fresh install of julia yesterday and I added all the packages from scratch. And yes when I run gr from
Plots I get the error
SystemError: opening file C:\Users\alaz\AppData\Local\Temp\jl_66ED.tmp.png: No such file or directory in #systemerror#51 at .\error.jl:34 [inlined]
I'll check out how to remove temporary files
Christopher Rackauckas
@ChrisRackauckas
Aug 31 2016 16:09
Oh that, yeah I've had that for awhile.
I should've reported it.
Josef Heinen
@jheinen
Aug 31 2016 16:29
It seems that we need something like GR.versioninfo():
           C: yes [Apple LLVM version 8.0.0 (clang-800.0.31)]
         C++: yes [Apple LLVM version 8.0.0 (clang-800.0.31)]
      Python: yes [version 2.7.12 (default, Jun 28 2016, 22:12:26) ]
       LaTeX: yes [version 3.14159265-2.6-1.40.17]
      dvipng: yes [version 1.15]
         Qt4: yes [version 4.8.7]
         Qt5: yes [version 5.5.1]
   wxWidgets: yes [version 3.0.1]
        GTK+: yes [version 2.24.19]
         X11: yes [/opt/X11]
         Xft: yes [version 2.3.2]
 Ghostscript: yes [revision 914]
        GLFW: yes [version 3.2.0]
         0MQ: yes [version 4.0.4]
      ffmpeg: yes [ffmpeg version 2.1.4]
       MuPDF: yes [version 1.6]
       Cairo: yes [version 1.14.6]