Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    aiasmartakis
    @aiasmartakis
    The project was not built since its build path is incomplete. Cannot find the class file for javax.servlet.ServletContext. Fix the build path then try building this project
    the same project works fine in intellij
    i have to change the pom file to make it go away
    (would need to add)
        <dependency>
            <groupId>javax.servlet</groupId>
            <artifactId>javax.servlet-api</artifactId>
            <version>3.1.0</version>
            <scope>provided</scope>
        </dependency>
        <dependency>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-starter-undertow</artifactId>
            <scope>provided</scope>
        </dependency>
    i'd rather not do pom changes specific to vscode
    any ideas?
    oh i made sure to set the JAVA_HOME to my 1.8 JDK
    both from settings.json and also user environment
    Christophe Bornet
    @cbornet
    This doesn't look like a problem of jhipster-ide
    I think you need to activate a maven profile (dev or prod)
    aiasmartakis
    @aiasmartakis
    oh im sorry
    wasnt sure where to post this
    Christophe Bornet
    @cbornet
    Do you launch the project with maven or from the IDE ?
    aiasmartakis
    @aiasmartakis
    i wanted to debug the project eventually
    command line everything works
    i also was able to set the maven profile in the vscode settings
    but that doesnt seem to affect running it outside the application
    sorry inside
    Christophe Bornet
    @cbornet
    I don't debug with vscode, sorry. You should ask your question on the main channel. You'll get a larger audience
    Serano Colameo
    @colameo
    I’ve tried this once and it worked for me: https://code.visualstudio.com/docs/java/java-debugging
    but agree, I would use IntelliJ or Eclipse which have a better support for debugging java
    aiasmartakis
    @aiasmartakis
    ok
    thanks
    i had it working previously
    must be something with vscode
    (in windows and on a mac)
    i think i've seen the error before too
    but i thought it had to do with setting the classpath or JAVA_HOME correctly
    aboubakrndong
    @aboubakrndong
    Hello guys,
    I created a project with jhipster by choosing elastic search as a search engine. it's been days since I got this bug, yet i started elastic search with the docker-compose command,
    someone to help me please !!!
    image.png
    Marcos Patricio
    @marcospatricio_twitter
    Hi everybody, anyone has a code sample or project template to build a dashbord using d3.js and JHipster?
    Serano Colameo
    @colameo
    please post this kind of questions in the appropriate channel @aboubakrndong @marcospatricio_twitter. This channel is only and exclusevely for the JHipster IDE (https://www.jhipster.tech/jhipster-ide)
    talk2starGit
    @talk2starGit
    Hello , can I get a sample application to get started with Jhipster & VS Code IDE? I have never used any of these tools before so struggling a bit . Thanks
    talk2starGit
    @talk2starGit
    Anyone to help with Jhipster & Visual Studio Code IDE ? @colameo , thanks but the link you provided is not about visual studio code IDE
    Serano Colameo
    @colameo
    @talk2starGit don’t understand what exactly u r a looking for… the vscode extension for jhipster has less features for “beginners” and therefore it’s better to start with the eclipse version
    Serano Colameo
    @colameo
    1. install jhipster
    2. mkdir myapp
    3. cd myapp
    4. code mymodel.jdl and wait until jhipster ide has been started
    5. add application config section and entities in the jdl
    6. open a terminal or go back to your previous terminal session and import jdl with jhipster import-jdl ./mymodel.jdl
    7. build your app and run it as spring-boot app
    have also a look to this repo https://github.com/jhipster/jdl-samples
    talk2starGit
    @talk2starGit
    Thanks a lot @colameo . Somehow eclipse IDE had installtion problems so went for VS IDE.
    Serano Colameo
    @colameo
    @talk2starGit there was a security issue in the eclipse marketplace, but that is now fixed. btw, the eclipse plugin for JHipster has more features as vscode.
    chenpenghui93
    @chenpenghui93
    Why is there no redis password attribute?(in the class "JHipsterProperties")
    Are there any special considerations?
    chenpenghui93
    @chenpenghui93
    image.png
    Jim van Dam
    @emagine-reality
    Hi, I am planning to add a UI DSL referencing JDL using xtext. If I understand the current flow for JDL correctly it uses xtext for the DSL entities file and editor, but then parses using chevrotain, transforms to json and then generates using ejs templates. Would there be objections against using xtend templates to generate to a UI target in a custom blueprint using this UI DSL? Contributors, please let me know how you feel about this, if I misinterpreted the flow or if I should raise this discussion somewhere else.
    talk2starGit
    @talk2starGit
    Any specific settings to choose when importing an Jhipster app into Eclipse IDE ? Need to edit the application using Eclipse but not able to load the application successfully in Eclipse.
    Serano Colameo
    @colameo
    have you installed/configured eveything as described here: https://www.jhipster.tech/configuring-ide-eclipse/
    Kiranmunivenkatappa
    @Kiranmunivenkatappa

    Hello Guys, I am trying to create the microservice with spring web flux using Jhispter generate with version 6.10.1.
    generation works fine, however, when I start service and try to call it from the registry swagger UI, I get "Forbidden /services/reactivemicroservice/reactivemicroservice:75f727caed86aac2799c3322a21b0261/v2/api-docs". I tried with plain microservice(without spring web flux) it works absolutely fine. Can anyone guide me on this ti slove it?.

    Thanks,
    Kiran