Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 22 2016 10:49
    kibotu starred jitpack/jitpack.io
  • Jan 22 2016 08:26
    jitpack-io closed #388
  • Jan 22 2016 08:26
    jitpack-io commented #388
  • Jan 22 2016 08:22
    jitpack-io closed #386
  • Jan 22 2016 08:22
    jitpack-io commented #386
  • Jan 22 2016 08:00
    jitpack-io commented #394
  • Jan 22 2016 08:00
    jitpack-io closed #394
  • Jan 22 2016 07:59
    jitpack-io commented #393
  • Jan 22 2016 04:28
    asadyarkhan007 opened #394
  • Jan 22 2016 04:27
    asadyarkhan007 opened #393
  • Jan 21 2016 21:57
    jitpack-io closed #392
  • Jan 21 2016 21:57
    jitpack-io commented #392
  • Jan 21 2016 21:56
    jitpack-io closed #391
  • Jan 21 2016 21:56
    jitpack-io commented #391
  • Jan 21 2016 21:53

    jitpack-io on master

    Update PRIVATE.md (compare)

  • Jan 21 2016 18:34
    renaudcerrato commented #392
  • Jan 21 2016 18:26
    jitpack-io commented #392
  • Jan 21 2016 18:25
    renaudcerrato commented #392
  • Jan 21 2016 18:23
    jitpack-io commented #392
  • Jan 21 2016 18:20
    renaudcerrato commented #392
pradeep-plenty
@pradeep-plenty
quickstats says 1 monitor is down
Eric
@es0329
Our pipelines are failing on JitPack 403s for private repos. Is there someone to troubleshoot with us?
Neeraj-Android
@Neeraj-Android
Hi, Getting "No read access to repo" for private gitlab repo in jitPack website during creation of dependency
David
@tipsy
:wave: i got a user report saying jitpack chooses the wrong module from a multi-module project, is there some configuration i have to do?
the "subproject" dropdown appears to be missing
Xiaoyu PENG
@xy-peng
Download Statistics is down? always show 'There seems to be an issue connecting to our servers. Please try again in a few minutes.'
Dom Rodriguez
@shymega
hi, i'm having issues with my artifacts being built, but no maven-metadata.xmlbeing generated - only maven-metadata-local.xml being generated, which means I can't include my artifact in my project.
I'm using Maven in the project. Is anyone else having this issue?
Xtizainy
@Xtizainy

Hello, I am trying to build my org's repo, but instantly getting

Subscription is not active right now
Requested subscription: github.com/.... 
Your subscriptions are listed in User Settings.
Please contact Support or repository admins if you need assistance.

I have paid account and my org admin approved the request. What could be the problem?

Ivan Schütz
@i-schuetz
Hi, how to distribute an .aar with jitpack? (more specifically an .so, which I assume has to be packaged in .aar)?
Victor Borja
@vic
Hello, what is the process (and where is the right place) to ask for an improvement building scala sbt projects? Currently many scala projects are moving from 2.12.x to 2.13.x and in that process sbt lets you define a project as cross-compiled to different scala versions. However, the default install step on jitpack for sbt projects is sbt publishM2 when it would be much better to be sbt '+ publishM2' which would actually build all cross-version artifacts. Does this change sounds easy to implement? Having that would be great for many scala projects.
Victor Borja
@vic
Just created an issue on GH. jitpack/jitpack.io#4249
Steve Perkins
@steve-perkins
Hi. Has anyone ever setup a remote proxy for jitpack.io in Artifactory (or Nexus, etc)?
So that your repository would cache and hold onto dependencies? (and so you wouldn't have to declare jitpack.io as a additional repository source in your Maven or Gradle script)
I have created a remote repo in Artifactory, pointing to https://jitpack.io. But it doesn't work, and I'm not sure if I need to add any additional path or other weird settings.
Stanislav
@StanislavKosyakov_gitlab
Hello anyone, I build my android library that have a few source set, main, debug with Jitpack, I connected my lib thought gradle using jitpack generated code, but I can't see my classes from debug source set only see classes in main source set. Have idea how to fix it?
Vic C
@cekvenich
How do I enable latest version of gradle? Do I allow .gradle or gradle?
Reagan Middlebrook
@Reagankm

I'm getting "Failed to resolve" errors with jitpack and any repo. I've checked the FAQ and old questions on here, but still having trouble.

In my top level build.gradle, I added maven { url 'https://jitpack.io' } to the end of repositories. In my app level build.gradle dependencies I tried adding implementation 'com.github.jkwiecien:EasyImage:3.0.4' (the repo I actually want to use) and tried adding implementation 'com.github.jitpack:android-example:2.0' (for testing when I was getting failures).

Using the FAQ help at jitpack.io, I tried running ./gradlew --info --refresh-dependencies from the command line (at the top level of my app) but the output doesn't contain any "HTTP Could not get" errors of any kind. In fact if I search through the (very long) output, I can't find any reference to jitpack or EasyImage or android-example at all.

I'm clearly missing something very basic here, but not sure what.

Any ideas?

Reagan Middlebrook
@Reagankm
Solved it. If anyone else has the same issue, you have to add maven { url 'https://jitpack.io' } to your app-level build.gradle as well. Nothing goes in the top-level build.gradle. :doh:
Marc Esher
@marcesher

Hi folks. I have a question about git branches that jitpack.io will treat as the "main" branch.

On Project A, we are switching from "master" to "trunk" branch as our default branch, and deleting the "master" branch

On Project B, its build.gradle file includes the "-SNAPSHOT" build of Project A, like so:

'com.github.foo:PROJECT_A:-SNAPSHOT'

So it's using that :-SNAPSHOT short-hand, which I think is just a shorthand for master-SNAPSHOT.

My question is: for Project A, if we move to "trunk" and delete "master", will that :-SNAPSHOT syntax continue to work, if "trunk" is set as the default branch on github, or is there something special about "master" from jitpack's perspective that enables that shorthand syntax?

Thanks so much.

Ino de Bruijn
@inodb
is there some issue with the service?

getting

Authentication failed for https://jitpack.io/com/github/cbioportal/cbioportal-frontend/v3.4.2/cbioportal-frontend-v3.4.2.jar 401 Unauthorized

this is an open source project, so it shouldn't have auth issues?
Ino de Bruijn
@inodb
this link also does not seem to work anymore: https://jitpack.io/#cbioportal/cbioportal-frontend
still works fine for another repo where we use jitpack as well: https://jitpack.io/#cbioportal/cbioportal
Ino de Bruijn
@inodb
started working again, thanks for this great service! We use it a lot 🙏
mrmkh
@mrmkh
Hello
I tried to sign in the site many times
But it didn't happen and Stays in loading
Tom Schultz
@bearcattom
Hello...sign in is not working, no builds nothing
https://jitpack.io/login - does it work for anyone?
Jack Osterman
@JackOsterman
Also unable to log in here
Juan Carlos Chávez Montes
@jcchavezm
Also having trouble signing in, help!
soportepagando
@soportepagando
i'm unable to login or access the repository
Hanno Gödecke
@hannojg_gitlab
service is completely down for me, everyone else?
Vic C
@cekvenich
I filed a bug: jitpack/jitpack.io#4260
GabrielTK
@GabrielTK
Hey, everything seems to be down for me, including maven
coingaming-jitpack
@coingaming-jitpack
hi, we ordered a paid subscription, yet the subscription was connected to a wrong github repository. no response from jitpack@jitpack.io in a week to help me. could i get some help here?
1 reply
mrmkh
@mrmkh
My library is not built and there is no error

BUILD SUCCESSFUL in 612ms
4 actionable tasks: 1 executed, 3 up-to-date
Build tool exit code: 0
Looking for artifacts...
Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=UTF-8 -Dhttps.protocols=TLSv1.2
Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=UTF-8 -Dhttps.protocols=TLSv1.2
Looking for pom.xml in build directory and ~/.m2
2020-07-06T19:04:15.246822661Z
Exit code: 0

ERROR: No build artifacts found

Nuwan Sanjeewa Abeysiriwardana
@nuwansa
Hi, i'm getting following error when i include plugin in build process.
Plugin's descriptor contains the wrong group ID: com.cloudimpl, Plugin's descriptor contains the wrong version: 2.0.0
plugin is look like this.
<plugin>
                <groupId>com.github.cloudimpl.errorcode4j</groupId>
                <artifactId>errorcode-generator</artifactId>
                <version>2.0.0.10</version>
                <executions>
                    <execution>
                        <phase>generate-sources</phase>
                        <id>xxx</id>
                        <goals>
                            <goal>ErrorCodeGenerator</goal>
                        </goals>
                        <configuration>
                        </configuration>
                    </execution>
                </executions>
            </plugin>
Darlan Borges
@darlanxw
Hello, I published my library and it work's fine, but when I added a depedency (aar) into the library, the project that's consumes the library, doesn't found the aar depedency. I need to make this aar (inside library) exportable or how can I create another lib just with aar?
Chaitanya Potti
@chaitanyapotti

Hello, i'm unable to fetch my project when using the custom domain name

Unable to resolve dependency for ':torusdirect@debugUnitTest/compileClasspath': Could not resolve org.torusresearch:fetch-node-details-java:1.0.5.

But, it works when using github name com.github.torusresearch:fetch-node-details-java:1.0.5.
https://jitpack.io/#org.torusresearch/fetch-node-details-java/1.0.5

Frekis
@frekis
Setting icon is not showing for private repos... As mentioned in artifact sharing doc https://jitpack.io/docs/PRIVATE/#artifact-sharing
I have subscribed to one of your JitPack Plan.. Artifact sharing option is not there for private repos.. I have to change it to everyone
Hayden
@LovinLifee
Heya! I'm trying to access the latest successful build using the jitpack rest api. https://jitpack.io/api/builds/com.github.LovinLifee/Avuna is totally valid and yields expected results but when I append /latestOk to the end of the URL it appears to be empty even though I do have successful builds.
Sidhant Srikumar
@sid9102
Hi, I'm wondering if there are any bandwidth/storage limits for paid plans
Sanalogi Corp.
@Sanalogi
Hi
I bough monthly package . But my subscription is inactive.
I write to you many mail . but you don't write answer. what is the problem
?
Sanalogi Corp.
@Sanalogi
wht is the support telephone number