Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Oct 12 15:36
    olemr commented #70
  • Oct 12 15:31
    olemr commented #70
  • Oct 12 13:07
    ardevd labeled #70
  • Oct 12 13:06
    ardevd commented #70
  • Oct 12 11:22
    olemr opened #70
  • Oct 07 20:07

    ardevd on v1.3.1

    (compare)

  • Oct 07 20:05

    ardevd on master

    updated version info for v1.3.1 (compare)

  • Oct 07 20:03

    ardevd on 68-swu-return-data

    (compare)

  • Oct 07 20:02

    ardevd on master

    properly return wake up timer d… (compare)

  • Oct 07 20:02
    ardevd closed #69
  • Oct 07 20:02
    ardevd closed #68
  • Oct 07 19:57
    ardevd milestoned #68
  • Oct 07 19:57
    ardevd assigned #69
  • Oct 07 19:57
    ardevd opened #69
  • Oct 07 19:57

    ardevd on 68-swu-return-data

    properly return wake up timer d… (compare)

  • Oct 07 19:55
    ardevd labeled #68
  • Oct 07 19:55
    ardevd assigned #68
  • Oct 07 19:55
    ardevd opened #68
  • Aug 31 17:50
    ardevd commented #59
  • Aug 30 18:39
    mattnewham commented #59
Karl Gustav
@karl-gustav
But after a while I run into issues that the JLR app complains about “error with remote charging profile”.an’t I use the api with the same user on two different deviceUUID?
*Can’t
Do I need to log out from the JLR app?
ardevd
@ardevd
That shouldn't be necessary. I use my account with a large number of different device uuids. However, the API is full ofnquriks
Of quirks*
So it
It could also just be a temporary issue
Server side that is
Karl Gustav
@karl-gustav
Maybe. But the last time this happened the car dealer removed the car from my account. And when I re-added i
...the car everything worked again.
And it happened the last time after I had messed around with the api’s. I don’t know 😞, maybe it is just a temporary problem.
On a related note. How do we get error messages from the API? Because when I for instance stop charging the response is always 200 OK. Regardless if it worked or not.
ardevd
@ardevd
The API returns 200 OK because the request was accepted and the service is started. The service might still fail which why you should check service status following the request
which will also indicate whether it's still running.
which is basically the InControl service communicating with your car via SMS
so when you request charging to stop, it's basically an asynchronous operation
from the perspective of the client
Also, I've played around with the API more than most and have never had any issues, really
So I highly doubt interacting with the API should itself cause issues
But there could certainly be bugs out there
That you trigger with certain requests or interactions
Karl Gustav
@karl-gustav
Anybody here seen this error message?
Is there any way to cancel a request? Get the car back to ready state maybe?
{
    "status": "Failed",
    "statusTimestamp": "2019-10-09T09:26:21+0000",
    "startTime": "2019-10-09T09:26:20+0000",
    "serviceType": "CP",
    "failureReason": "NegativeAcknowledge",
    "failureDescription": "parameterAlreadyInRequestedState",
    "customerServiceId": "<service ID>",
    "vehicleId": "<vin>",
    "active": false,
    "initiator": "USER",
    "eventTrigger": null,
    "serviceCommand": null,
    "serviceParameters": [
        {
            "key": "CHARGE_NOW_SETTING",
            "value": "FORCE_OFF"
        }
    ]
}
ardevd
@ardevd
Ive never seen parameterAlreadyInRequestedStatebefore. Are you saying this error occurs every time you try to pause charging?
Karl Gustav
@karl-gustav
yup
ardevd
@ardevd
and the car is actually charging when you send that request?
(dumb question, just making sure)
Karl Gustav
@karl-gustav
Totaly understandable:-) Yes the car is definitely charging. But as a side note I’m not able to stop it from the
Jaguar remote app either....
ardevd
@ardevd
Seems like there is something wrong with your vehicle and/or InControl account then I'm afraid
You're on TCU 16.2?
Toni Trop
@ttrop_gitlab
I ve seen parameterAlreadyInRequestedState in my loop for changing pausing and unpausing. Actually its been more of a recent thing. The loop just kept going and eventually got the result I wanted. Car is 14.2
ardevd
@ardevd
If you're on 14.2 then you will have issues with remote charging control.
16.2 fares much better.
Karl Gustav
@karl-gustav
I’m on 16.2 😞
I have an appointment at the mechanic in 8 days. I’ll try and see if I can get an explanation on what parameterAlreadyInRequestedState actually means...
ardevd
@ardevd
Good stuff :)
and good luck
you'll need it ^^
ardevd
@ardevd
Anyone else having issues with InControl at the moment?
stefferber
@stefferber
No problems so far
stefxx
@stefxx
Yes. All day.
ardevd
@ardevd
yes as in working all day or issues all day?
Pekka Kaipiainen
@pekkaipi_twitter
There have been connectivity issues with InControl today and others have reported them too in I-Pace Facebook groups
christian voldsund
@cvold_twitter
I've also had issues today from around 11 am (Norway)
stefxx
@stefxx
Sorry. Issues all day.
ardevd
@ardevd
Good to hear I'm not alone
It seems to be working again now
but who knows for how long
seems to be very slow and unstable at the moment
Arne Henriksen
@ArneHenriksen
Hi guys - as I'm on iOS the famous WattCat is not an option for me...
Anyone tested running python scripts on iOS, using tools like http://omz-software.com/pythonista/ ?