These are chat archives for joefitzgerald/go-plus

22nd
Aug 2016
risk danger olson
@technoweenie
Aug 22 2016 20:07
hey all, when I try to invoke the go autocompleter, it only ever comes back with PANIC. does that mean my go env is busted in atom?
it tells me about compilation errors and go vet, so it's not that broken
welp, i think i was missing the environment plugin for atom. installed that, re-installed gocode, and it works
chat is great for rubber ducking sometimes
Joe Fitzgerald
@joefitzgerald
Aug 22 2016 22:35
@technoweenie nothing to do with the environment package
running gocode close && go get -u github.com/nsf/gocode will always do the trick
had a chat with Nathan Bass on Slack resulting in: joefitzgerald/autocomplete-go#44
in essence: you need to close the gocode daemon after you upgrade go to a new version