Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 2019 20:18
    greenkeeper[bot] labeled #868
  • Jan 31 2019 20:18

    greenkeeper[bot] on flow-bin-0.92.0

    chore(package): update flow-bin… chore(package): update lockfile… (compare)

  • Jan 31 2019 20:18
    greenkeeper[bot] opened #868
  • Jan 31 2019 16:18
    purehyperbole starred joefitzgerald/go-plus
  • Jan 31 2019 05:15
    hjyun328 commented #861
  • Jan 31 2019 04:32

    greenkeeper[bot] on prettier-1.16.3

    (compare)

  • Jan 31 2019 04:23

    greenkeeper[bot] on prettier-1.16.3

    chore(package): update prettier… chore(package): update lockfile… (compare)

  • Jan 31 2019 03:32
    hjyun328 commented #861
  • Jan 31 2019 03:31
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:28
    hjyun328 commented #861
  • Jan 31 2019 03:28
    hjyun328 commented #861
  • Jan 31 2019 03:26
    hjyun328 closed #861
  • Jan 31 2019 03:25
    hjyun328 commented #861
  • Jan 31 2019 03:25
    hjyun328 commented #861
  • Jan 31 2019 03:19
    hjyun328 commented #861
  • Jan 31 2019 03:14
    hjyun328 commented #861
David Komer
@dakom
Ah!! cool I found the solution for gocode - setting lib-path: gocode set lib-path C:\Users\david\Documents\GOPATH\pkg\windows_amd64_appengine
:D
(and auto-build off since gocode doesn't use goapp... not sure whether or not it's a race condition against your builder-go, but anyway to get around that I guess I could periodically run goapp install or trigger builds then try again or whatever)
David Komer
@dakom
Though I will say - getting off of goapp would be great... right now I'm only doing appengine stuff... I don't even want to think what the nightmare would be if I was going back and forth between appengine and vanilla go :\
Joe Fitzgerald
@joefitzgerald
Cool glad you found the solution
Alexey Mozzhakov
@alexmozzhakov
hey! can somebody help me installing gocode on mac? Atom says
package github.com/nsf/gocode: cannot download, $GOPATH not set. For more details see: go help gopath, but i already have set up my $GOPATH
Joe Fitzgerald
@joefitzgerald
Set your GOPATH ?
What shell do you use?
export GOPATH=/Users/yourusername/go
In .profile or .bash_profile or .zshrc
also, make sure $GOPATH/bin is in your path
@alexmozzhakov
quit atom and relaunch if you have already done this
Alexey Mozzhakov
@alexmozzhakov
In .profile or .bash_profile or .zshrc can u explain?
Joe Fitzgerald
@joefitzgerald
Finally if that still doesn't work, install the atom shell launchers and invoke GOPATH=/path/to/your/gopath atom .
@alexmozzhakov that is a shell initialization script
run every time you launch a new terminal
Alexey Mozzhakov
@alexmozzhakov
thanks a lot! @joefitzgerald
Roy van Zanten
@rvzanten
Hello. Iam having a problem with missing errors when saving. But when I build the go application manually in the terminal it returns a bunch of errors. Back in the days go-plus also showed all build errors this when saving the application in Atom. How should I fix this? There is one console error in Atom: "[Package-Deps] Unable to get package info for json-lint-provider" Maybe this is related?
I am running Atom version 1.8 by the way. Thanks for any help.
Erthy
@ErthyLoL_twitter
Hey, just installed atom and go-plus on Windows 10 and even though Atom shows everything as installed, nothing is working, no gofmt, no autocomplete, nothing. Any hints?
Joe Fitzgerald
@joefitzgerald
You have to have your GOPATH set correctly
You have a few options: 1) set it as a user environment variable and log out / log in 2) system environment variable and reboot or 3) set the config in go-config package settings for GOPATH
@ErthyLoL_twitter
Erthy
@ErthyLoL_twitter
'C:\Users\roese>go env
set GOARCH=amd64
set GOBIN=
set GOEXE=.exe
set GOHOSTARCH=amd64
set GOHOSTOS=windows
set GOOS=windows
set GOPATH=C:\BTSync\Developing\Go
set GORACE=
set GOROOT=C:\Go
set GOTOOLDIR=C:\Go\pkg\tool\windows_amd64
set GO15VENDOREXPERIMENT=1
set CC=gcc
set GOGCCFLAGS=-m64 -mthreads -fmessage-length=0
set CXX=g++
set CGO_ENABLED=1'
I think my GOPATH is set, the only question is if correctly.
(Sorry for not quite understanding everything and for such a prompt response @joefitzgerald !)
Joe Fitzgerald
@joefitzgerald
In atom type ctrl-alt-i to open the chromium inspector; then go to console and type process.env.GOPATH
Erthy
@ErthyLoL_twitter
process.env.GOPATH
"C:\BTSync\Developing\Go"
That looks good, right?
Joe Fitzgerald
@joefitzgerald
Yup. The only other thing to check is that $GOPATH/bin is in your path
Erthy
@ErthyLoL_twitter
That might actually not be the case!
I tried to add C:\BTSync\Developing\Go\bin to my PATH. Is restarting Atom enough to test it out, or do I need to relog/restart?
Erthy
@ErthyLoL_twitter
restarting atom was enough. thank you for your help sir and have a wonderful day! :)
Bas van Beek
@basvanbeek
On Mac OS X autocomplete seems to only work for standard lib packages but not for packages in GOPATH. I checked process.env.GOPATH and it's set properly. Is there anything else I can do or check?
Joe Fitzgerald
@joefitzgerald
You just updated to go 1.7?
Bas van Beek
@basvanbeek
I have updated but have had this issue with 1.6 too
Joe Fitzgerald
@joefitzgerald
In your terminal run gocode close && go get -u github.com/nsf/gocode
You have to do this every time you update your go version
Bas van Beek
@basvanbeek
did not help
might have found it by inspecting some stuff in gocode... seems I had an old brew install lingering around...
Bas van Beek
@basvanbeek
uninstalled the brew install, did the gocode close stuff and rebooted... still no luck
Bas van Beek
@basvanbeek
found the issue... some messed up gocode settings... thanks for the help
Joe Fitzgerald
@joefitzgerald
What was messed up about them @basvanbeek ?
Bas van Beek
@basvanbeek
somehow package lookup mode was set to gb... i don't use gb and all is in normal gopath
Gergely Brautigam
@Skarlso
THanks @joefitzgerald! This actually helped me. :)
I mean this bit -> gocode close && go get -u github.com/nsf/gocode
Now everything works fiiiiiiiiiine.
Maxim Tkachenko
@T-M-A
Thanks. autocomplete works fine :)
risk danger olson
@technoweenie
hey all, when I try to invoke the go autocompleter, it only ever comes back with PANIC. does that mean my go env is busted in atom?