Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 2019 20:18
    greenkeeper[bot] labeled #868
  • Jan 31 2019 20:18

    greenkeeper[bot] on flow-bin-0.92.0

    chore(package): update flow-bin… chore(package): update lockfile… (compare)

  • Jan 31 2019 20:18
    greenkeeper[bot] opened #868
  • Jan 31 2019 16:18
    purehyperbole starred joefitzgerald/go-plus
  • Jan 31 2019 05:15
    hjyun328 commented #861
  • Jan 31 2019 04:32

    greenkeeper[bot] on prettier-1.16.3

    (compare)

  • Jan 31 2019 04:23

    greenkeeper[bot] on prettier-1.16.3

    chore(package): update prettier… chore(package): update lockfile… (compare)

  • Jan 31 2019 03:32
    hjyun328 commented #861
  • Jan 31 2019 03:31
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:29
    hjyun328 commented #861
  • Jan 31 2019 03:28
    hjyun328 commented #861
  • Jan 31 2019 03:28
    hjyun328 commented #861
  • Jan 31 2019 03:26
    hjyun328 closed #861
  • Jan 31 2019 03:25
    hjyun328 commented #861
  • Jan 31 2019 03:25
    hjyun328 commented #861
  • Jan 31 2019 03:19
    hjyun328 commented #861
  • Jan 31 2019 03:14
    hjyun328 commented #861
Erthy
@ErthyLoL_twitter
I think my GOPATH is set, the only question is if correctly.
(Sorry for not quite understanding everything and for such a prompt response @joefitzgerald !)
Joe Fitzgerald
@joefitzgerald
In atom type ctrl-alt-i to open the chromium inspector; then go to console and type process.env.GOPATH
Erthy
@ErthyLoL_twitter
process.env.GOPATH
"C:\BTSync\Developing\Go"
That looks good, right?
Joe Fitzgerald
@joefitzgerald
Yup. The only other thing to check is that $GOPATH/bin is in your path
Erthy
@ErthyLoL_twitter
That might actually not be the case!
I tried to add C:\BTSync\Developing\Go\bin to my PATH. Is restarting Atom enough to test it out, or do I need to relog/restart?
Erthy
@ErthyLoL_twitter
restarting atom was enough. thank you for your help sir and have a wonderful day! :)
Bas van Beek
@basvanbeek
On Mac OS X autocomplete seems to only work for standard lib packages but not for packages in GOPATH. I checked process.env.GOPATH and it's set properly. Is there anything else I can do or check?
Joe Fitzgerald
@joefitzgerald
You just updated to go 1.7?
Bas van Beek
@basvanbeek
I have updated but have had this issue with 1.6 too
Joe Fitzgerald
@joefitzgerald
In your terminal run gocode close && go get -u github.com/nsf/gocode
You have to do this every time you update your go version
Bas van Beek
@basvanbeek
did not help
might have found it by inspecting some stuff in gocode... seems I had an old brew install lingering around...
Bas van Beek
@basvanbeek
uninstalled the brew install, did the gocode close stuff and rebooted... still no luck
Bas van Beek
@basvanbeek
found the issue... some messed up gocode settings... thanks for the help
Joe Fitzgerald
@joefitzgerald
What was messed up about them @basvanbeek ?
Bas van Beek
@basvanbeek
somehow package lookup mode was set to gb... i don't use gb and all is in normal gopath
Gergely Brautigam
@Skarlso
THanks @joefitzgerald! This actually helped me. :)
I mean this bit -> gocode close && go get -u github.com/nsf/gocode
Now everything works fiiiiiiiiiine.
Maxim Tkachenko
@T-M-A
Thanks. autocomplete works fine :)
risk danger olson
@technoweenie
hey all, when I try to invoke the go autocompleter, it only ever comes back with PANIC. does that mean my go env is busted in atom?
it tells me about compilation errors and go vet, so it's not that broken
welp, i think i was missing the environment plugin for atom. installed that, re-installed gocode, and it works
chat is great for rubber ducking sometimes
Joe Fitzgerald
@joefitzgerald
@technoweenie nothing to do with the environment package
running gocode close && go get -u github.com/nsf/gocode will always do the trick
had a chat with Nathan Bass on Slack resulting in: joefitzgerald/autocomplete-go#44
in essence: you need to close the gocode daemon after you upgrade go to a new version
risk danger olson
@technoweenie
ah, thanks for the context
Alexys Lozada
@alexyslozada
Hola, muchas gracias @joefitzgerald . Tenía problemas del plugin de autocompetado debido a que había actualizado a la versión 1.7 de GO. Pero con la ejecución del comando gocode close && go get -u github.com/nsf/gocode funcionó perfecto.
Hi @joefitzgerald , thank you, the trick work for me perfect!!!.
Ryan Sullivan
@KayoticSully
I signed in to also thank you for the gocode close && go get -u github.com/nsf/gocode tip. Fixed my problem perfectly! May I suggest that you add that to the "Having Issues?" section on the git repo. I think that will probably help a good number of people! Thanks again!
Josh Ault
@jault3
+1 for adding the gocode close part to the README. but I had an issue with code highlighting that I suspect is from the go-plus package but can't figure it out. Large chunks of my code are highlighted in red. does this seem familiar to anyone? can post a screenshot in a second
Screen Shot 2016-10-04 at 8.16.00 AM.png
Josh Ault
@jault3
moved to slack, that seems more active
Loren Hale
@halorium
@joefitzgerald Wow, I am having the same issue with autocomplete not working anymore. I think it was after upgrading Go. I also used brew this time to install Go. I tried the recommended: gocode close && go get -u github.com/nsf/gocode However this didn't seem to do anything for me.
Joe Fitzgerald
@joefitzgerald
@halorium please use slack in the future (see the topic)
run the golang:update-tools command
bound to ctrl-alt-shift-g u
i.e. press ctrl-alt-shift-g, release, then type u
Beard of War
@blainsmith
Anyone else having similar issues? joefitzgerald/go-config#62
Just noticed the move to slack. Sorry!
meprateek1986
@meprateek1986
How to get Autocomplete for go-plus?
i wrote fmt. and nothing showed up
meprateek1986
@meprateek1986
its working.. i just restarted and it worked..
amalho14
@amalho14
I am facing issues with go-plus where autocomplete of packages aren't working...this is faced on 2018/10/31 10:53:58 rpc: can't find service Server.Exit for gocode package dependencies...anyone know how to fix it?