Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 20:18
    greenkeeper[bot] labeled #868
  • Jan 31 20:18

    greenkeeper[bot] on flow-bin-0.92.0

    chore(package): update flow-bin… chore(package): update lockfile… (compare)

  • Jan 31 20:18
    greenkeeper[bot] opened #868
  • Jan 31 16:18
    purehyperbole starred joefitzgerald/go-plus
  • Jan 31 05:15
    hjyun328 commented #861
  • Jan 31 04:32

    greenkeeper[bot] on prettier-1.16.3

    (compare)

  • Jan 31 04:23

    greenkeeper[bot] on prettier-1.16.3

    chore(package): update prettier… chore(package): update lockfile… (compare)

  • Jan 31 03:32
    hjyun328 commented #861
  • Jan 31 03:31
    hjyun328 commented #861
  • Jan 31 03:29
    hjyun328 commented #861
  • Jan 31 03:29
    hjyun328 commented #861
  • Jan 31 03:29
    hjyun328 commented #861
  • Jan 31 03:29
    hjyun328 commented #861
  • Jan 31 03:28
    hjyun328 commented #861
  • Jan 31 03:28
    hjyun328 commented #861
  • Jan 31 03:26
    hjyun328 closed #861
  • Jan 31 03:25
    hjyun328 commented #861
  • Jan 31 03:25
    hjyun328 commented #861
  • Jan 31 03:19
    hjyun328 commented #861
  • Jan 31 03:14
    hjyun328 commented #861
Bas van Beek
@basvanbeek
uninstalled the brew install, did the gocode close stuff and rebooted... still no luck
Bas van Beek
@basvanbeek
found the issue... some messed up gocode settings... thanks for the help
Joe Fitzgerald
@joefitzgerald
What was messed up about them @basvanbeek ?
Bas van Beek
@basvanbeek
somehow package lookup mode was set to gb... i don't use gb and all is in normal gopath
Gergely Brautigam
@Skarlso
THanks @joefitzgerald! This actually helped me. :)
I mean this bit -> gocode close && go get -u github.com/nsf/gocode
Now everything works fiiiiiiiiiine.
Maxim Tkachenko
@T-M-A
Thanks. autocomplete works fine :)
risk danger olson
@technoweenie
hey all, when I try to invoke the go autocompleter, it only ever comes back with PANIC. does that mean my go env is busted in atom?
it tells me about compilation errors and go vet, so it's not that broken
welp, i think i was missing the environment plugin for atom. installed that, re-installed gocode, and it works
chat is great for rubber ducking sometimes
Joe Fitzgerald
@joefitzgerald
@technoweenie nothing to do with the environment package
running gocode close && go get -u github.com/nsf/gocode will always do the trick
had a chat with Nathan Bass on Slack resulting in: joefitzgerald/autocomplete-go#44
in essence: you need to close the gocode daemon after you upgrade go to a new version
risk danger olson
@technoweenie
ah, thanks for the context
Alexys Lozada
@alexyslozada
Hola, muchas gracias @joefitzgerald . Tenía problemas del plugin de autocompetado debido a que había actualizado a la versión 1.7 de GO. Pero con la ejecución del comando gocode close && go get -u github.com/nsf/gocode funcionó perfecto.
Hi @joefitzgerald , thank you, the trick work for me perfect!!!.
Ryan Sullivan
@KayoticSully
I signed in to also thank you for the gocode close && go get -u github.com/nsf/gocode tip. Fixed my problem perfectly! May I suggest that you add that to the "Having Issues?" section on the git repo. I think that will probably help a good number of people! Thanks again!
Josh Ault
@jault3
+1 for adding the gocode close part to the README. but I had an issue with code highlighting that I suspect is from the go-plus package but can't figure it out. Large chunks of my code are highlighted in red. does this seem familiar to anyone? can post a screenshot in a second
Screen Shot 2016-10-04 at 8.16.00 AM.png
Josh Ault
@jault3
moved to slack, that seems more active
Loren Hale
@halorium
@joefitzgerald Wow, I am having the same issue with autocomplete not working anymore. I think it was after upgrading Go. I also used brew this time to install Go. I tried the recommended: gocode close && go get -u github.com/nsf/gocode However this didn't seem to do anything for me.
Joe Fitzgerald
@joefitzgerald
@halorium please use slack in the future (see the topic)
run the golang:update-tools command
bound to ctrl-alt-shift-g u
i.e. press ctrl-alt-shift-g, release, then type u
Beard of War
@blainsmith
Anyone else having similar issues? joefitzgerald/go-config#62
Just noticed the move to slack. Sorry!
meprateek1986
@meprateek1986
How to get Autocomplete for go-plus?
i wrote fmt. and nothing showed up
meprateek1986
@meprateek1986
its working.. i just restarted and it worked..
amalho14
@amalho14
I am facing issues with go-plus where autocomplete of packages aren't working...this is faced on 2018/10/31 10:53:58 rpc: can't find service Server.Exit for gocode package dependencies...anyone know how to fix it?
pchaws
@pchaws
I just updated go-plus, my autocomplete stopped working, I installed autocomplete-go, go-get and go-config, they are getting removed. seems they are integrated in new verison on go-plus...
how can I make it work
Dmitry Kotik
@dkotik
autocomplete mess: it used to work, after recent updates stopped. Here is what I noticed: it works for objects in scope, but fails to autocomplete on argument objects
Saikat
@saikatd
@joefitzgerald I ran this
gocode close && go get -u github.com/nsf/gocode
and this started autocompleting for fmt, etc
but I still dont get attribute suggestions for struct variables
This was working before
saurabh hirani
@saurabh-hirani
@amalho14 late reply but I ran into the same issue and did a gocode -s -debug to find out my socket file - removed it and ran the gocode close && go get -u github.com/nsf/gocode as per above replies to get it working.
saurabh hirani
@saurabh-hirani
@joefitzgerald I second @saikatd - fixing gocode gives basic stuff but struct variables were working before. Is it related to go-plus or some other package.
saurabh hirani
@saurabh-hirani
@saikatd - closing gocode, starting it and enabling atom-ide-ui gives full autocompletion.
Tommy Back
@murr3katt_twitter
i've had go-plus working with autoformatting and including imports etc. i made an update to latest go-plus now and it's not working anymore and i see no errors anywhere. have already tried multiple things to uninstall and reinstall and all kind of combinations in the settings. any suggestions where to start troubleshooting? :)
go-plus 6.10 and atom 1.35
sakthig
@sakthig
hi all, i am new to golang
trying to follow go.mod
using which i am able to compile project with main package
but does nothing for non-main project
i do … go install ./…
and check $HOME/go/pkg..
there is no new library
any help on this .?
asdf23
@asdf23
When I start up atom, I get this:
/home/user1/go/bin/gocode stderr: flag provided but not defined: -unimported-packages
Usage: /home/user1/go/bin/gocode [-s] [-f=<format>] [-in=<path>] [-sock=<type>] [-addr=<addr>]
<command> [<args>]
I'm on fedora which uses go 1.13 I'm thinking -unimportant-packages has been depreciated..?
Sorry that's *1.11.13

$ go version
go version go1.11.13 linux/amd64

$ go env
GOARCH="amd64"
GOBIN=""
GOCACHE="/home/user1/.cache/go-build"
GOEXE=""
GOFLAGS=""
GOHOSTARCH="amd64"
GOHOSTOS="linux"
GOOS="linux"
GOPATH="/home/user1/go"
GOPROXY=""
GORACE=""
GOROOT="/usr/lib/golang"
GOTMPDIR=""
GOTOOLDIR="/usr/lib/golang/pkg/tool/linux_amd64"
GCCGO="gccgo"
CC="gcc"
CXX="g++"
CGO_ENABLED="1"
GOMOD=""
CGO_CFLAGS="-g -O2"
CGO_CPPFLAGS=""
CGO_CXXFLAGS="-g -O2"
CGO_FFLAGS="-g -O2"
CGO_LDFLAGS="-g -O2"
PKG_CONFIG="pkg-config"
GOGCCFLAGS="-fPIC -m64 -pthread -fmessage-length=0 -fdebug-prefix-map=/tmp/go-build022957457=/tmp/go-build -gno-record-gcc-switches"