Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Zach Langbert
    @zlangbert
    Hi, I'm pretty much a total chef noob and I'm trying to use this cookbook.
    I have cookbook 'consul', '~> 0.11.1' in my Berksfile
    depends 'consul' in metadata
    include_recipe 'consul' in my recipe
    It says it can't find consul_config, what am I doing wrong?
    Tomasz Sętkowski
    @tomzo
    version 0.11 has been changed significantly, it is no longer recommended to just include default recipe.
    A default recipe exists to show off the most common usage - writing out a Consul configuration and creating the Consul service - from node attributes. It is important to note that this cookbook is essentially a Library cookbook which provides an default example recipe (e.g. application cookbook).
    Either use 0.10 or use resources to set up consul
    Zach Langbert
    @zlangbert

    use resources to set up consul

    I think that's what I'm trying to do. How to I include them so I can use them in a recipe?

    Tomasz Sętkowski
    @tomzo
    I'd recommed that you start with some first-step resources like chef file - a good example is at https://docs.chef.io/resource_file.html
    Try those first, then come back to consul-cookbook
    I haven't tested 0.11 yet so I cannot help you set up consul, maybe the default recipe is broken now
    I know that 0.10 versions work. I use them in production deployment
    Zach Langbert
    @zlangbert
    I have done some basic recipies using the built in chef resources already, I'm just having trouble actually getting the consul resources in scope so I can use them
    I'll try 0.10 and see if I can get that to work
    Zach Langbert
    @zlangbert
    0.10 worked okay, thanks @tomzo
    Maybe @johnbellone can chime in and tell me where I went wrong :)
    matelukas
    @matelukas
    hi guys
    I am struggling with this issue

    NameError

    uninitialized constant Archive::EXTRACT_OWNER
    I tested following consul versions without success
    consul 0.10.1 0.10.0 0.9.1 0.6.0
    Chef Development Kit Version: 0.7.0
    chef-client version: 12.4.1
    berks version: 3.2.4
    kitchen version: 1.4.2
    what do you think which version of consul will not have this issue ?
    is there any way to force chefdk to not use builtin Archive ?
    aricb
    @buererra
    Any idea as to a date when version 1.3 will be available on supermarket.chef.io?
    André Freitas
    @andrefreitas
    Hi, I am installing consul from this cookbok and getting
    No resource or method named selinux_state' forChef::Recipe "disabled"'
    Franklin Hanson
    @fhanson
    Hello I am trying to run the testing suite for this cookbook but running into errors with poise
    `require': cannot load such file -- poise_boiler/spec_helper (LoadError)
    Robert J. Berger
    @rberger
    For some reason can’t seem to get the consul-ui working. The consul-ui resource put the files in /srv/consul-ui/current/dist and I have the line "ui_dir": "/srv/consul-ui/current/dist” is in /etc/consul.json but when I go to the host:8500/ui I get a 404
    Robert J. Berger
    @rberger
    Never mind. Operator error in my URL It was working fine.
    eeskov
    @eeskov
    hi all!
    First of all sorry for my bad english.
    I have a question about consul serf health checks. They periodically (average 5 sec) had unreacheble status. What I've done wrong?
    Riley Shott
    @Ginja
    Hey Everyone

    I was wondering if anyone has into this issue while using this cookbook:

    Dec  3 19:04:43 HOSTNAME init: consul main process (15424) terminated with status 1
    Dec  3 19:04:43 HOSTNAME init: consul main process ended, respawning

    That's what I get when the service starts from the consul-cookbook. I can however, start the service manually in the foreground.

    Riley Shott
    @Ginja
    Using CentOS 6.7
    Grant Joy
    @grantjoy
    hello.
    I'm getting this error: Error executing action create on resource 'vault_config[/home/vault/.vault.json]'
    I see that this issue was closed: johnbellone/vault-cookbook#21
    but I'm not understanding how to actually move past it. anyone have advice?
    Grant Joy
    @grantjoy
    issue is that vagrant is not creating the /home/vault dir...
    neilmunro
    @neilmunro
    ran into an issue with consul service not starting after a machine restart. traced it through consul-cookbook to a change in poise-service cookbook. seems like a breaking change in a patch release.
    poise/poise-service#14
    specific to CentOS 6 - hope no one else runs into it :)
    Grant Joy
    @grantjoy
    congrats neil. I figured out my issue too. the documentation for setting up the wrapper script was a little off.