These are chat archives for jruby-gradle/jruby-gradle-plugin

29th
Aug 2014
R. Tyler Croy
@rtyler
Aug 29 2014 00:03
openjdk version?
Schalk W. Cronjé
@ysb33r
Aug 29 2014 00:10
Oracle 8
let me test it under linux & openjdk
R. Tyler Croy
@rtyler
Aug 29 2014 00:11
weird
I wonder how I'm having such failures
can you give me the md5sum of the snapshot .jar you're using?
Schalk W. Cronjé
@ysb33r
Aug 29 2014 00:12
56699dd734adca7ffddc56a32a7d4637
R. Tyler Croy
@rtyler
Aug 29 2014 00:13
wacky! that's what I just ran with
Schalk W. Cronjé
@ysb33r
Aug 29 2014 00:17
yip passed on linux with openjdk 1.7
and failed with 1.7.14
R. Tyler Croy
@rtyler
Aug 29 2014 00:18
can you report that jruby/jruby#1927?
Schalk W. Cronjé
@ysb33r
Aug 29 2014 00:20
I’ll look into that tomorrow. I have reported that the other issue I raised has been fixed by the SNAPSHOT
rtyler @rtyler nods
R. Tyler Croy
@rtyler
Aug 29 2014 00:20
thanks
Schalk W. Cronjé
@ysb33r
Aug 29 2014 00:20
tomorrow? mmm… more like later today for me.
R. Tyler Croy
@rtyler
Aug 29 2014 00:27
heh, get some sleep buddy
I'll hack while you ZZZzzzZZZ
Schalk W. Cronjé
@ysb33r
Aug 29 2014 16:23
I created a gradle script today, which use 1.715-SNAPSHOT as the jruby version. It ran fine
R. Tyler Croy
@rtyler
Aug 29 2014 16:28
I'm running the integration tests on an ubuntu machine on EC2 now
Schalk W. Cronjé
@ysb33r
Aug 29 2014 16:36
I had a stab at improving the integration tests today, but rolled back. The way I did it in the jar plugin will not work for base as I need to have transitive dependencies to work as well.
R. Tyler Croy
@rtyler
Aug 29 2014 16:38
bummer
Schalk W. Cronjé
@ysb33r
Aug 29 2014 16:39
I’ll need to ask on the gradle forum. I thought I posted a Q there, but could not find it.
R. Tyler Croy
@rtyler
Aug 29 2014 17:13
testing 1.7.15-SNAPSHOT on ubuntu with JDK8 now
R. Tyler Croy
@rtyler
Aug 29 2014 18:39
@ysb33r looks like jruby/jruby/#1927 is specific to FreeBSD. full report here
what a pain in the ass
Schalk W. Cronjé
@ysb33r
Aug 29 2014 18:50
right.
R. Tyler Croy
@rtyler
Aug 29 2014 18:53
it's been a rough couple days here :P
R. Tyler Croy
@rtyler
Aug 29 2014 20:16
@ysb33r are you waiting on a warbler-bootstrap release?
Schalk W. Cronjé
@ysb33r
Aug 29 2014 20:16
nope.
R. Tyler Croy
@rtyler
Aug 29 2014 20:17
then this failure is just a code breakage? jruby-gradle/jruby-gradle-war-plugin#4
Schalk W. Cronjé
@ysb33r
Aug 29 2014 20:17
I think we need to get the next version of ‘base’ out
as both ‘jar’ and ‘war’ are waiting for a new feature in ‘base'
it allows the user to control the verison of warbler-bootstrap they want to use
R. Tyler Croy
@rtyler
Aug 29 2014 20:18
will you make a comment in the pull requests that need new bases
I'll be out of town this weekend and I don't want to forget
Schalk W. Cronjé
@ysb33r
Aug 29 2014 20:19
AOK
R. Tyler Croy
@rtyler
Aug 29 2014 20:21
3 day weekend in the states
FYI
Schalk W. Cronjé
@ysb33r
Aug 29 2014 20:25
Labor Day? I forgot. It means I won’t get an answer out of the US before Tuesday from a client. Grrr...
You going anywhere?
R. Tyler Croy
@rtyler
Aug 29 2014 20:28
Yosemite
going to see some trees and whatnot
Schalk W. Cronjé
@ysb33r
Aug 29 2014 20:29
nice. I’ve never been.
R. Tyler Croy
@rtyler
Aug 29 2014 20:40
me neither!
Schalk W. Cronjé
@ysb33r
Aug 29 2014 21:48
tech question: to run Rake from jruby? would it be jruby -S rake ?
Schalk W. Cronjé
@ysb33r
Aug 29 2014 21:55
nm. sorted