These are chat archives for jruby-gradle/jruby-gradle-plugin

8th
Jul 2015
Blane Dabney
@raelik
Jul 08 2015 18:34
so all those hoops I was trying to jump through yesterday were a bit unnecessary . jrubyPrepare does everything I need
Christian Meier
@mkristian
Jul 08 2015 18:36
:)
Blane Dabney
@raelik
Jul 08 2015 18:38
I'm fiddling around with the jar plugin too, but I'm having trouble getting it to use jruby 9k
Christian Meier
@mkristian
Jul 08 2015 18:39
even after the updates from yesterday? version 0.3.2 of the plugin ?
Blane Dabney
@raelik
Jul 08 2015 18:41
yeah, I may just be missing something
oh, there it goes
gotta set default Version and execVersion
Christian Meier
@mkristian
Jul 08 2015 18:43
I thought you can omit one of those - not sure which one
R. Tyler Croy
@rtyler
Jul 08 2015 18:44
I filed a bug a while back about needing to set both
Blane Dabney
@raelik
Jul 08 2015 18:47
oh, looks specific to the jar plugin
it always pulls down 1.7.21
but, it also grabs 9k
as long as it only puts 9k in the jar, I guess it doesn't matter if it caches 1.7.21
Schalk W. Cronjé
@ysb33r
Jul 08 2015 18:48
execVersion controls what version is used by JRubyExec tasks. defaultVersion controls which version is used for embedding.
Blane Dabney
@raelik
Jul 08 2015 18:53
hmmm, so jrubyJar does put 1.7.21 in the jar file, not 9k
figured it out :P
jrubyJar { jrubyVersion '9.0.0.0.rc1' }