These are chat archives for jruby-gradle/jruby-gradle-plugin

1st
Sep 2015
James Way
@jamescway
Sep 01 2015 17:16
@rtyler should dependencies.gems pull in transitive deps? or should they all be explicitly listed
seems like it should be the latter (tho it didn't quite work for me)
R. Tyler Croy
@rtyler
Sep 01 2015 17:16
provided the gem declares its dependencies properly, those will be slurped in, you can view this by ./gradlew dependencies
James Way
@jamescway
Sep 01 2015 17:19
cool
James Way
@jamescway
Sep 01 2015 18:09
@rtyler could it be that spec.add_dependency “some-gem” doesn’t have the version number and gradle does’t like it?
R. Tyler Croy
@rtyler
Sep 01 2015 18:10
I don't know what you're seeing d00d
nice edit :smile:
James Way
@jamescway
Sep 01 2015 18:10
gradle dependencies —> +— rubygems:some-gem:[0,) -> 0.1.0 (*)
that looks like it wouldn’t know which version to install so it seems like the gemspec needs to peg specific version numbers?
or alternatively, you are explicit and list out all the gems in your build.gradle
R. Tyler Croy
@rtyler
Sep 01 2015 18:12
@jamescway since this is with an internal thing, ping me on internal chat and give me the full output of ./gradlew depdendencies