These are chat archives for jruby-gradle/jruby-gradle-plugin

17th
Sep 2015
R. Tyler Croy
@rtyler
Sep 17 2015 13:23
I'm starting to think that this might be due to an outofmemory situation and it's just hidden from me because it's i na shared jenkins CI environment
Christian Meier
@mkristian
Sep 17 2015 13:28
@rtyler I was thinking about OutOfMemory as well especially since firing up more then one jruby instance for each jetty server could be quite something
R. Tyler Croy
@rtyler
Sep 17 2015 13:35
I wasn't able to replicate the behavior locally, there's something happening to where I believe the Jeknins slave is causing the spawned Gradle process to inherit some options
which then the Gradle wrapper says "oh my, these options are too different, i'm going to fork!"
Schalk W. Cronjé
@ysb33r
Sep 17 2015 13:37
Doesn’t Jenkins run a Gradle daemon in the background? If so, it would need to fork should options or version be different
A way to track that down is to use a Bash build step instead of a Gradle build step in Jenkins
R. Tyler Croy
@rtyler
Sep 17 2015 13:40
I did, no change
it's also not respecting the --no-daemon option :/
Schalk W. Cronjé
@ysb33r
Sep 17 2015 13:41
version 2.3?
R. Tyler Croy
@rtyler
Sep 17 2015 13:42
and 2.2
Schalk W. Cronjé
@ysb33r
Sep 17 2015 13:42
but not 2.4?
R. Tyler Croy
@rtyler
Sep 17 2015 13:42
I can't upgrade to 2.4, dependency lock plugin bullshit
Schalk W. Cronjé
@ysb33r
Sep 17 2015 13:49
just checking the release notes to see if there is any mention of that
R. Tyler Croy
@rtyler
Sep 17 2015 13:50
ah good idea
Schalk W. Cronjé
@ysb33r
Sep 17 2015 13:55
cannot see anthing specific
R. Tyler Croy
@rtyler
Sep 17 2015 13:55
@ysb33r I don't know if you saw, but with #195 fixed the plugin portal now has the base plugin synced up proprely again
they're still lagging behind on syncing 1.1.2 of the jar plugin, not sure why
rtyler @rtyler continues to tell everybody who will listen to use jcenter
R. Tyler Croy
@rtyler
Sep 17 2015 14:31
apparently dependency-lock 3.0.0 suports up to gradle 2.6, i'm going to give that a try
rtyler @rtyler waits impatiently
Schalk W. Cronjé
@ysb33r
Sep 17 2015 14:40
Have you tried to reproduce the issue locally by actually running gradle with —daemon
R. Tyler Croy
@rtyler
Sep 17 2015 14:50
yeah, no dice :(
well, with Gradle 2.6 at least I see a new error! :)
2015-09-17 07:40:22 java.lang.OutOfMemoryError: PermGen space
<)M
_< rather
Christian Meier
@mkristian
Sep 17 2015 14:53
ah - this is the error I saw when I try to run both integration test with jdk7
there is no more permgen space in jkd8
R. Tyler Croy
@rtyler
Sep 17 2015 15:04
going to crank up the permgen space and see if the build will pass at least once