These are chat archives for jruby-gradle/jruby-gradle-plugin

Mar 2016
Luís Duarte
Mar 16 2016 11:26
Hello guys. Has anyone ever used JRuby-Gradle for packaging a LogStash Plugin ?
Christian Meier
Mar 16 2016 12:23
logstash plugins, are they gems ? if, yes then you the jruby-gradle plugin is not the right thing
Blane Dabney
Mar 16 2016 15:36
@mkristian You think that (=1.3.0,1.99999] could be caused by the dependency in the gemspec being parsed incorrectly? The dependency in question is: add_dependency "tilt", ["~> 1.1", "!= 1.3.0"]
Christian Meier
Mar 16 2016 15:47
yes very much it is parsed incorrectly. what is the version of tilt ?
no, sorry the gem which depends on tilt ? is it public ?
Blane Dabney
Mar 16 2016 17:00
yeah, it's rails/sprockets, any 2.x version
they had to define it like that because tilt failed to semantically version properly when they released 1.3, by not releasing 1.3.0 (or at least tagging a 1.3.0 pointing to 1.3), and then went to 1.3.1
to be fair, I'm only having this issue because my project has to support an old rails 3.2 app
they're updating it to rails 4, but that isn't going to production for a while