These are chat archives for jruby-gradle/jruby-gradle-plugin

7th
Dec 2016
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:19

@rtyler @mkristian Any ideas how to resolve this conflict:

import com.github.jrubygradle.JRubyExec

plugins {
    id "com.github.jruby-gradle.base" version "1.3.3"
}


dependencies {
    jrubyExec 'rubygems:github-pages:106'
}

task jekyll( type : JRubyExec ) {
    jrubyArgs '-S'
    script 'jekyll'
    scriptArgs '--future'
    workingDir projectDir
}

Fails with

> Could not resolve all dependencies for configuration ':jrubyExec'.
   > Could not resolve rubygems:octokit:(=4.4.0,4.99999].
     Required by:
         project : > rubygems:github-pages:106 > rubygems:jekyll-github-metadata:2.2.0
      > there is no overlap for [4.2,4.99999] and (=4.4.0,4.99999]
   > Could not resolve rubygems:public_suffix:[2.0.2,2.99999].
     Required by:
         project : > rubygems:github-pages:106 > rubygems:jekyll:3.3.1 > rubygems:addressable:2.5.0
      > there is no overlap for [1.4,1.99999] and [2.0.2,2.99999]
Christian Meier
@mkristian
Dec 07 2016 19:21
that is a bug (=4.4.0,4.99999] it should be (4.0,4.99999]
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:22
A bug in our plugin?
Christian Meier
@mkristian
Dec 07 2016 19:22
looks like
the second one is not clear it indeed does not overlap
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:23
What about a bug in the GEM or the gem->mvn resolver?
|    +--- rubygems:jekyll-github-metadata:[2.2.0,2.2.0.0.0.0.0.1) -> 2.2.0
|    |    +--- rubygems:octokit:(=4.4.0,4.99999] FAILED
|    |    \--- rubygems:jekyll:[3.1,3.99999] -> 3.3.1 (*)
that is what gradle dep gives me. All others seem to be fine
Christian Meier
@mkristian
Dec 07 2016 19:24
that is good question, let me check the gem
nope it is our plugin: s.add_runtime_dependency(%q<octokit>, ["!= 4.4.0", "~> 4.0"])
it is this != which I never saw before. maybe it is the gem also.
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:27
mmm... maybe I can force the version of octokit to be 4.4.0
Christian Meier
@mkristian
Dec 07 2016 19:28
no not 4.4.0 that is what the gem author wanted to write
the notation is correct and it is a bug in the plugin
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:30
Shall I raise an issue?
Christian Meier
@mkristian
Dec 07 2016 19:30
please
R. Tyler Croy
@rtyler
Dec 07 2016 19:32
interesting
Christian Meier
@mkristian
Dec 07 2016 19:32
the second problem could even resolve with picking a version 4.6.2
R. Tyler Croy
@rtyler
Dec 07 2016 19:32
hm
Christian Meier
@mkristian
Dec 07 2016 19:32
I pretty sure we just look for ! and not != as the = remains part of the version :(
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:33
#44 done
Christian Meier
@mkristian
Dec 07 2016 19:33
thanks. did you try to just add another dependency for octokit-4.6.2 ?
better pick jekyll-github-metadata-2.1.1 to avoid this != declaration altogether
oh - you probably can't - well you need play around with those dependencies a bit :( or force them which ruby might not like when executing the code :P
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:37
Or roll back to github-pages:100 to work around my immediate problem
Christian Meier
@mkristian
Dec 07 2016 19:37
yes :)
Schalk W. Cronjé
@ysb33r
Dec 07 2016 19:50
At least we have found bug.
Christian Meier
@mkristian
Dec 07 2016 19:51
:)