These are chat archives for jruby-gradle/jruby-gradle-plugin

6th
May 2017
amiracam
@amiracam
May 06 2017 10:06
@raelik btw, how does the Jruby gradle plugin know which jruby compiler to use ?
amiracam
@amiracam
May 06 2017 10:16
@raelik I notice that there is no compileRuby or compileJRuby tasks which do show up for the other lang plugins e.g. compileJava, compileGroovy, cmmpilekotlin etc, maybe I have missed a step ?
Blane Dabney
@raelik
May 06 2017 13:25
@amiracam Ruby scripts aren't normally compiled, so that step isn't necessary.
@amiracam The jRuby version is 9.1.7.0 by default I believe, but you can override that if you want.
Christian Meier
@mkristian
May 06 2017 13:52
@amiracam the only reason to compile ruby code is for obfuscation, but it comes with its own set of problems here and there. there is no gain in performance etc, as the JRuby JIT is just doing a great job in optimizing.
Blane Dabney
@raelik
May 06 2017 13:52
@mkristian that too :P