These are chat archives for jruby-gradle/jruby-gradle-plugin

28th
Nov 2017
R. Tyler Croy
@rtyler
Nov 28 2017 17:18
so it looks like even in the master branch this integration test fails when trying to use JRuby 1.7.19
@mkristian @ysb33r what do you two think about just dropping support for 1.7.x at this point
Christian Meier
@mkristian
Nov 28 2017 17:20
since time constraints are the biggest issue on this project I am all for sticking to jruby-9k. jruby-1.7.x is officially end of live as well.
R. Tyler Croy
@rtyler
Nov 28 2017 17:21
alright, I think for #318 and a 1.6.0 release I'll remove 1.7.x
the 1.7.27 release was in May too
Christian Meier
@mkristian
Nov 28 2017 17:22
BTW it seems jruby-9.1.15 is on its way. a week or two.
R. Tyler Croy
@rtyler
Nov 28 2017 17:22
hah
of course
maybe it'll be done by the time 1.6.0 is ready to ship
Schalk W. Cronjé
@ysb33r
Nov 28 2017 17:28
Added TODOs to issue.
R. Tyler Croy
@rtyler
Nov 28 2017 18:56
@ysb33r do you happen to know what Gradle's future is with some of the JDK9 uncertainty with Groovy?
Schalk W. Cronjé
@ysb33r
Nov 28 2017 20:30
@rtyler not sure. I know some of the Groovy issues will be dealt with in upcoming releases of Groovy itself, however it will also depend when Gradle adopts a 2.5.x version.
R. Tyler Croy
@rtyler
Nov 28 2017 20:31
we've been hurting in the Jenkins project due to some JDK9 idiocy
rtyler @rtyler flips table
R. Tyler Croy
@rtyler
Nov 28 2017 23:07
@mkristian jruby-mains gonna be released anytime soon? :)