Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Nov 27 21:44
    byteit101 commented #6422
  • Nov 27 16:18

    eregon on master

    Add tags for new failing specs (compare)

  • Nov 27 15:25
    dmitry-weirdo commented #2498
  • Nov 27 14:58

    eregon on master

    Update to ruby/mspec@b58e665 Update to ruby/spec@c4170a3 Add tags for new failing specs (compare)

  • Nov 27 14:58
    eregon closed #6478
  • Nov 27 14:57
    eregon synchronize #6478
  • Nov 27 13:57
    eregon opened #6478
  • Nov 27 13:57
    eregon milestoned #6478
  • Nov 26 18:38
    kevin-klein commented #6129
  • Nov 25 21:06
    byteit101 synchronize #6422
  • Nov 25 20:42
    byteit101 synchronize #6422
  • Nov 25 19:11

    enebo on master

    OperatorCallNode was missing fr… Merge pull request #6474 from b… (compare)

  • Nov 25 19:11
    enebo closed #6474
  • Nov 25 19:11
    enebo milestoned #6474
  • Nov 25 18:56
    ahorek commented #6476
  • Nov 24 04:06
    fzakaria opened #6477
  • Nov 24 01:47
    mistergibson opened #6476
  • Nov 23 19:52
    rjnienaber closed #2393
  • Nov 21 20:06
    gshields opened #6475
  • Nov 21 14:21
    JonRowe commented #5235
Uwe Kubosch
@donv
Hi! The nightly builds are not accessible: https://www.jruby.org/nightly links to https://repo.aws.oss.sonatype.org/content/repositories/snapshots/org/jruby/jruby-complete/ which gives a 404 error page.
Charles Oliver Nutter
@headius
Gah that should be there
It's not a 404 for me
Oh but the jar isn't there
Well that's strange, the nightly snapshot job disappeared
Matt Patterson
@fidothe
Afternoon/Morning. I have this project: https://github.com/fidothe/saxon-rb which wraps the Saxon Java library. We vendor a specific version of Saxon in to the gem with jar-dependencies. There's a mechanism to use different Saxon JARs if you need them (for an older version, or for the EE version). That has worked fine. I just came to use it again to test something and I am getting StackOverflow errors. I have a simple example gist at https://gist.github.com/fidothe/5247bb8236e6dcd42d6bbc1d1b63ad2f showing what's needed. All the loading code is in lib/saxon/loader.rb.
At this point I'm really not sure if this is a bug in my code or a problem somewhere else
I will check with a JRUBY nightly and see
Matt Patterson
@fidothe
Still a problem there.
I will open an issue later this evening, once I get home. Hopefully it's just me doing something dumb.
Matt Patterson
@fidothe
yeah, I'm doing something 'dumb'
I'd tested the ability to load other versions of Saxon by loading a SaxonPE version
which has a different JAR name
So I imagine that despite having not required any of the jar_dependencies stuff on the code path that loads an external Jar, trying to load another version of the Saxon HE jars causes a horrendous pile up because the jar_dependencies vendors the Jars under lib, and so on the $LOAD_PATH
So, this is probably one to take up with @mkristian on the jar_dependencies repo issues list...
(I have checked, and current code example will load an external Saxon PE jar fine)
Charles Oliver Nutter
@headius
@fidothe hey there
Yeah, if you think it is related to jar-deps then file it there, but filing on main JRuby repo is fine too
Do you have a stack trace gist handy?
Uwe Kubosch
@donv
Hi all! @headius We launched a beta of our airport bus tracking system based on Ruboto with jruby-complete-9.2.9.0-20191002.125108-59 this week. First launch looks good. We will give it a week without incidents before going GA.
Matt Patterson
@fidothe
@headius I don't have a stack trace handy - will get one. Assumption about HE/PE (differently named .jars with mostly the same classes in) is also wrong, so I'm digging deeper. jar-deps looks less likely as a problem source
Matt Patterson
@fidothe
@headius, better reproduction with a non-1-line stacktrace at the updated https://gist.github.com/fidothe/5247bb8236e6dcd42d6bbc1d1b63ad2f
Will file an issue. Not sure there's a simpler reproduction than to clone my project and grab the external JAR, alas.
Matt Patterson
@fidothe
@headius here you go jruby/jruby#5914
Charles Oliver Nutter
@headius
@donv Oh that's cool! Would love to host a blog post from you about the architecture of your apps some time. I'd be happy to help write it or whatever
@fidothe Thank you!
Charles Oliver Nutter
@headius
@fidothe I posted a "fix" but I don't hve a full understanding of why it works one way (jar-deps) but not the other (classpath)
@donv It seems like jruby-complete jars started snapshotting again 🤷‍♂️
Matt Patterson
@fidothe
@headius @enebo I don't know if anyone is tackling #5905, but it looks like something I could tackle in a reasonable time. Looking the code over, it seems fairly straightforward. The main thing I don't really understand is the role of RubyString's gsubFast - the only use of that I can find is in RubyDate.java, which uses a Regexp, so it's not directly affected by behaviour that uses a string pattern arg.
Charles Oliver Nutter
@headius
@fidothe Hey that would be great!
Yeah gsub fast may not be used by this logic...but I suppose it could be?
I think I linked the MRI commit that made this optimization in that bug, so that would be a good rough template to follow (even though this logic isn't a line-for-line port)
jlahtinen
@jlahtinen
jruby-9.2.8.0 :006 > e = Exception.new('å'); puts "#{e} - #{e.inspect}"
å - #<Exception: Ã¥>
is this expected behavior?
Matt Patterson
@fidothe
I've been setting up my machine for hacking on #5905, and I have a couple of questions. just running mvn complains about the .polyglot.pom.rb, ./mvnw is fine, and ./mvnw -Pbootstrap runs fine, but ./mvn still complains after. (This is on JDK 1.8 on macOS 10.14) Is this expected? I ran jruby -S rake spec:ruby:fast which reported 3 failures and 2 errors (Signal.list redefines CLD with CHLD if defined FAILED, plus some networking stuff that seems like it might be a platform thing). I can see that's not happening in the last Travis build. Is that expected/a problem?
Blane Dabney
@raelik
@jlahtinen The normal behavior is that inspect returns a string that uses the default system encoding.
for MRI Ruby
Blane Dabney
@raelik
That said, I tried that on my jRuby and got the same result, whereas MRI 2.5.3 does what you would expect: å - #<Exception: å>
So that looks like a bug
Charles Oliver Nutter
@headius
hey hey
I wish notifications worked on here
@fidothe What's the complain? I think you might be hitting a recent Maven bug :-(
3.6.4 or something broke polyglot maven
I think if you delete pom.rb it will work fine since we keep the pom.xml up to date too
@jlahtinen That is a bug
Looks like it's probably just a bug in Exception#inspect
can you file it please?
Ghost
@ghost~5377c1e9048862e761fa1c25
@headius are you relying on the app for notifications? This app seems to be getting worse over time even with no updates!
Charles Oliver Nutter
@headius
Yeah they actually replied to my complaint and pointed to an unfixed bug they know about