These are chat archives for juttle/juttle

17th
Mar 2016
Rodney Lopes Gomes
@rlgomes
Mar 17 2016 00:24
@chenryn we pushed out a fix to a dependency of juttle-engine that fixes your issue on Chrome v42 so you could do npm uninstall juttle-engine -g followed by npm install juttle-engine -g and let us know if the error has gone away on chrome and things look good again.
饶琛琳
@chenryn
Mar 17 2016 02:33
try again, there is no error in console now, but webpage report the same unexpected error
Daria Mehra
@dmehra
Mar 17 2016 02:39
The default values error?
饶琛琳
@chenryn
Mar 17 2016 02:40
a.default.values(...).find is not a function
yes
Daria Mehra
@dmehra
Mar 17 2016 02:46
Strange, we tested in a docker container with your chrome version and it worked... Any chance you could update Chrome to latest, to get around this?
饶琛琳
@chenryn
Mar 17 2016 02:47
I open chrome://chrome/ then it tell me it's newest version...
because I'm in China maybe...I will download a newer one manually.
Daria Mehra
@dmehra
Mar 17 2016 02:50
Does "about chrome" say 49? Or 48 which I have and also works fine? Your old one was 42
Rodney Lopes Gomes
@rlgomes
Mar 17 2016 02:58
@chenryn I'm back... can you check you share what the output of npm ls juttle-engine juttle-viewer juttle-client-library -g outputs ?
饶琛琳
@chenryn
Mar 17 2016 03:01
/opt/local/lib
└─┬ juttle-engine@0.5.0
└── juttle-viewer@0.3.2
Rodney Lopes Gomes
@rlgomes
Mar 17 2016 03:01
juttle-viewer seems to be at the right version so I'm very stumped
oh you were running juttle-engine &... did you have one already running ? can you make sure to kill anything that was running ? ps aux | grep juttle if there's any juttle-engine then pkill -9 [pid] and start the juttle-engine again ?
饶琛琳
@chenryn
Mar 17 2016 03:03

just one process running.

I install a version49, and everything right now.

Rodney Lopes Gomes
@rlgomes
Mar 17 2016 03:04
the TypeError: Object.assign is not a function {stack: (...), message: "Object.assign is not a function"} (anonymous function) @ index.js:25 issue was solved
but I somehow forgot there was the a.default.values(...).find is not a function on the page so I'm going to see what that was about
Rodney Lopes Gomes
@rlgomes
Mar 17 2016 03:09
ok well @chenryn let us know if you run in to any other problems
try out a few example programs and see that things are working fine with juttle-engine