Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Atsushi Eno
    @atsushieno
    いのまたさんは「最も簡潔な形式にはしていません」などを提案していますね…
    Atsushi Eno
    @atsushieno
    七色、にすると文脈から読み取れないことになりそうなので、わたしは 虹色 くらいが妥当だと思うところです(虹が七色なのは日本語固有の話なので、七色なんてPetzoldが書いているはずがないということは、分かる人にはすぐバレます)
    extravageant、読書会の時に「大掛かりな」あたりがいいかな、というコメントがあったので、これがいいかなと思って書いていました
    Kentaro Inomata
    @matarillo
    虹の七色は確かにちょっとうっとおしいので「虹色」で良いとは思います。なお原文には"the colors of the rainbow, traditionally red, orange, yellow, green, blue, indigo, and violet." というくだりがあり、6色ではなく7色だったりします。
    Atsushi Eno
    @atsushieno
    !! 七色派と六色派があるのか… http://www.excite.co.jp/News/bit/00091127807434.html
    Yoichi Nakamura
    @yoichinak
    週末の邦訳読書会の続きです。連投失礼します。
    第23章 トリガーとビヘイビア

    p288 ( 原文p899 )

    列挙メンバーで

    そうした列挙は

    第22章と同様に適宜「列挙子」や「列挙型」に。

    p303 ( 原文p913 )

    255を乗数とする整数に変換されたうえで、

    単に「255倍して整数に変換」でいいのではないでしょうか。

    第24章 ページナビゲーション

    p314 ( 原文p923 )

    代わりに、App のパラメーターなしのコンストラクターを使って NavigationPage をインスタンス化し

    間違いでしょう。「パラメーターなしのコンストラクター」は NavigationPage のコンストラクターであって、App のコンストラクターではないでしょう。「App の」をトル。

    p317 ( 原文p927 )

    画面の一番下に[戻る]ボタンがあります(図24-6)。

    原文'on the bottom of the screen'なので訳は正しいのですが、私は原文が間違っていると考えます。Windows Phone 8.1の[戻る]ボタンの説明は、直後のp320 ( 原文p929 ) では 'on the bottom of the phone'となっており、こちらに統一すべきだと思います。日本語では「デバイスの一番下に」となるでしょう。

    p320 ( 原文p929 )

    画面の一番下に[戻る]ボタンがあるため、

    前述の通りです。原文は'on the bottom of the phone'であり、「デバイスの一番下に」がよいでしょう。

    p321 ( 原文p930 )

    ただし、PushAsync または PushModelAsync を呼び出して前のページに戻るには、

    それぞれ PopAsyncPopModalAsync の誤りでしょう。

    p333 ( 原文p942 )

    すでに新しいページインスタンスへナビゲートしている途中だからです。

    間違いでしょう。正しくは、「ナビゲートする先のインスタンスを既に持っているからです」。

    p334 ( 原文p943 )

    DisplayInfo を呼び出すページインスタンスは、PopAsync タスクと PopModalAsync タスクから返されるページインスタンスではなく、これらのメソッドを呼び出すページインスタンスと同じだからです。

    原文では分かれていた後半の文章をくっつけたうえ、指示語が指すものを間違えているでしょう。Pop~ の戻り値はスタックから Remove されるページのはず。「DisplayInfo を呼び出す《べき》ページインスタンスは、PopAsync タスクと PopModalAsync タスクから返されるページインスタンス《ではありません。》《これらのメソッドによって返されるのは、》これらのメソッドを呼び出しているページインスタンスと同じだからです。」

    p334 ( 原文p943 )

    このプログラムが最初に起動するときに呼び出されなければなりません。

    原文の 'also' が落ちています。「このプログラムが最初に起動するときに《も》呼び出されなければなりません。」

    p336 ( 原文p944 )

    無効な Button 要素をタップしたときに何が起きるかを調べたい場合は、その部分のコードを無効にしてみてください。

    原文の 'invalid' と 'comment out' の訳語に同じ「無効」を使っていて紛らわしいです。しかもこのあたりには 'disabling' もあります。前者は「不正な」とかに、後者は「コメントアウト」でいいでしょう。

    p336 ( 原文p944 )

    • モードレスページからは、別のモードレスページかモーダルページへナビゲートできる。
    • モーダルページからは、別のモーダルページにしかナビゲートできない。

    後の文が否定形になっていて、混乱を招きます。「別のモーダルページにのみナビゲートできる」でいいでしょう。

    p338 ( 原文p946 )

    ページ番号は大きくなる一方です。

    原文は'ever-increasing'です。私は「大きくなる一方です」よりも「増え続けます」の方が好みです。

    p339 ( 原文p948 )

    これは、2つの Entry 要素に何かが入力されていて、かつ Picker 要素に何かが入力されている場合にのみ、

    'type' と 'enter' の訳語が同じ「入力」になっていてイケてない感じがします。後者は、勇気をもって意訳して「選択」ではいかがでしょうか。

    p362 ( 原文p969 )

    Activator.CreateInstance オブジェクトをコードで作成し、

    原文にはないし、意味が通りません。「Activator.CreateInstance」をトル。

    p391 ( 原文p997 )

    InfoCollection プロパティと CurrentInfo プロパティは前のプログラムものと同様ですが、CurrentInfoIndex という int 型のプロパティも定義されています。このプロパティには XmlIgnore 属性が指定されているため、シリアライズの対象にはなりません。

    間違いでしょう。原文では 'the CurrentInfo property is flagged' となっているのを、「このプロパティには」と訳していますが、「このプロパティ」は CurrentInfoIndex を指しているように読めますので、間違った文章になってしまいます。 「CurrentInfo プロパティには XmlIgnore 属性が指定されているため、」がいいでしょう。

    あと「前のプログラム《の》ものと」。

    p402 ( 原文p1007 )

    NoteTaker プログラムは、本章の DataTransfer プログラムと同じような構造化になっており、

    「構造になっており」で。

    以上、よろしくお願いします。
    Atsushi Eno
    @atsushieno
    ありがとうございます! コメントは登録しておきましたー

    on the bottom of the screen

    技術的にはこっちのほうが正しそうな気がします(スクリーンの下に何があるかはデバイス依存なのでw)

    Yoichi Nakamura
    @yoichinak
    邦訳読書会 第25章 の続きを連投します。ちょっと細かいところもあります。

    p419 ( 原文 p1022 )

    DetailPage には、 Padding は含まれていません。

    ソースを見ると Padding はあるので、おかしいと思うはずです。実は、ここで無いと言っている Padding は、 OnPlatform で指定されている padding のことです。直前の文に次のような説明があります。「iPhone でのステータスバーのオーバーラップを回避するために Padding が含まれている点に注目してください。」そっちの Padding ならば確かにありません。原文 'The DetailPage does not contain that Padding.' の 'that' を訳出すべきでは?

    対案は、「 DetailPage には、《そのような》 Padding は含まれていません。」

    p424 ( 原文 p1027 )

    MasterBehavior プロパティに Popover を割り当てると、iPhone と同様に、マスターページが詳細ページの上に表示されます。

    「上に表示されます」は y 軸方向だと読めてしまってあまり良くない気がします。z 軸方向だということが分かりやすい訳語を選びたいです。原文は 'overlays' です。

    対案は、「~マスターページが詳細ページに覆いかぶさります。」

    p424 ( 原文 p1027 )

    横向きモードでは、マスターページと詳細ページが画面を共有しますが、

    「共有します」は 'share' の訳として何も間違っていませんが、私の好みは「分け合います」です。画面の左右に分かれている様子が伝わるといいのですが。

    p424 ( 原文 p1027 )

    タブレットを縦向きモードにすると、詳細ページが画面全体を占めるようになり、マスターページが詳細ページを覆うように配置されます。

    'overlays' を「覆うように配置されます」と訳していますが、「配置」は補い過ぎだと感じます。対案は「覆いかぶさります」。

    p445 ( 原文 p1046 )

    また、プログラムが(たとえば)終了の準備のためにスリープ状態に遷移するときに、 SchoolViewModelSaveNotes メソッドにも Properties ディクショナリを渡します。

    「終了の準備のために」が「スリープ状態に遷移する」にかかっているように読めますが、間違いでは?「終了の準備のために」が説明しているのは、なぜスリープ状態に遷移するか、ではなく、なぜ Properties を渡すのか、ではないでしょうか。

    また、 'possibly' を「(たとえば)」としたようですが、「たとえば」は例示の意味が強いので、あまり良くない気がします。 SaveNotes メソッドの実装はこの章では示されていない(第19章にあります)ので、分からないふりをしているのでしょう。

    対案は、「また、おそらく終了の準備のため、プログラムがスリープ状態に遷移するときに、SchoolViewModelSaveNotes メソッドにも Properties ディクショナリを渡しています。」

    p451 ( 原文 p1052 )

    よい知らせは、Android と Windows 10 Mobile では、これが非常にうまくいくことです。

    間違ってはいないのですが、ぎこちないと思います。

    対案は、「《喜ばしいことに》、Android と Windows 10 Mobile では、これが非常に《うまくいきます》。」

    以上、よろしくお願いします。
    Atsushi Eno
    @atsushieno
    ありがとうございます。いただいたコメントは反映しておきました。
    わたしも上下とかは他の章も含めてたまに指摘していました(困る)
    Yoichi Nakamura
    @yoichinak

    第25章の追加です。現地でも話題になっていましたが、念のため確認しました。

    p451 ( 原文 p1052 )

    アイテムをさらに表示するためのボタンとドットが3つ並んだボタンは機能しません。

    more button は日本語では「その他」になりました。ソースは Xamarin.Forms.Platform.iOS/Resources/StringResources.ja.resx だと思います。また、Apple 純正アプリ iTunes Store でも同様でした。

    2017-09-19_10-01-36-午前.jpg
    Yoichi Nakamura
    @yoichinak
    第27章の追加を連投します。

    p529 ( 原文 p1127 )

    よい知らせは、カスタムレンダラーの作成も可能であることです。

    'The good news is that ...' の訳し方は、間違いではないがイケてない、と以前にも指摘したので、一応挙げます。
    対案は「喜ばしいことに、独自のレンダラーを書くこともできます。」

    'your own renderers' を「カスタムレンダラー」と意訳しているのは、直訳が多い中では意外に感じました。
    'write' を「作成」と訳しているのは OK だと思います。

    p545 ( 原文 p1141 )

    メソッドは、描画サーフェス(表示範囲)を無効にし、

    「無効にし」は、原文では 'invalidates' です。
    間違いではないですし、よくある訳し方だと思いますが、他の場所(第26章 p485)では「インバリデートする」と訳していたので、統一したい気もします。

    p548, 549, 550

    このあたり、等幅フォントの範囲がずれているようです。

    p553 ( 原文 p1149 )

    Xamarin.Forms のほとんどの要素はインラクティブです。

    「イン《タ》ラクティブ」ですね。

    p561 ( 原文 p1157 )

    イスには、 Seekbar に変更を通知するメソッドが3つ定義されています。

    この「Seekbar」は原文通りなのですが、「b」は大文字で「SeekBar」が正しいのではないでしょうか。

    以上です。ありがとうございました。
    P3PPP
    @P3PPP

    27章 540ページ 下から8行目あたり

    ただし、レンダリングインフラストラクチャには 〜 置き換える必要があります。

    『しかしながら、レンダリングインフラストラクチャにはXamarin.Forms要素にレンダラーインスタンスをアタッチする仕掛けと、あるXamarin.Forms要素からデタッチしたレンダラーインスタンスを別の(Xamarin.Forms)要素にアタッチする仕掛けがあります。
    おそらくXamarin.FormsはXamarin.Forms要素を再生成したり、すでにレンダラーインスタンスがアタッチされたXamarin.Forms要素を置き換える必要があるのでしょう。』

    (Xamarin.Forms)とした所はさすがに省略した方が日本語としては読みやすいかと。後半部分は「こういう仕組みがあるから(詳しくは追わないけど)必要なのでしょう」くらいニュアンスだと思うので断言しない方が良いと思います。

    P3PPP
    @P3PPP

    27章 553ページ 下から9行目

    が取り得る値の数は

    「が取り得る値の個数は」になると少し読みやすくなると思います。

    Atsushi Eno
    @atsushieno
    @yoichinak チェックが遅くなってすみませんがこれからコメント反映します。ありがとうございます!
    @P3PPP こちらもありがとうございます!