These are chat archives for kerberos-io/hades

17th
Aug 2015
stephenjamieson
@stephenjamieson
Aug 17 2015 13:54
17-08-2015 09:54:28 AM 1 - OpenCV : /opt/kerberos-io/build/opencv/modules/highgui/src/cap_gstreamer.cpp:1622: error: (-2) GStreamer: your gstreamer installation is missing a required plugin
the only plugin on the list that you provided I don't have is gstreamer-ffmpeg, that does not exist in ubuntu
stephenjamieson
@stephenjamieson
Aug 17 2015 14:00
@cedricve ^^^
Cédric Verstraeten
@cedricve
Aug 17 2015 14:08
You should also install addons for gstreamer
stephenjamieson
@stephenjamieson
Aug 17 2015 14:10
addons?
stephenjamieson
@stephenjamieson
Aug 17 2015 14:19
installed gstreamer0.10-ffmpeg using a trusty repository, then I disabled the repo... sorta sucks but it's been taken out of the main repos.
Aug 17 10:20:44  kerberos[12407]: [IMGUTILS @ 0x7ffd0f4a3c70] Picture size 0x0 is invalid
Aug 17 10:20:44  kerberos[12407]: [IMGUTILS @ 0x7ffd0f4a3c50] Picture size 0x0 is invalid
Aug 17 10:20:44  kerberos[12407]: OpenCV Error: Assertion failed (scn == 3 || scn == 4) in cvtColor, file /opt/kerberos-io/build/opencv/modules/imgproc/sr
c/color.cpp, line 3739
see one error now, but after switching to rectangle from hull it seems to be working
stephenjamieson
@stephenjamieson
Aug 17 2015 16:06
one more error
Aug 17 11:54:27 kerberos[14162]: GStreamer Plugin: Embedded video playback halted; module source reported: Could not open resource for reading and writin
g.
Aug 17 11:54:27 kerberos[14162]: OpenCV Error: Unspecified error (GStreamer: unable to start pipeline
Aug 17 11:54:27 kerberos[14162]: ) in icvStartPipeline, file /opt/kerberos-io/build/opencv/modules/highgui/src/cap_gstreamer.cpp, line 383