Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Matthew Frost
    @mattronix
    ah i see
    thanks
    so far i only see my own records via the API i think
    but i am a "system administrator"
    do i need to be "administrator"
    Matthew Frost
    @mattronix
    think i found a small bug
    if you make a user called api
    you cant browse to the edit page of the user
    Matthew Frost
    @mattronix
    whatever i set i cant view timesheets that are not my own via the api
    Matthew Frost
    @mattronix
    also hitting error after upgrading
    Loading composer repositories with package information
    Installing dependencies from lock file
    Nothing to install or update
    Package zendframework/zend-code is abandoned, you should avoid using it. Use laminas/laminas-code instead.
    Package zendframework/zend-escaper is abandoned, you should avoid using it. Use laminas/laminas-escaper instead.
    Package zendframework/zend-eventmanager is abandoned, you should avoid using it. Use laminas/laminas-eventmanager instead.
    Generating optimized autoload files
    composer/package-versions-deprecated: Generating version class...
    composer/package-versions-deprecated: ...done generating version class
    Executing script cache:clear [KO]
     [KO]
    Script cache:clear returned with error code 255
    !!  Symfony\Component\ErrorHandler\Error\ClassNotFoundError {#77
    !!    #message: """
    !!      Attempted to load class "DoctrineFixturesBundle" from namespace "Doctrine\Bundle\FixturesBundle".\n
    !!      Did you forget a "use" statement for another namespace?
    !!      """
    !!    #code: 0
    !!    #file: "./src/Kernel.php"
    !!    #line: 100
    !!    trace: {
    !!      ./src/Kernel.php:100 {
    !!        App\Kernel->registerBundles()
    !!        › if (isset($envs['all']) || isset($envs[$this->environment])) {
    !!        ›     yield new $class();
    !!        › }
    !!      }
    !!      ./vendor/symfony/http-kernel/Kernel.php:446 { …}
    !!      ./vendor/symfony/http-kernel/Kernel.php:133 { …}
    !!      ./vendor/symfony/framework-bundle/Console/Application.php:169 { …}
    !!      ./vendor/symfony/framework-bundle/Console/Application.php:75 { …}
    !!      ./vendor/symfony/console/Application.php:147 { …}
    !!      ./bin/console:29 { …}
    !!    }
    !!  }
    !!  2020-10-15T18:01:45+02:00 [critical] Uncaught Error: Class 'Doctrine\Bundle\FixturesBundle\DoctrineFixturesBundle' not found
    !!  
    Script @auto-scripts was called via post-install-cmd
    [PRODUCTION]root@web-web:[/var/www/time.uptic.nl]:
    Kevin Papst
    @kevinpapst
    Be careful with mixing APP_ENV=dev and then executing composer install with --no-dev
    Bildschirmfoto 2020-10-15 um 18.17.30.png
    You should carefully read the API descriptions
    Matthew Frost
    @mattronix
    thats funny i dont have that in mine
    i think i am just a version behind
    as i dont even have that permission in my list
    any way i can get rid of that error i did switch back to prod
    Matthew Frost
    @mattronix
    fixed it :)
    image.png
    bingo
    that was the problem
    was on 1.8
    had not realized the API was changed quite a bit so now on newer version :)
    Matthew Frost
    @mattronix
    well
    it works very well
    we automated our invoicing :)
    and tasks for finance department
    Matthew Frost
    @mattronix
    running into issues with the API
    it ignore the start and end time i send
    so it will just give me all records instead of the begin and end that i have set :(
    currently fixing with: if timesheet["begin"][5:7] == start_day_of_prev_month.strftime("%m") and timesheet["end"][5:7] == last_day_of_prev_month.strftime("%m"):
    Kevin Papst
    @kevinpapst
    send me a test link to the demo api that does not work. users and tokens can be found here: https://www.kimai.org/demo/
    Matthew Frost
    @mattronix
    sure :)