Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Mikhail Podgurskiy
@kmmbvnr
Hi, @jonykalavera
Vahid M.
@vahidm
Hi @kmmbvnr , Is there a version with django1.5 compatibility available?
Jorick Spitzen
@jspitzen
@vahidm Don't want to be 'that guy' but you really should upgrade, Django itself doesn't even support 1.5 anymore
Vahid M.
@vahidm
@jspitzen Thanks, you're right and it's already in the backlog :)
@kmmbvnr Nevermide I found it, it's 0.14.0
Mikhail Podgurskiy
@kmmbvnr
To prevent future questions. There is no django-jenkins compatible with django 0.96 Also it was really rock and solid release :satisfied:
Kenneth Kinyanjui
@kenju254
@kmmbvnr do have a documentation page for Django-Jenkins
Mikhail Podgurskiy
@kmmbvnr
@kenju254 all documentation listed in README.
And there are several tutorials available in internet.
Alejandro R. Sedeño
@asedeno
Am I being unreasonable in requesting that the current and future release be tagged in github, given many prior releases are tagged as well?
Mohammad Rafiee
@mrafieee
hi all
I faced a problem with coverage module
can anybody help me
Tyson Clugg
@tysonclugg
@mrafieee +1 from me on that issue!
Glad to see its fixed now...
Update your changelogs!
And tag your releases while you're at it.
nikolas
@nikolas
like some people have noted, django-jenkins 0.18.1 requires coverage >= 4.0. This could specified in setup.py, or we could update the changelog/readme to let people know about this. @kmmbvnr what do you think?
Tyson Clugg
@tysonclugg
@nikolas: Either it works because coverage is specified as an install_requires entry in setup.py - or - the relevant feature/plugin is disabled because you're using pkg_resources.iter_entry_points(group_name) which returns installed requirements as defined in entry_points from your setup.py.
Personally, I'd just add coverage>=4.0 to install_requires in setup.py and be done with it.
Mikhail Podgurskiy
@kmmbvnr
Coverage is optional requirement for Django-Jenkins.
I am hink error message on coverage version mismatch is already descriptive enough hhttps://github.com/kmmbvnr/django-jenkins/blob/master/django_jenkins/tasks/with_coverage.py#L12
Jasonparrish
@Jasonparrish

May be a stupid question (I haven't gone through the chat history).

but can I use django jenkins for commenting style violations (via pep8) to github from jenkins?

Mikhail Podgurskiy
@kmmbvnr
djangojenkins just make a report for jenkins cobertura plugin
Łukasz Neumann
@fuine
Hello, is there any way to use --enable-coverage with --parallel flag? Currently it looks like enabling parallel tests results in falsely low coverage statistics (I think that coverage.xml gets overwritten by the last thread to finish). I found #8 but I'm not sure if it describes my problem. Can you elaborate @kmmbvnr ?
Mikhail Podgurskiy
@kmmbvnr
yep, parallel execution is not supported
José L. Patiño
@jose-lpa
Hello. Just want to ask if there are any plans to continue maintaining Django-Jenkins repo. It seems it has been abandoned for a while, and there are a couple of issues few PRs have been waiting for at least more than 1 year. Would be nice to know what happened with the repo, and help the author to maintain if needed. Thanks :)
mateuszz0000
@mateuszz0000
Helllo is there anybody? I have a simple question :)