Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Giacomo Ciarlini
    @clone95
    Hi I cloned the repo to my local disk on my windows machine (I have only 1 disk). By the way now I check the permission thing, thanks for the support, I'll keep you posted. Is this the right place?
    Giacomo Ciarlini
    @clone95
    Following ( docker-library/rabbitmq#171 ) I changed from /var/lib/rabbitmq ---> /var/lib/rabbitmq/mnesia, and now it's not lamenting anymore that issue.

    Now it tells me

    rabbitmqlost | 2019-10-29 09:02:26.326 [info] <0.985.0> connection <0.985.0> (172.20.0.4:34330 -> 172.20.0.3:5672): user 'guest' authenticated and granted access to vhost '/'
    rabbitmqlost | 2019-10-29 09:02:26.352 [info] <0.1001.0> accepting AMQP connection <0.1001.0> (172.20.0.5:53722 -> 172.20.0.3:5672)
    rabbitmqlost | 2019-10-29 09:02:26.355 [info] <0.1001.0> connection <0.1001.0> (172.20.0.5:53722 -> 172.20.0.3:5672): user 'guest' authenticated and granted access to vhost '/'
    rabbitmqlost | 2019-10-29 09:05:08.020 [error] <0.813.0> closing AMQP connection <0.813.0> (172.20.0.4:34306 -> 172.20.0.3:5672):
    rabbitmqlost | missed heartbeats from client, timeout: 60s
    rabbitmqlost | 2019-10-29 09:05:16.634 [error] <0.889.0> closing AMQP connection <0.889.0> (172.20.0.5:53706 -> 172.20.0.3:5672):
    rabbitmqlost | missed heartbeats from client, timeout:

    I'm doing everything with admin rights.
    gereonreus
    @gereonreus

    Hi @clone95

    Thank you for the info and sorry for the late reply.

    Interesting that windows requires a different mounting point.
    With a new and fresh installation under windows I could now also cause the error you described at the beginning.
    With the change of the mounting folder of /var/lib/rabbitmq ---> /var/lib/rabbitmq/mnesia
    it worked for me with windows.

    I can't explain that it still doesn't work for you, because I can't cause this error anymore.
    However, it might help to delete all docker containers (especially the rabbitmq container).
    Alternatively, you can try to reinstall the entire LOST installation (but you can keep the docker container images).
    Please keep in mind that in .docker-compose.yml the mounting point is the correction you suggested in the rabbitmq container.

    This will be further investigated in the coming days.

    It would be nice if you could create an issue on Github.

    Thank you very much and best regards,
    Gereon

    yc10086
    @yc10086
    Hi, I'm trying to install from the Docker on Windows 10,but I'm having a problem: db-lost: forward host lookup failed: Unknown host,and This line appears repeatedly。
    gereonreus
    @gereonreus

    Hello @yc10086,

    The message you described means that the container with the database (db-lost) was obviously not started.
    In Windows, Docker specifically asks for a file share for each container when, for example, docker-compose up starts all containers.
    Maybe you missed one of these messages ? This should appear three times (for each container separately).

    If one of the containers doesn't get a share, it can't start. So the whole application cannot be started.

    Best regards,
    Gereon

    yc10086
    @yc10086
    @gereonreus I am confused, then how can I let the container share to solve this problem. Looking forward to your reply, I am bothering you.
    Muhammed Mazen Hafez
    @mh-mazen
    hi all i wanna integrate this tool into my web app , can i do so and how? i am fairly new to dockers and containers and don't see a way to make modifications on the system itself any help would be great
    glemarivero
    @glemarivero
    hello
    I'm unable to start one of the predefined pipelines...not sure why, but after setting the file name it says that the argument is still missing
    Arguments available
    I'm running the quick_setup docker
    Thanks in advance
    :-)
    glemarivero
    @glemarivero
    ah sorry, my bad, now I understand that I didn't go through all the required steps..as you go through the definition of each step the header turn green when it is valid
    glemarivero
    @glemarivero
    what is the suggested way for an annotator to reviews its annotations?
    gereonreus
    @gereonreus

    Hello @yc10086,

    unfortunately I have little experience with Docker on Windows.
    When I installed Docker with Windows, I remember that Docker explicitly asked me to do this when I started the container.

    Here is a guide on how to share your Windows drives with Docker Containers:
    https://token2shell.com/howto/docker/sharing-windows-folders-with-containers/

    Best regards,
    Gereon

    Hello @mh-mazen

    Integration without a docker becomes very difficult.
    Please describe your problem in detail.

    Thank you and best regards,
    Gereon

    gereonreus
    @gereonreus

    @glemarivero

    Hello

    In SIA, you can scroll back and forth through your annotations as long as the annotation task has not been completed and further processed by the pipeline.

    Since version 1.0.0 you can also undo your last annotations in MIA (within a browser session).
    However, this feature cannot really be used for a review function.

    If you want to review the annotations of e.g. another person, then it is recommended to write a pipeline, which consists of two annotation tasks and whose annotations are then merged in a following script (with own logic).

    How to create your own pipelines and scripts is described here:
    https://lost.readthedocs.io/en/latest/all_about_pipelines.html

    In addition, a review tool is planned for SIA, which will allow you to filter for annotations with specific properties.

    Best regards,
    Gereon

    glemarivero
    @glemarivero

    Hi,
    Sometimes we have two different types of labels we want our annotators to annotate. For example, given a face, we would like to label its shape, but also its tone. So I created one label that is called Face that has two children (Tone and Shape) and each of them have n and m labels associated. Is there a way to perform both labeling at the same time? I thought about using multi-label pipeline, but that could potentially allow to have two different types of shapes at the same type for example.
    So ideally what I'm looking for is to have two dropdown menus, one for each set of labels.
    Finally, when do you plan on adding the review tool that would allow us to filter?

    Thanks!

    PawanKuma
    @PawanKuma
    Hi, i am following the guidlines o run docker but when i run docker-compose up following error is thrown
    ERROR: Couldn't connect to Docker daemon - you might need to run docker-machine start default
    i am using ubuntu 16 ,
    gereonreus
    @gereonreus

    @PawanKuma
    This might happen if your linux user in not part of the docker group.
    Try

    sudo adduser mylinuxuser docker

    After adding user to group, renew group:

    newgrp docker

    Best regards,
    Gereon

    KonradAdamczyk
    @KonradAdamczyk
    Hi,
    I am upgrading from LOST version 0.0.6 to LOST version 1.1.0, how can do that while preserving ~/lost/data folder with previous tasks, etc ?
    Currently I'm getting:
    Original exception was: (_mysql_exceptions.OperationalError) (1054, "Unknown column 'is_junk' in 'field list'") [SQL:
    'INSERT INTO image_anno (anno_task_id, timestamp, timestamp_lock, state, sim_class, frame_n, video_path, img_path, result_id, iteration, user_id, anno_time, is_junk, description) VALUES (%s, %s, %s, %s, %s, %s, %s, %s, %s, %s, %s, %s, %s, %s)'] [parameters:
    (570, None, None, 1, 1, None, None, 'data/media/folder/.~lock.images.csv#', 1152, 0, None, None, None, None)] (Background on this error at: http://sqlalche.me/e/e3q8) PipeElementID = 2912
    jaeger-j
    @jaeger-j
    @KonradAdamczyk While moving from LOST 0.x.x to 1.x.x we had some breaking changes in the database model and in the python script API. You could try to manually add the missing columns and tables is the database. In order to see what changed you can use git diff 0.0.6...1.1.0 -- backend/lost/db/model.py. Since we introduced multi-label support in SIA you will also need to adjust your scripts: use git diff 0.0.6...1.1.0 -- backend/lost/pyapi/inout.py to see the changes. Finally you need to adjust your pipeline definition files, especially the SIA config part.
    KonradAdamczyk
    @KonradAdamczyk
    Thanks, that worked for me.
    Could you please tell me how to enable LOST to properly handle UTF-8 chars like chinese or japanese ?
    Tarun Bhatt
    @_Tarun_Bhatt__twitter
    Hi, Can you please tell me the instructions for running the LOST on web server?
    Ryan Porter
    @OblongBurrbank_twitter
    Hey having a weird issue where I can't select anything from the menu on the first stage of pipeline creation. Currently using LOST_VERSION=1.1.4 according to the .env file
    Ryan Porter
    @OblongBurrbank_twitter
    I resolved this a week ago, had something to do with having NFS mounts
    Sagar1094
    @Sagar1094
    Hi, Regarding review, after review the updated annotations would not get populated to the csv file. Is there a way to update csv file with reviewed annotations or make review step mandatory before running the export_csv.py script
    ziyun99
    @ziyun99
    @Sagar1094 hii, i have also been exploring this tool recently. I think if you don't mark the annotation task as done/finished after you have annotated all images, the changes in review will still be updated.
    Good idea to make the review step mandatory, what i can think of is to add a 2nd Annotation Task in the pipeline (after the original Annotation Task ) and assign it to yourself, then you can review / re-annotate the images.
    Not sure if this is really a good approach, but hope it helps :)
    Sagar1094
    @Sagar1094
    That's amazing, this might help me. Thanks a lot
    Sagar1094
    @Sagar1094
    @ziyun99 I tried the above stated solution, the problem I encountered is if I only add a annotation task after my previous annotation task it automatically gets completed, so I added data source before the second annotation task but the problem persists
    I am not sure why it gets triggered and gets finished by itself
    Sagar1094
    @Sagar1094
    Update, after adding the get_anno script the above stated solution works fine, but the problem is i dont know how to retrieve images from the database to update them
    Sagar1094
    @Sagar1094
    Hi, I am having trouble with verification step, I am trying to verify over 900 images and always around 120 images it says timeout, I am not able to jump between images and have to start from very start. Its quite frustrating is there any way to review annotations without getting logged off and starting from scratch all the time?
    sathyan sethumadhavan
    @satnair
    Hi there. Got a question. we are evaluating lost for a labelling solution. we have all the datasets in MinIO and access it via Object storage. Is there ways to access via MinIO or S3 related api's
    We can't copy it to any location due to security constraints
    shruthidipali
    @shruthidipali
    Hi, is there any support for oauth integration?
    jaeger-j
    @jaeger-j

    Hi there. Got a question. we are evaluating lost for a labelling solution. we have all the datasets in MinIO and access it via Object storage. Is there ways to access via MinIO or S3 related api's

    Hi @satnair I am not into MinIO, but if you can mount your datasets/images into the lost filesystem it should work. In order to do that you need to adjust the docker-compose.yml -> under volumes -> add your mount point: my_mount_point_on_host_system:/home/lost/data/media/my_datasets

    1 reply

    Hi, is there any support for oauth integration?

    HI @shruthidipali oauth integration is currently not supported

    sathyan sethumadhavan
    @satnair
    Hi one more question.......We want to add a textbox to capture the actual value of the ROI...in addition to the label for ROI...any quick suggestion how to do this
    Ryan
    @burrbank
    Hey, one of my annotators was wondering if there was a way to extend the time that they stay logged into LOST, anything that would enable that?
    pepijnob
    @pepijnob
    Hi, I was wondering if there is an easy way in SIA to have annotations(e.g. bounding boxes) already loaded it from a csv or xml file? (as a suggestion)
    jaeger-j
    @jaeger-j

    Hi one more question.......We want to add a textbox to capture the actual value of the ROI...in addition to the label for ROI...any quick suggestion how to do this

    Hi @satnair, Unfortunately, there is no quick fix for this... We need to adjust SIA here ... Could you write a feature request on GitHub

    Hey, one of my annotators was wondering if there was a way to extend the time that they stay logged into LOST, anything that would enable that?

    Hi @burrbank, in the .env config file you can add SESSION_TIMEOUT=x, where x is the time in minutes, until an inactive annotator get automatically logged out

    jaeger-j
    @jaeger-j

    Hi, I was wondering if there is an easy way in SIA to have annotations(e.g. bounding boxes) already loaded it from a csv or xml file? (as a suggestion)

    Hi @pepijnob, you can write a pipeline, with a custom script that will read your annotations and requests these annotations for a SIA task.